Mobile menu

"Cannot find source language in source ini file"+ Wordfast
Thread poster: esmeraldarl
esmeraldarl
Local time: 18:22
English to Spanish
+ ...
Jun 1, 2004

After aligning two texts with wordfast, I try to create the TM, but this message appears "cannot find source language in source ini file".

What's wrong?

Help please!!

Thank you!

Esmeralda


Direct link Reply with quote
 
xxx00000000
English to French
+ ...
Wordfast Groups Jun 2, 2004

Hello Esmeralda --

Anybody using Wordfast should really join at least one mailing list. The English one is mostly for advanced users who have read the manual, but there is a friendly Spanish one. If you can communicate in French, that's probably your best bet.

http://www.wordfast.net/index.php?whichpage=community〈=engb

About your present problem, I haven't aligned with Ptools in a while but your problem seems to be that you haven't created a TM in Wordfast. Click New TM and you will be prompted for the languages. When you're done and you've saved this new TM, your wordfast.ini will have properly identified languages.

Best,
Esther

[Edited at 2004-06-03 17:41]


Direct link Reply with quote
 
esmeraldarl
Local time: 18:22
English to Spanish
+ ...
TOPIC STARTER
I tried it again, but it didn't function, again Jun 2, 2004

Tank you Esther for your answer.

I did create a TM as per manual, but it didn´t function

I don't know what's the matter, and I'm going crazy.

Once again, thank you.

Esmeralda


Direct link Reply with quote
 
xxx00000000
English to French
+ ...
Don't waste your time with PTools Jun 3, 2004

Hi Esmeralda --

Even long-time, knowledgeable users of Wordfast prefer other tools for aligning. Get on some mailing lists to find out about it. I can't help you here, because I have Trados and SDLX, but as I subscribe to the French, Spanish and Portuguese lists, I often see discussions about aligning. There are apparently some good tools out there, several of them free.

Best,
Esther


Direct link Reply with quote
 

Simon Mountifield  Identity Verified
Local time: 18:22
French to English
TMs and setup files Jun 3, 2004

Hello Esmeralda,

Have you tried creating two different setup files (such as spanish.ini and english.ini) with a different source language for both (such as ES-ES for the Spanish one and EN-GB for English one)? When it asks you for the target language, you can put anything in - I think the important bit is to have a different source language for both setup files. You will also need to create a different TM for each setup file (again, you can put anything in, as the TMs will not actually be used).

Now when you go to PlusTools, select the Align tab and specify the two different setup files, and with a bit of luck, it should work (fingers crossed).

Let me know how you get on.

Kind regards,

Simon


Direct link Reply with quote
 
esmeraldarl
Local time: 18:22
English to Spanish
+ ...
TOPIC STARTER
Thank you, but it didn't function Jun 3, 2004

Now when you go to PlusTools, select the Align tab and specify the two different setup files, and with a bit of luck, it should work (fingers crossed).

I'm going crazy. I'm following the manual to the letter, but it seems "too difficult" for me and I cannot create the TM.

I'll try it again, again, again, again......


Direct link Reply with quote
 

Simon Mountifield  Identity Verified
Local time: 18:22
French to English
Another idea Jun 4, 2004

Hi,

Don't despair!

One way of checking that your version of Wordfast is working properly and/or that your setup files are OK, is for you to send me your two setup (.ini) files. That way, I'll check them with my Wordfast version (sbm_2@club-internet.fr)

If that fails, I'll go through the setup process on my system and I'll write down every step of what I did so that you can see how I did it (I must admit that some parts of the Wordfast / PlusTools manuals are not terribly user-friendly).

Simon


Direct link Reply with quote
 
esmeraldarl
Local time: 18:22
English to Spanish
+ ...
TOPIC STARTER
My ini.files have gone!! Jun 4, 2004

Supersim wrote:

One way of checking that your version of Wordfast is working properly and/or that your setup files are OK, is for you to send me your two setup (.ini) files. That way, I'll check them with my Wordfast version (sbm_2@club-internet.fr)

Simon


Hello Simon,

I have searched my computer looking for my ini.files and there are not ini.files anywhere. If I run wordfast, they "appear" in the menu with the wordfast.ini, but they are not in my computer.

Moreover, I tried to uninstall wordfast in order to install it again, and because of not having the wordfast.ini, I cannot uninstall it!

Some ideas?

Thankyou,

Esmeralda


Direct link Reply with quote
 

Simon Mountifield  Identity Verified
Local time: 18:22
French to English
My alignment procedure Jun 7, 2004

Hello Esmeralda,

To uninstall Wordfast, I think you may need to remove the .dot file from Word's startup directory.

Anyhow, I had a bit of aligning to do this morning, so I made a note of how I did it. Hopefully, it will work for you as well:

1. Create two directories – Source and Target. Place COPIES of the source files to be aligned in the Source directory and then COPIES of the corresponding target files to be aligned in the Target directory (make sure you use copies, as PlusTools converts them into another format).

2. Open Wordfast and go to the Setup tab. In the Gen section, click on the "Save setup as" button and enter the source language name (i.e. Spanish).

3. Go to the Translation memory tab. In the Files section, click on "New TM". Enter the language codes (such as ES-ES for the source and EN-GB for the target) and save the TM as align1 (it's important to get the language codes right).

4. Now go to the Gen section of the Setup tab and click on "Save setup as". This time, enter the target language name (i.e. English).

5. Go to the Translation memory tab. In the Files section, click on "New TM". Enter the language codes (such as EN-GB for the source and ES-ES for the target) and save the TM as align2.

6. Now close any documents and open PlusTools. Go to the Align tab. In "Wordfast setup to segment source files", pick your source setup file (i.e. spanish.ini) and in "Wordfast setup to segment target file", pick your target setup file (i.e. english.ini).

7. Then under Source files (note the language codes given in brackets), select the Source directory that you created (your source files to be aligned should appear). Then do likewise for the target files (Target directory).

8. When you've done that, click on "Extract". Click on OK when it says about converting to text files.

9. When the extraction process is finished, you'll end up with PlusTools again and the files in text format in the Source and Target windows. Now click on Align. Afterwards, you'll end up with two documents side by side or a 2-column table, depending on the option you selected.

10. After aligning, leave the document open, start PlusTools, go to the Align tab and click on Create TM. PlusTools creates the TM and you are then prompted to save it as a text file – give it the appropriate name and that's all there is to it!

I hope it will work for you.

Regards,

Simon


Direct link Reply with quote
 

Bilingualduo  Identity Verified
Italy
Local time: 18:22
English to Italian
+ ...
What version of +Tools and WF are you using? Jun 8, 2004

The problem you have was a known issue, but is it said to have been resolved with the latest version of +Tools running with the right WF version.

HTH
Bambi


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"Cannot find source language in source ini file"+ Wordfast

Advanced search


Translation news related to CAT tools





CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs