Mobile menu

Trados 5.0, Dejavu 3.0.21, Wordfast 3.35i : Chinese character problems
Thread poster: mrchan
mrchan
Local time: 16:33
Malay to Chinese
+ ...
May 3, 2002

I am new to translation memory tools. All following problems are related to Chinese language input/display. Experienced user please help solving my problems.



1. Trados 5.0 Freelance, English trial version -



a) In Tag-editor, I can input english character only but not Chinese character. I am using WindowsXP with Chinese(PRC) as non-unicode language setting. I am using Microsoft Global IME tool and other programs to input Chinese character. I just able to enter a space-occupied but blank character. Why ? What\'s wrong with me ? Please help.



b) In WordXP English version, I \'Open \' a phrase, translate it, \'Close\' it. The resultant Chinese characters appreared to be invalid characters. Why ? What\'s wrong with me ? Please help.



2. DejaVu 3.0.23, English trial version - I am using WindowsXP with Chinese(PRC) as non-unicode language setting. I finish the translation into Chinese chracters, save as WordXP format. Later, open the file using WordXP English version, invalid characters appear. Why ? What\'s wrong with me ? Please help.



3. WordFast 3.35i, English freeware - I am using WindowsXP with Chinese(PRC) as non-unicode language setting. In WordXP English version, WordFast not even start ! It gives \"Compile error in hidden module : rousette\". Later I change the non-unicode language setting back to English (US). WordFast works again ! Anyone successfully launch WordFast in WordXP English version using WindowsXP with Chinese(PRC) or other asian languages as non-unicode language setting ? Please share your opinios.


Direct link Reply with quote
 
Libin PhD  Identity Verified
Chinese to English
+ ...
May 4, 2002

Quote:


On 2002-05-03 18:41, mrchan wrote:

I am new to translation memory tools. All following problems are related to Chinese language input/display. Experienced user please help solving my problems.



1. Trados 5.0 Freelance, English trial version -



a) In Tag-editor, I can input english character only but not Chinese character. I am using WindowsXP with Chinese(PRC) as non-unicode language setting. I am using Microsoft Global IME tool and other programs to input Chinese character. I just able to enter a space-occupied but blank character. Why ? What\'s wrong with me ? Please help.



b) In WordXP English version, I \'Open \' a phrase, translate it, \'Close\' it. The resultant Chinese characters appreared to be invalid characters. Why ? What\'s wrong with me ? Please help.



2. DejaVu 3.0.23, English trial version - I am using WindowsXP with Chinese(PRC) as non-unicode language setting. I finish the translation into Chinese chracters, save as WordXP format. Later, open the file using WordXP English version, invalid characters appear. Why ? What\'s wrong with me ? Please help.



3. WordFast 3.35i, English freeware - I am using WindowsXP with Chinese(PRC) as non-unicode language setting. In WordXP English version, WordFast not even start ! It gives \"Compile error in hidden module : rousette\". Later I change the non-unicode language setting back to English (US). WordFast works again ! Anyone successfully launch WordFast in WordXP English version using WindowsXP with Chinese(PRC) or other asian languages as non-unicode language setting ? Please share your opinios.





With Trados, go back to your TM setup and check if you have selected 宋体 as the default fonts. You should have your TM open without reading in a source fragment. Then go to File>Setup, it will bring you to the set up dislogs. Also, select a few common English fonts as the source font, such as Time New Roman, Aril, Courier, etc and select 宋体 as the target font for all the source fonts. That probably should solve the display problem.



With DejaVu, I have not use that product although I bought a full version last November at the ATA Los Angeles Annual Meeting. When you create a new TM, all these programs ask you to make some selections of the fonts, fragmentation rules, penalty rules, measurement, time and date conventions, etc. You need to make the right selection to make it work.



I have been using TRADOS for many years and have not used Wordfast, either, although I downloaded a copy, thinking sometime I might need it for freelancers who work with me. Cannot help you here.



Bin





Direct link Reply with quote
 
mrchan
Local time: 16:33
Malay to Chinese
+ ...
TOPIC STARTER
> Li Bin : Thank you May 4, 2002

Thanks Li Bin for solving my problem in 1(a). I follow your instructions and I am able to input/display Chinese character within \"TagEditor\" flawlessly now.



But the problem about the integration of my Trados Freelance 5.0 Freelance with WordXP (case 1b) still remain unsolved. The resultant Chinese characters after Trados actions [\"Open\" > translate > \"Close\"] are still invalid codes, even I apply changes towards font-setting instructed by Li Bin in the TM.



DejaVu : Works with HTML, Plain text ... is ok. But it seems non-compatible with WordXP yet [Chinese Characters Display] ?



WordFast : I\'d contacted the author Mr. Champallion about the integration of WordFast 3.35i with WordXP [Chinese as non-unicode system language setting]. He said he never noticed this problem yet, but reveiced similar inquiries regarding the asian languages. I hope the next version of WordFast would solve this minor problem soon.


Direct link Reply with quote
 
Libin PhD  Identity Verified
Chinese to English
+ ...
May 5, 2002

Quote:


On 2002-05-04 08:47, mrchan wrote:

Thanks Li Bin for solving my problem in 1(a). I follow your instructions and I am able to input/display Chinese character within \"TagEditor\" flawlessly now.



But the problem about the integration of my Trados Freelance 5.0 Freelance with WordXP (case 1b) still remain unsolved. The resultant Chinese characters after Trados actions [\"Open\" > translate > \"Close\"] are still invalid codes, even I apply changes towards font-setting instructed by Li Bin in the TM.



DejaVu : Works with HTML, Plain text ... is ok. But it seems non-compatible with WordXP yet [Chinese Characters Display] ?



WordFast : I\'d contacted the author Mr. Champallion about the integration of WordFast 3.35i with WordXP [Chinese as non-unicode system language setting]. He said he never noticed this problem yet, but reveiced similar inquiries regarding the asian languages. I hope the next version of WordFast would solve this minor problem soon.







To solve the Trados-Word integration issue, please first go to C:\\Program Files\\TRADOS\\T5_FL\\TT\\Templates\\,



Copy the Word template TRADOS5.DOT file to the following folder:



C:\\Document and Settings\\Your user name (LIBIN in my case)\\Application Data\\Microsoft\\Word\\STARTUP



Alternatively, go to Word menu Tools > Templates and Plug-ins. A dialog box will appear. Click Add and navigate to C:\\Program Files\\TRADOS\\T5_FL\\TT\\Templates\\. Then select TRADOS5.dot and click OK.



Then you will see the TRADOS toolbar appear in Word.





Trados 5.0 does not claim full sopport to Word XP but TRADOS 5.5 does. However, before version 5.5 came out, I had been using version 5.0 with Word XP all the time. Most of the common functions are sopported in Word XP. Some new functions in Word XP, such as Smart Tags, are not sopported, of course.



Please try this out and let me know if that solves your problem.





[ This Message was edited by: on 2002-05-05 15:25 ]

[ This Message was edited by: on 2002-05-05 17:14 ]

Direct link Reply with quote
 
mrchan
Local time: 16:33
Malay to Chinese
+ ...
TOPIC STARTER
> Li Bin : Kindly open the URL I attached ... May 6, 2002

The Trados bar is in my WordXP while I\'m installing it. Thanks for your guidance. You make me just realize that in WindowsXP, the \"C:\\Documents and Settings\\xxx\\Application Data\" is a hidden folder, where \'xxx\' can be any user name.



However, my problem still unsolved : the Chinese character display problem during the integration of WordXP and Trados.





Please kindly open this URL :

-------------------------------------

\"http://cttc.hotusa.org/proz/q1.html\"

-------------------------------------

[I captured a few shots of the real process, about my Trados\'s Chinese character display problem in WordXP.]





Bother you again or anyone who can help me.





p/s : By the way, does the language version of WordXP affecting this problem in this case ? My WordXP is english version, I saw another Chinese-Simplified version of Microsoft Office sold at my place (Malaysia).


Direct link Reply with quote
 
Libin PhD  Identity Verified
Chinese to English
+ ...
May 6, 2002

Quote:


On 2002-05-06 09:53, mrchan wrote:

The Trados bar is in my WordXP while I\'m installing it. Thanks for your guidance. You make me just realize that in WindowsXP, the \"C:\\Documents and Settings\\xxx\\Application Data\" is a hidden folder, where \'xxx\' can be any user name.



However, my problem still unsolved : the Chinese character display problem during the integration of WordXP and Trados.





Please kindly open this URL :

-------------------------------------

\"http://cttc.hotusa.org/proz/q1.html\"

-------------------------------------

[I captured a few shots of the real process, about my Trados\'s Chinese character display problem in WordXP.]





Bother you again or anyone who can help me.





p/s : By the way, does the language version of WordXP affecting this problem in this case ? My WordXP is english version, I saw another Chinese-Simplified version of Microsoft Office sold at my place (Malaysia).





1. To unhide the folders, open Windows Explorer and go to Tools > Folder Options and select the View tab. Then check \"Show hidden files and folders\" and uncheck \"Hide extensions for know file types\" but keep the \"Hide protected operating system files (Recommended)\" checked so that you will not inadvertently do anything wrong with those files.



After that, most files will be visible.



English Windows XP is fine as that is what I am using. Try to check the following:

(1) Go to Start > Programs > Microsoft Office Tools > Microsoft Office XP Language Settings and make sure that Chinese (Simplified) is Enabled (appear in the right column).



(2) Open a blank Word XP file and go to Format > Font and make sure Asian Text font is 宋体 and Latin Text Font is Times New Roman or something you prefer. Then click on the \"Default...\" button at the lower left corner of dialog box to make this font setting default for all new files.



Open and TM in WorkBench and go to File > Setup > Fonts and make sure you also check \"Translate into target default for all other fonts\" assuming that you have set 宋体 as the \"Target Default Font\".



Try these out and see if it works. I think it should as long you are using Windows XP and Office XP and you installed Asian Language support when you installed your Windows.



Bin

Direct link Reply with quote
 
Libin PhD  Identity Verified
Chinese to English
+ ...
I cannot view your screen shots May 6, 2002

By the way, I copied the URL you provided but can only see five picture placeholders, not the picture themselves.

Direct link Reply with quote
 
Libin PhD  Identity Verified
Chinese to English
+ ...
Now I can see the pictures May 6, 2002

I think the problem is with font setting in Word XP. The 引擎 in the second picture is not in 宋体. You can verify this by inserting the cursor between the two characters and loot at the format toolbar and see what font they are in. They look like \"system\" font.



You need to go to Word Format > Font and set 宋体 as the default for Asian Text font. From this point on, all new file created from Word will have the default. However, when you receive a file from a client, the default font might still be something else. You need to do a Select All and go to Format > Font and change Asian Text font to 宋体. This will ensure that any Chinese text you type in this file will be displayed in 宋体.



Sometime, if you copy the original text to the Target text field, The font from the target text will also be copied. When you type in Chinese, check the font and see if it is 宋体. If it is still in Times New Roman, it will not be correctly displayed after you hit the Close button on TRADOS toolbar.



In this case, before you hit the Close button, you need to first select the Chinese text in the target field that is in Times New Roman font and change it to 宋体. Then you will be OK.



Bin

[ This Message was edited by: on 2002-05-06 21:20 ]


Direct link Reply with quote
 
mrchan
Local time: 16:33
Malay to Chinese
+ ...
TOPIC STARTER
> Li Bin : Please revisit the URL May 6, 2002

I confirm all settings are OK (follow your suggestion) in both WordXP and Trados Translator\'s Workbench.



Problem still exists ...



My WordXP has multilanguage support, this minor problem of unusual Chinese text display error is probably due to the integration with Trados 5 Freelance)



For a clearer picture ,



Please kindly open this URL: (again)

-------------------------------------

\"http://cttc.hotusa.org/proz/q1.html\"

-------------------------------------

[I captured a few shots of the real process, about my Trados\'s Chinese character display problem in WordXP.]


Direct link Reply with quote
 
Libin PhD  Identity Verified
Chinese to English
+ ...
What is the font in the target field between those strange characters? May 7, 2002

What is the font in the target field between those strange characters?



We need to find out what is the font there. I assume you used the TM to get those characters. If you did, it is becasue when TRADOS save this segment, your font setup for that TM was not correct.



To test if I am right or wrong, please enter two different words, say China, then type 中国,and click the number 6 (Set/close read new segment) or Number 8 (Set/Close) button from the left. Set/Close just enter this segment into TM and close it.



If it still does not work, close the current TM and create a new TM and do it again.



When you create the new TM, make sure you select English as Source Language and Chinese as Target language. Then click Create...button and give the TM a new file name. Then come back to Setup to set the fonts for source and target text.



Than try again.



Please let me know.



Bin





Direct link Reply with quote
 
mrchan
Local time: 16:33
Malay to Chinese
+ ...
TOPIC STARTER
> Li Bin : Almost solved ! May 8, 2002

Regards to > \"http://cttc.hotusa.org/proz/q1.html\"



Yes, you are right. I found that the \"引擎\" is not \"宋体\".



(a) When I manually change it to \"宋体\". After press the \"Set/Close\" button of Trados Toolbar. The font appear to be correct ! ... but



(b) When I press \"Open\" again, the Chinese text become invalid code again.



(c) Just after step (a). Although the text is now a valid Chinese character. But I found it is in Latin font again (eg. Times, Arial ... which follow the pre-translate english font face). So If I manually change it to \"宋体\" and I press \"Open\" again, the Chinese is valid code !



Though this problem is almost solved, but this manual-change-font steps increase my work-load. So, any suggestion to solve this manual-change-font problem ? Do I need to modify the \"Trados5.dot\" template file ? (modify the formatting / style ...)



[I have set \"宋体\" as default asian font in WordXP]



Anyone, please help and drop your opinions ...


Direct link Reply with quote
 
Libin PhD  Identity Verified
Chinese to English
+ ...
May 8, 2002

Quote:


On 2002-05-08 05:43, mrchan wrote:

Regards to > \"http://cttc.hotusa.org/proz/q1.html\"



Yes, you are right. I found that the \"引擎\" is not \"宋体\".



(a) When I manually change it to \"宋体\". After press the \"Set/Close\" button of Trados Toolbar. The font appear to be correct ! ... but



(b) When I press \"Open\" again, the Chinese text become invalid code again.



(c) Just after step (a). Although the text is now a valid Chinese character. But I found it is in Latin font again (eg. Times, Arial ... which follow the pre-translate english font face). So If I manually change it to \"宋体\" and I press \"Open\" again, the Chinese is valid code !



Though this problem is almost solved, but this manual-change-font steps increase my work-load. So, any suggestion to solve this manual-change-font problem ? Do I need to modify the \"Trados5.dot\" template file ? (modify the formatting / style ...)



[I have set \"宋体\" as default asian font in WordXP]



Anyone, please help and drop your opinions ...







I have send you an email asking you to reply to it so that I can send you some test files.



When you receive the test, please follow the procedure given below to do the test. I put it here for the benefit of other people who might be following this thread.





I will be sending you a TM file (test.tmw, including 4 other files with test as the file name and different file extensions) and a Word file test.doc. Although it is not necessary to include the other four files for the TM, I include them anyway as they are small.





Test Procedures:



1. Unzip my file on your desktop, all files are in a folder called Trados Test.



2. Launch TRADOS.



3. Go to File > Close and close current TM.



4. Go to File > Open and navigate to Desktop/Trados Test folder and select the TM file test.tmw.



5. Click on the Word file test.doc and open it. Save this file as test1.doc. There are three sentences in the file. I have translated the first two sentences and leave one untranslated for you to try yourself.



6. Put the cursor at the very beginning of the first sentence and click open on Trados Toolbar. In Trados, the source should read \"This is a test.\" and the Target should be \"这是一个测试。\"



7. Click on the 6th button on Trados Tool bar, which is \"Set/Close next Open/Get\"

It will close the previous sentence and save it to TM and open the next sentence.



8. Then the second sentence should appear in Trados with the source being \"China\'s economy is growing.\" and the target \"中国的经济正在增长。\"The above two sentences are what I have translated with Trados and both source and target are saved in the TM file test.tmw.



9. Now hit \"Set/Close next Open/Get\" again, Trados should read in the last sentence in the Word file, which is \"Please translate this sentence yourself using Trados.\"



10. Just translate this sentence in the target filed and Click on Close, which is the 8th button on the Trados toolbar, as there is no more sentences to read in.



11. Save test1.doc and close it.



12. Open test.doc again and save it as test2.doc.



13. Start with cursor at the beginning of the first sentence and click Open (1st button on Trados toolbar). This should bring up the translated sentence. in both source and target area in Trados.



14. Click \"Get Translation\" (the 3rd button on Trados Toolbar). \"这是一个测试。\" should appear in the target field in the Word file. Click \"Set/Close next Open/Get\" to close this sentence and read in the second sentence.



15. Repeat Step 14 with the third sentence and see if your own translation will show up. If it show up, everything is fine.



Then the reason your file was not working could be two-folds: a. Your Word file was created before you send the default font 宋体 for Chinese text; b. You did the translation of 引擎 before you set up the target fonts correctly in the TM you are using and 引擎 was not saved in 宋体 in the TM. Therefore, when you get it into Word, it uses whatever font it was saved with before you correctly set up the target fonts in the TM, which of course is not 宋体.



Bin

[ This Message was edited by: on 2002-05-08 10:24 ]

[ This Message was edited by: on 2002-05-08 10:43 ]

Direct link Reply with quote
 
mrchan
Local time: 16:33
Malay to Chinese
+ ...
TOPIC STARTER
> Li Bin May 10, 2002

I format my partition and reinstall WindowsXP and OfficeXP.

Trados5 works fine now.

Thank you so much helping me to solve all major and minor doubts.



[Thread closed]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 5.0, Dejavu 3.0.21, Wordfast 3.35i : Chinese character problems

Advanced search






WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
TMreserve
Wake up in the Morning and see that you have sold TMs and made Money overnight



The TM Market Place for Translators
New: Our Instant TM Download
TM owners: Upload your TMs into the online database
Customers: Analyse your text & instantly download a text-specific TM
Well over 1.2 BILLION translation units

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs