Thunderbird (1.5.0.8) Character Encoding Problem
Thread poster: Patricia Rosas

Patricia Rosas  Identity Verified
United States
Local time: 05:49
Spanish to English
+ ...
Nov 13, 2006

Last Spring, a fellow ProZer asked this and got no reply:
*****************************************
I use Thunderbird. Sometimes when replying to a message it announces, that the message contains characters, which do not fit into the UTF-8. I click ok and off it goes, but I'm curious, since I use only normal skandinavian characters.
And why UTF-8? Shouldn't we rather use 16 bit encoding? Here at ProZ.com they have still difficulties with displaying normal European character sets. Wouldn't 16 bit encoding be much more easy?

Regards
Heinrich
***********************************
I'm having a similar problem that is driving me batty. I searched on Mozilla's technical help pages and "bug reports," but I can't find anything that says how to stop the problem.

Specifically, in my case, it occurs with incoming mail. Under options, I've set the display to Western (ISO-8859-1). But when I boot the program, and open a message, it appears in Unicode-32 Big Endian. On the View menu, I go to "Character Encoding," and I reset to ISO 8859-1. Under the same submenu, I have also gone to auto detect and toggled the choice "universal".

When I open a message, all I get are question marks. When I go to view and then to character encoding, a menu opens that shows that the character set is Unicode UTF-832 big endian.

I don't know where this UTF-832 comes from, but it seems capable of overriding the Western ISO character set.

Perhaps somebody else has had this problem and can give me some help. THANKS!


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 15:49
Member (2003)
Finnish to German
+ ...
Still the same Nov 14, 2006

Hi Patricia, I didn't remember anymore I wrote that. But the same problem consists. After start thunderbird behaves quite normally, but after a while it gets the flu and sees unicode everywhere.

Regards
Heinrich


Direct link Reply with quote
 

Natalie  Identity Verified
Poland
Local time: 14:49
Member (2002)
English to Russian
+ ...

MODERATOR
Hi Patricia and Heinrich Nov 14, 2006

I have never had such problems with Thinderbird, though I have rather complicated settings (different folders are set to different ecodings).

First of all you should go to to View > Character encoding > Autodetect, and turn autodetection OFF.

Second, right-click at the desired folder (for example, inbox), choose Properties > Default character encoding, and set the desired encoding. Repeat with all folders. DO NOT check the box "Apply default to all messages in folder".

Natalia


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 15:49
Member (2003)
Finnish to German
+ ...
Properties? Nov 14, 2006

Which menu is that from left to right.
Thanks for your hints, Natalie!
Regards
Heinrich

Found it. But the settings were ok already.

[Bearbeitet am 2006-11-14 16:37]


Direct link Reply with quote
 

Patricia Rosas  Identity Verified
United States
Local time: 05:49
Spanish to English
+ ...
TOPIC STARTER
Seems to do the trick Nov 14, 2006

Natalie,
Thanks for answering! I changed the settings per your instructions in two folders, and tested it, and it seems to solve the problem. Yippee! Of course, I have a zillion folders, so it seems like a flaw in the otherwise good Thunderbird.

Hope your instructions help Heinrich out, too.
Best,
Patricia


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Thunderbird (1.5.0.8) Character Encoding Problem

Advanced search






Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums