Mobile menu

MemoQ 3.0.34 & Word 2000
Thread poster: Ansi
Ansi
United Kingdom
Local time: 11:06
English to German
Dec 5, 2008

I am just trying out MemoQ and though I'm impressed and find it easy to handle I'm having constant trouble to make it work with Word version 2000 properly.

First thing I noticed is that it can't create the preview (can live without).

Then it almost always crashes Word when importing, once so heavily Word wouldn't start up again until I had replaced my Normal.dot. My guess is it uses some unorthodox method (probably by injecting a macro module) to access Word. I thought it would need Word only to convert to/from RTF but even when I import RTF files this happens (rather odd).

Anyone had similar experiences? Is this confined to Word 2000 (or just my installation)?


Direct link Reply with quote
 

Effie Emmanouilidou  Identity Verified
Greece
Local time: 13:06
English to Greek
You can find help at MemoQ Yahoo group Dec 5, 2008

Hello Ansi,

I found the following at the MemoQ Yahoo group (http://tech.groups.yahoo.com/group/MemoQ), which could help you. If you plan on trying out MemoQ you could sign up and have access to the group. The developers are members as well and answer quite quickly when problems arise.

Re: Issue with MS Word files
Hi,

since I'm also an O2K user, for the same reasons as you, I can confirm
this issue is not new in MQ 3.x but has been there for a long time
already, since the preview pane feature was introduced. In the
beginning I reported it several times to Gabor and he managed to
improve this issue to some considerable extent, but parts of it still
it remain. I stopped mentioning this because a) I'm fully aware that
O2K support of course has no priority for developers any more and b)
in fact I really don't need the preview pane at all.

Solution: Disable "Create Preview.." in MQ Options.

(Remark: You may have to repeat this several times/week because MQ
tends to forget this setting and starts trying to create the previews
again)

---
Hi,

H wrote:
>> (Remark: You may have to repeat this several times/week because MQ
>> tends to forget this setting and starts trying to create the previews
>> again)
> Thanks for the warning - I would expect Translation *Memory* software to remember such things O:-)
This setting, along with many others, is a global setting which should be set from:

Tools -> Options -> Appearance, locations -> Enable preview for translations
If you start MemoQ blank (without any project) and set it there, it will be properly saved and remembered
If you use the View -> Show preview feature, it's then a different story. It will "hide" the preview, but still generate it and handle it. Not showing it slightly different than disabling. To make sure you don't create the preview in your MBD files when importing your source files, you should actually disable the feature and not just hide the preview.
But just for the sake of pinpointing the problem and try to solve it anyway, what exact version of Word 2000 are you using Herbert? Did you apply all Office 2000 Service Packs up to SP3?
To properly update your Office 2000 copy, you should first upgrade it using SR1a (http://www.microsoft.com/downloads/details.aspx?FamilyID=AF6C8D03-7633-45B4-AB96-795EE656F2A2&displaylang=EN), and only then can you download and update to SP3 (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=5c011c70-47d0-4306-9fa4-8e92d36332fe).
As the Office 2000 is quite old, it is really a mandatory step, as many bugs were fixed, especially concerning RTF format which is relatively more "standard" (MS doesn't stick 100% to the standard RTF specs, hence the problems sometimes between tools with that format).
Also, I noticed that applying the following fix (http://support.microsoft.com/default.aspx?scid=kb;en-us;224663) recommended by MS to help alleviate the "RTF bloat" issues with Word 2000 and later helps a lot to keep better control of your docs (even with DVX, as it seems to also convert as RTF and import the resulting RTF). Here is a summary of the fix, for the archives:
To prevent Word from saving two copies of the graphic in the document, and to reduce the file size of the document, add the ExportPictureWithMetafile=0 string value to the Microsoft Windows registry. To do this, follow these steps:
1. Quit Word.
2. Click Start, click Run, type regedit in the Open box, and then click OK.
3. Locate and then click to select one of the following registry keys, depending on your version of Word:
• For Microsoft Office Word 2003, locate and then click HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options.
• For Microsoft Word 2002, locate and then click HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options.
• For Word 2000, locate and then click HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options.
• For Word 97, locate and then click HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Word\Options
4. After you select the key that is specified in step 3, point to New on the Edit menu, and then click String.
5. Type ExportPictureWithMetafile, and then press ENTER.
6. Right-click ExportPictureWithMetafile, and then click Modify.
7. In the Value data box, type 0, and then click OK.
8. On the File menu, click Exit to quit Registry Editor.
Now, when you save a Word document that contains an EMF, a PNG, a GIF, or a JPEG graphic in a different format (for example, Word 6.0/95 (*.doc) or Rich Text Format (*.rtf)), Word does not retain two copies of the graphic and does not dramatically increase the file size of the document as compared to the Word version of the file.

--------------------
If you need more information, check the string beginning with Message #4394.

Hope this helps.

Best regards,

Effie


Direct link Reply with quote
 
Ansi
United Kingdom
Local time: 11:06
English to German
TOPIC STARTER
You can find help at MemoQ Yahoo group Dec 5, 2008

Thank you very much, Effie, that's very helpful.

Direct link Reply with quote
 

Gergely Vandor
Hungary
Local time: 12:06
English to Hungarian
Office 2000 SR2 is the minimum requirement Dec 9, 2008

Hello Ansi,

Are you sure you have at least Office 2000 SR2?

MemoQ doesn't do very esoteric things with Office, it just does interop on a hidden instance of Word, Excel, or PowerPoint. But Office interop in itself can be tricky. I would check if running (starting, closing, etc.) several normal instances of Word at the same time works all right on you machine.

Also be aware that if you have some problem that causes a user prompt or an error message to be displayed at every startup or shutdown of Word (like some template related problem), MemoQ will "face" the same error messages, but it can't click OK or Cancel. So it is a good idea to check all your auto-started Word templates if they all load and work without any errors or prompts to the user. If there are templates that are currently auto-started with Word on your system, but are not actually needed in day-to-day work, it can be a good idea to remove them from the Word startup folder (and only load them when you actually need them) to see if it helps.

And, of course, you really should upgrade from Office 2000. Sorry, I couldn't resist.

Bests,
Gergely Vandor

Kilgray


Direct link Reply with quote
 
Ansi
United Kingdom
Local time: 11:06
English to German
TOPIC STARTER
Office 2000 SR2 Dec 10, 2008

Dear Gergely,

Thanks for your kind advice. Yes, I patched and upgraded Word2k to what is possible. I often thought about buying a new version but it's always such a drag to find all the buttons to switch off the new rubbish they build in .... and just for the better unicode support: it's not really an issue with English/German. (What bugs me, though, is that I still have to use NET1.1... I'll probably make the switch soon )

I was a bit taken aback when Memoq crashed my Word template since Word otherwise starts nicely. Other programs which use Word as RTF converter don't have this problem which got me thinking. When I found then the Interop.VBIDE.dll in the DocConverters folder it got me worrying and led me to wrong conclusion Memoq might inject a macro to run it (I think WinFax did this many years ago - may be still, I don't know). But of course the Interop.VBIDE.dll comes as standard COM access to Word.

I have an idea what could cause the problem but am to busy to test it. Could it be that Memoq starts Word without loading add-ins? Obviously this would be quite smart - and it would explain my problem.

For the time being I just convert manually and keep "Create Preview" disabled.

Keep the good work up!


Direct link Reply with quote
 

Denis HAY  Identity Verified
Local time: 12:06
English to French
.NET 2.0 and Office 2000 SR2 as minimum requirement Dec 10, 2008

Ansi wrote:

Thanks for your kind advice. Yes, I patched and upgraded Word2k to what is possible.


Just to be on the safe side, did you actually check that the service pack 2 had been properly applied by selecting Help -> About when running Word? Sometimes, even though you execute such packs, they somehow don't update all files properly (most often when a stalled winword.exe process is still running in the background).


I often thought about buying a new version but it's always such a drag to find all the buttons to switch off the new rubbish they build in .... and just for the better unicode support: it's not really an issue with English/German. (What bugs me, though, is that I still have to use NET1.1... I'll probably make the switch soon )


This puzzles me, really. If you installed MemoQ, then you have .NET 2.0 running, not 1.1, MemoQ, from 2.x to the current 3.2.13 requires .NET 2.0.


I was a bit taken aback when Memoq crashed my Word template since Word otherwise starts nicely. Other programs which use Word as RTF converter don't have this problem which got me thinking. When I found then the Interop.VBIDE.dll in the DocConverters folder it got me worrying and led me to wrong conclusion Memoq might inject a macro to run it (I think WinFax did this many years ago - may be still, I don't know). But of course the Interop.VBIDE.dll comes as standard COM access to Word.


MemoQ doesn't install anything on Word, so template crashes are a completely independent matter. However, some earlier versions of Word might have serious issues when saving documents as RTF, and that is precisely what might be causing your trouble here. The last remnants of RTF saving glitches have been fixed only since Office 2003 SP3 (even though most users generally don't have any problems with Word XP and later.

I have an idea what could cause the problem but am to busy to test it. Could it be that Memoq starts Word without loading add-ins? Obviously this would be quite smart - and it would explain my problem.


Not that I know of, but only an insider such as Gergely could answer you on that one.

As an added tip, and to make sure your document import issues are Word related and not MemoQ related, could you manually save those faulty docs as RTF using Word, then select the "Import as…" option from MemoQ and make sure that "Save RTF files with Word" is unchecked?


Direct link Reply with quote
 

Gergely Vandor
Hungary
Local time: 12:06
English to Hungarian
Word templates and add-ins are all loaded... Dec 11, 2008

...in the hidden Word instance MemoQ starts for import or spell check. The reason is that there is simply no way to make interop start a "clean" instance as far as I know.

This is especially painful with Word 2007, which throws file access errors for every template when a second Word instance is started.

As for the .NET framework, there is no need to worry, you can have as many versions of it as you like, and they should never interfere. All you applications will use the version they were built for.

Bests,
Gergely


Direct link Reply with quote
 
Ansi
United Kingdom
Local time: 11:06
English to German
TOPIC STARTER
Office 2000 SR2 Dec 11, 2008

Just to be on the safe side, did you actually check that the service pack 2 had been properly applied by selecting Help -> About when running Word? Sometimes, even though you execute such packs, they somehow don't update all files properly (most often when a stalled winword.exe process is still running in the background).


Yes, I did.

This puzzles me, really. If you installed MemoQ, then you have .NET 2.0 running, not 1.1, MemoQ, from 2.x to the current 3.2.13 requires .NET 2.0.


I coded some own COM add-ins in C#. For them I can' use NET2 or later but only NET1.1.

As an added tip, and to make sure your document import issues are Word related and not MemoQ related, could you manually save those faulty docs as RTF using Word, then select the "Import as…" option from MemoQ and make sure that "Save RTF files with Word" is unchecked?


This is exactly what I'm doing now.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

MemoQ 3.0.34 & Word 2000

Advanced search






Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs