Mobile menu

Does anybody know how to turn off the "right-to-left" shortcut in Windows XP?
Thread poster: Henrik Pipoyan

Henrik Pipoyan  Identity Verified
Local time: 17:14
Member (2004)
English to Armenian
Jun 10, 2007

Since I installed Windows XP, this has been a nightmare for me. Whenever I hit the Control key with the right Shift key, the text changes direction - right-to-left. I often use these keys for other purposes, and every second I have to hit undo. Is there a way I can turn this shortcut off?

Any help will be appreciated.


Direct link Reply with quote
 

JaneTranslates  Identity Verified
Puerto Rico
Local time: 09:14
Member (2005)
Spanish to English
+ ...
Do you mean within Word? Jun 10, 2007

From Microsoft Word Help:
Insert a right-to-left or left-to-right mark
Show All
Hide All
The feature or some of the options described in this Help topic are only available if support for right-to-left languages is enabled through Microsoft Office Language Settings.

Place the insertion point where you want to insert the character.
On the Insert menu, click Symbol, and then click the Special Characters tab.
Click Left-to-Right Mark or Right-to-Left Mark.


I don't know if this helps--but maybe it's worth a try, if your problem occurs while using Word. If you don't use right-to-left languages, but for some reason they have been enabled in your language settings, disabling that might be simpler than trying to figure out how to disable the shortcut.

I'm pretty low-tech so I offer this in all humility; you probably tried this weeks ago.

Good luck!

Jane


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 17:14
Member (2004)
English to Armenian
TOPIC STARTER
Hi Jane Jun 10, 2007

Thank you for your help.

In fact it's everywhere, but most of all it hinders me in Word, because I work in Word most of the time.

The problem is that I do need the "right-to-left" option checked in Regional and Language Options, because Armenian is included in it, although it's a left to right language (probably it is considered as a language with complex script). If I turn it off, the problem will be solved, but I can't write Armenian.


Direct link Reply with quote
 

Edith Goebel  Identity Verified
Local time: 15:14
German to Danish
+ ...
Change shortcut in Word Jun 11, 2007

On my computer, nothing happens when I press the control key with the right shift key.

Some shortcuts can be changed in Word:

Under "Tools" - "Customize"
choose the tab "Toolbars"
Press the button "Keyboard".

Here find the shortcut, that causes your problem, and change it.

I hope this helps!

I have a similar problem, when working with Outlook. The shortcut Control+Return sends the email without any warning. And I often use the shortcut Control+Backspace, and the backspace key is just above the return key. But I don't think that shortcuts can be changed in Outlook.

Edith


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 17:14
Member (2004)
English to Armenian
TOPIC STARTER
Hi Edith Jun 11, 2007

Unfortunately I cannot turn off this shortcut from Word, because this is a Windows shortcut. In word it is under Format > RtlPara, but there is no shortcut assigned to it. And still it works. Maybe on your computer it doesn't work because you haven't activated the "left-to-right" language support in Windows Regional and Language Options. But I had to do it, because otherwise I couldn't type Armenian. Although Armenian is a left-to-right language it's included in this group.

Regarding Outlook, I think you're right -- you cannot change the shortcuts in Outlook. But I am familiar with this problem. Here's how I have solved this problem. First of all I have unchecked the "Send messages immediately" checkbox in Tools > Options > Send. So whenever a message goes to the Outbox, it is never sent to the address until I hit "Send/Receive". Secondly, I usually write the address in the end, and when the "To:" box is empty, it never goes to the Outbox, just gives an error message.

Best regards,

Henry


Direct link Reply with quote
 

Edith Goebel  Identity Verified
Local time: 15:14
German to Danish
+ ...
Language settings Jun 11, 2007

I also use the trick with no address in emails before they are ready to send.

I found this, it sounds very much like your problem. Perhaps it will do it:

"All these settings can be changed via Control Panel > Regional and Language Settings > Language tab > Details > Key Settings"

http://microsoft-personal-applications.hostweb.com/TopicMessages/microsoft.public.word.docmanagement/750777/1/Default.aspx


Edith


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 17:14
Member (2004)
English to Armenian
TOPIC STARTER
Hi Edith Jun 12, 2007

Thank you for the link. Seems like this is really what I needed, but unfortunately it allows you to assign key sequences only for the languages, you cannot turn off the right-to-left shortcut. But I hope I can contact Microsoft through that link.

Best regards,

Henry


Direct link Reply with quote
 

Edith Goebel  Identity Verified
Local time: 15:14
German to Danish
+ ...
But it must be here! Jun 12, 2007

Have you tried:
Control Panel > Regional and Language Settings > Language tab > Details > Key Settings
Here choose the Action "Switch between input languages" and then press the button "Change Key Sequence".

Checkout either "Switch input languages" or "Switch keyboard layouts - the one with the problematic shortcut.

It must be that.


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 17:14
Member (2004)
English to Armenian
TOPIC STARTER
Hi Edith Jun 12, 2007

Yes, I did try that. I was hoping this would help, but it didn't change anything. I even turned off all shortcuts, so that I could change the language only with the help of the mouse, and still this shortcut remains.

Thank you for all your help.

Best regards,

Henry


Direct link Reply with quote
 

Edith Goebel  Identity Verified
Local time: 15:14
German to Danish
+ ...
Ok, I give up. Jun 13, 2007

There must be something wrong. The Control+Shift shortcut can normally be turned off by checkout of one of these functions "Switch input languages" or "Switch keyboard layouts":

http://www.linginfo.it/images/support/help/02/03/eng/7.gif


- And remember to pres OK all the way back. You will need to restart the computer too.

[Edited at 2007-06-13 07:27]


Direct link Reply with quote
 

Henrik Pipoyan  Identity Verified
Local time: 17:14
Member (2004)
English to Armenian
TOPIC STARTER
Hi Edith Jun 13, 2007

Yes, I agree, it's really strange. In fact this was the first thing I tried when I wanted to get rid of that shortcut. Normally this type of change takes effect immediately, but I even restarted the computer, to make sure it is accepted. Nothing happened.

After you suggested it, I decided to try it again, hoping that last time I had missed something, because this setting really means what I need. I did it, pressing all the "OK"s and "Apply"s, and restarted the computer. Again the shortcut didn't turn off. Then I turned off all the shortcuts, so that I wasn't even able to change the languages using the shortcut. No luck; the text direction still changes.

Thank you for all your help.

Best regards,

Henry


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Does anybody know how to turn off the "right-to-left" shortcut in Windows XP?

Advanced search






Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs