Field Codes in Word 2007 & 2003
Thread poster: Katrin Jarvis

Katrin Jarvis  Identity Verified
United States
Local time: 18:54
English to Swedish
+ ...
Mar 10, 2008

I am pulling my hair trying to figure out how I can hide the field codes in certain documents in Word 2007. I have a Swedish version, so the labels might be different, but I have so far figured out that there is a box in the Advanced section under Word alternatives. It is called something like "Show field codes instead of just text" or similar. Great! But every time I try to write something the field codes are back! The box is still unchecked, but another box, under the tab View in Word alternatives is checked: "Show hidden text". It doesn't matter how many times I uncheck this box, as soon as I go back to my text and write something, the field codes are back. As is the check mark in the "Show hidden text" box. How do I HIDE the field codes permanently? The ALT + F9 doesn't do anything. I am at a loss here... Please advice!

NOTE: I just tested the document in Word 2003, same problem! Field Codes are hidden, but the Hidden Text button is doing the exact same thing! What gives? This is driving me nuts!

Thanks,
Katrin

[Edited at 2008-03-10 14:12]


Direct link Reply with quote
 
Tommy Guignard  Identity Verified
Local time: 18:54
English to French
+ ...
I have exactly the same problem Aug 9, 2008

Hi Katrin,

I am sorry not to give you a solution for your problem, but I wanted to get this thread up the list so that we finally get a reply. I have exactly the same problem as you do.

I work on Word 2003. In 2006, I bought SDL Trados 2006 and this happened everytime a document included filed codes (i.e. page numbers, hyperlinks, automatic insertions, etc.). The screen would only show these complex codes instead of the values that match with them. I then had to format my computer (for another reason), reinstall SDL Trados and it never happened again, even when I upgraded to 2007 version. I had to buy a new computer recently when my old one crashed and since I re-installed SDL Trados 2007, those annoying field codes are back. Like you, Alt+F9 does not work all the time and when it does, or when I right-click on the code and select to show value, it gets back to codes as soon as I write something in the document.

So, my question goes like this: Is there a way Word 2003 (or 2007) can display field values instead of field codes by default? The problem is closely linked to Trados, according to my experience.

Thank you very much and hope we're gonna get this problem solved pretty soon!

Tommy


Direct link Reply with quote
 
jens wencker  Identity Verified
Local time: 17:54
English
+ ...
Field Codes Oct 14, 2008

Hi Katrin,

I don't know if that is helpful, but there is a Macro to remove the Field Codes. However it sounds like you just want to hide them for translation purposes and keep the Field Codes in your final file.

Anyway, here is a MAcro to remove the Codes: (I number my Macros, in this case it is "Macro4" you can rename it of course)

Sub Macro4()
'
' Dim doc As Document
Dim fld As Field
Set doc = ActiveDocument
For Each fld In doc.Fields
fld.Select
If fld.Type = wdFieldIndexEntry Then
fld.Delete
End If
Next
Set fld = Nothing
Set doc = Nothing
End Sub




If you don't have too many FIeld Codes, you can may be apply them back in the final document.

OR

You can try Ctrl + Shift + F9. This combination changes hyperlinked text to normal text, who knows, maybe it works for Field Codes as well.

Best Regards,
Jens


Direct link Reply with quote
 

Richard Sanders  Identity Verified
United States
Local time: 18:54
Member
Dutch to English
+ ...
Field Codes in Word 2007 & 2003- Solution to Field Codes appearing in a document Oct 19, 2008

My wife just ran into and SOLVED the same problem.
Here is what you do:
In Word 2003 click on Tools and then click on Options; in Options go to View, in View make sure that the box called Field Codes is NOT checked. This will solve the problem!


[Edited at 2008-10-19 16:43]


Direct link Reply with quote
 
heTed
Local time: 17:54
Word 2007 show or hide field codes Oct 22, 2009

Press button upper left corner of toolbar, select Word Options, select Advanced, scroll down to Show Document Content and click Show Field Codes instead of thier values. Unclick to hide again.

Direct link Reply with quote
 

Caro Maucher  Identity Verified
Germany
Local time: 00:54
Member (2005)
English to German
+ ...
Thanks, heTed! Dec 17, 2010

That solved my problem in Word 2007. What I'm wondering now is where that little check mark came from, since I certainly didn't put it there! Is there a secret shortcut I might have pressed by mistake?

Direct link Reply with quote
 

Caro Maucher  Identity Verified
Germany
Local time: 00:54
Member (2005)
English to German
+ ...
Alt+F9 in Word 2007 turns on/off the option "Show Field Codes instead of their values" Jan 25, 2011

Referring to my question above about the secret shortcut, Steve B sent me a mail saying:

Yes, pressing Alt+F9 in Word 2007 permanently turns on/off the option to “Show Field Codes instead of their values”.

So that's probably what happened.
Thanks, Steve!


Direct link Reply with quote
 
Thanks HeTed Jan 24, 2013

Thanks HeTed. Your help is much appreciated.
heTed wrote:

Press button upper left corner of toolbar, select Word Options, select Advanced, scroll down to Show Document Content and click Show Field Codes instead of thier values. Unclick to hide again.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Field Codes in Word 2007 & 2003

Advanced search






PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs