Mobile menu

Editing OmegaT batch file
Thread poster: Andrew Stucken

Andrew Stucken
United Kingdom
Local time: 21:59
German to English
Nov 5, 2008

I have installed the latest version of OmegaT and now find the TM file for my latest project is too big for the memory.

I understand I need to edit the batch file to increase the memory, but where do I find it exactly please?


Direct link Reply with quote
 

Selcuk Akyuz  Identity Verified
Turkey
Local time: 23:59
Member (2006)
English to Turkish
+ ...
Additional information please Nov 5, 2008

Hi Andrew,
I can not answer your question but additional information may be helpful.
What is your operating system Windows (XP, Vista), Linux or Mac?

And about the latest build of OmegaT, is it the Beta version 1.8.1?


[Edited at 2008-11-05 11:44]


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 23:59
Member (2006)
English to Russian
+ ...
You can't do anyhing about TM size, Nov 5, 2008

but you can increase the initial Java memory size as follows (make a batch file containing the following string and put it into the directory where OmegaT.jar resides):
Code:
java -server -Xmx256m -jar OmegaT.jar



Try experimenting with the second parameter, by replacing 256 with another value in megabytes (a rule of finger: set double to your RAM).

[Edited at 2008-11-05 12:14]


Direct link Reply with quote
 

Andrew Stucken
United Kingdom
Local time: 21:59
German to English
TOPIC STARTER
Batch file Nov 5, 2008

Hi thanks for these.

I am running Windows XP and OmegaT 1.8.1 beta, plus the latest version of Java.

I have now located the MS DOS batch file. When I open it up I see there is only one line in it however - re\bin\javaw -jar OmegaT.jar %*

Can I type the code you quoted in here instead of making a batch file, please?

If not, how do I make a batch file?

TIA


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 23:59
Member (2006)
English to Russian
+ ...
You can do both Nov 5, 2008

Either replace the code of the existing file with my sample, or open a text editor paste into it my line and save as anyfilename.bat. Good luck!

Direct link Reply with quote
 

Andrew Stucken
United Kingdom
Local time: 21:59
German to English
TOPIC STARTER
Same problem Nov 5, 2008

Thanks, did exactly as you suggest - same problem.

I replaced the line in the batch file with the line you gave me. I even increased the size to 512. Have I done something wrong here?

BTW the TM file size is 14.3MB.


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 23:59
Member (2006)
English to Russian
+ ...
Give more detail Nov 5, 2008

What exactly is your problem?

Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 22:59
Member (2007)
English to French
+ ...
No batch file in 1.8.1 Nov 5, 2008

Andrew Stucken wrote:
I am running Windows XP and OmegaT 1.8.1 beta, plus the latest version of Java.

I have now located the MS DOS batch file. When I open it up I see there is only one line in it however - re\bin\javaw -jar OmegaT.jar %*

Can I type the code you quoted in here instead of making a batch file, please?

If not, how do I make a batch file?


1.8.1 for Windows contains no batch file, and it isn't needed.

To change runtime settings, edit the file OmegaT.l4J.ini.
Inside, there's a line
#-Xmx1024M

Uncomment it (remove the #), and adapt the number to the memory you want.

Didier


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 23:59
Member (2006)
English to Russian
+ ...
Gee, I've missed the news :-)))) Nov 5, 2008

Didier Briel wrote:
1.8.1 for Windows contains no batch file, and it isn't needed.

But you still can use a batch file to run OmegaT.


Direct link Reply with quote
 

Andrew Stucken
United Kingdom
Local time: 21:59
German to English
TOPIC STARTER
Not there yet Nov 5, 2008

Thanks Didier and Esperantisto. Have tried adapting the file Didier suggests (to 2048) , and changed the line in the batch file too. Still no joy.

Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 22:59
Member (2007)
English to French
+ ...
The ini files only concern OmegaT.exe Nov 5, 2008

find the TM file for my latest project is too big for the memory

Which version was it?
There has not been a significant memory consumption difference since OmegaT 1.6.

re\bin\javaw -jar OmegaT.jar %*

This would tend to mean that, previously, you were using the "embedded" JRE included with some versions of OmegaT.
Which version of Java do you use?
If you are unsure, you should install OmegaT for Windows *with* Java, which I am sure contains a decently recent JRE.

Andrew Stucken wrote:
Have tried adapting the file Didier suggests (to 2048) ,

Depending on your machine, 2048 may be refused by Java, and thus not be taken into account. Have you tried with 1024?

and changed the line in the batch file too. Still no joy.


The change in the ini file only applies if OmegaT is launched using OmegaT.exe.

Conversely, the change in the batch file only applies if you use the batch file, not if you launch the .exe or OmegaT.jar directly.

Didier


Direct link Reply with quote
 

Dragomir Kovacevic  Identity Verified
Italy
Local time: 22:59
Member
Italian to Serbian
+ ...
make a link to the original bat file Nov 5, 2008

Andrew Stucken wrote:

Thanks, did exactly as you suggest - same problem.

I replaced the line in the batch file with the line you gave me. I even increased the size to 512. Have I done something wrong here?

BTW the TM file size is 14.3MB.


hello, no use to modify the source bat file in OmegaT programme folder. Make a link to it. In the link, make an addition, so that all should look like:

java -Xmx512M -Duser.language=en -jar OmegaT.jar %*

the above will suffice.

Then you can copy the bat file once again into a place you wish to see it in: desktop, for example

take note that the "en" here is for english. Put in the another code for another language for the UI you want to use, in case it is translated.

D


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 23:59
Member (2006)
English to Russian
+ ...
But again, what's exactly the problem? Nov 6, 2008

I used to work with even larger files with even older versions of OmegaT without any particular problem (other than slooooow loading on my machine).

Direct link Reply with quote
 

Andrew Stucken
United Kingdom
Local time: 21:59
German to English
TOPIC STARTER
Another day, a solution Nov 6, 2008

OK, issue is now resolved.

For good measure I startred afresh to ensure leaving no legacy alterations form yesterday.

Uninstalled and then re-downloaded OmegaT.

Removed # and altered the line in OmegaT.l4J.ini as per instructions - to 2048.

Did not work.

Changed figure back to 1024 and hey presto, it worked. The TM took ages to load - 14MB file.

Thanks to all who helped with this.

Re: Esparantisto's question: The exact error message is gone and even trying to bring it back by restoring the # temporarily does not now bring it back. Curious. Anyway the gist was that there was not enough memory to run OmegaT and that I should edit the omegaT.bat file in exactly the manner you prescribed.


Direct link Reply with quote
 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


Editing OmegaT batch file

Advanced search






Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs