Mobile menu

Alignment Russian to English file in Trados, how?
Thread poster: Yngve Roennike

Yngve Roennike  Identity Verified
Local time: 14:24
Danish to English
+ ...
Jun 19, 2008

I've managed to install Russian as one of the languages in Trados, target being English.

I have two files for alignment from Russian to English. You need to save both files in Rich Text Format, but then you lose the Russian characters and get the usual gibberish. What then happens if you import this gibberish into the Russian to English Trados file, I wonder.

What on earth is a guy gotta do to accomplish this?

I'm hoping and assuming that there is a simple solution to this obvious problem. The Trados guys would have created a solution for this?

PS. I'll post in the Trados forum as well, since not just Russian would be affected, but rather all non-latin-scripted languages.

YR


[Edited at 2008-06-19 13:34]


Direct link Reply with quote
 

Valentinas & Halina Kulinic  Identity Verified
Local time: 21:24
English to Ukrainian
+ ...
Dear Yngve, Jun 19, 2008

You do not need to save the files in RTF format - WinAlign will do this automatically. Just add the EN and RU files in Files tab of New WinAlign Project dialog box. If you still get spoiled characters, change the system locale into Russian.

By the way, I work with Lithuanian locale but this never creates problems when aligning Russian and Ukrainian files.

Va

[Edited at 2008-06-19 06:43]


Direct link Reply with quote
 

Sergei Tumanov  Identity Verified
Local time: 21:24
English to Russian
+ ...
one solution Jun 19, 2008

you can download free software 'plustools' from here
http://www.wordfast.net/index.php?whichpage=plustools&lang=engb

as far as I know it can align doc files without additional conversion to rtf.
And aligning process is rather user friendly.


Direct link Reply with quote
 

Yngve Roennike  Identity Verified
Local time: 14:24
Danish to English
+ ...
TOPIC STARTER
Further discovery, same problem! Jun 19, 2008

I've now clicked the options for using .doc documents and adjusted the settings and the alignment proceeds alright, but the aligned document that was Russian still displays gibberish even though the file I am loading is a perfect non-RTF file, i.e., a .doc document, which I've double checked.

Let me know what you all think. This would affect all languages not in the standard European code page, since an RTF conversion does not maintain the original non-latin characters.

I don't know how WordFast handles this alignment.

Right now I would have to click my way through all segments and cut and paste, rather than use alignment.

How about the documentation for Trados. Anything there?

Regarding changing my whole system to a Russian operating environment or locale, that would not be an option I would think. I work in many other languages.

The problem may be systemic though, because now that I try and open segments they immediately turn into gibberish, where there should be Russian.

I have no clue at this point, I wonder if the Trados folks (a rather aloof lot, frankly, unless you buy an extensive support option) will render any assistance with this basic issue.



[Edited at 2008-06-19 16:01]


Direct link Reply with quote
 
Boyan Brezinsky  Identity Verified
Bulgaria
Local time: 21:24
English to Bulgarian
+ ...
Try changing the settings for non-Unicode programs Jun 19, 2008

Assuming you are on Windows XP, try to change the language settings for non-Unicode programs. Control Panel -> Regional and Language Options -> Advanced -> Language for non-Unicode programs - and set that to Russian. You might need the Windows installation media though. Then you'll have to restart.
Of course, the alignment will have to be rerun.
I have no idea if this will help, but it is not that time-consuming to try.


Direct link Reply with quote
 

Yngve Roennike  Identity Verified
Local time: 14:24
Danish to English
+ ...
TOPIC STARTER
Marvellous, Jun 19, 2008

Bsb_2 (Paris of Eastern Europe). That worked like a miracle.

Yngve

bsb_2 wrote:

Assuming you are on Windows XP, try to change the language settings for non-Unicode programs. Control Panel -> Regional and Language Options -> Advanced -> Language for non-Unicode programs - and set that to Russian. You might need the Windows installation media though. Then you'll have to restart.
Of course, the alignment will have to be rerun.
I have no idea if this will help, but it is not that time-consuming to try.


As a footnote, I should add that Trados works much slower in this environment at least on my XP-run computer than I am used to, advancing between segments at a snail's pace. Maybe my computer has to get used to this new "alien" environment



[Edited at 2008-06-20 15:32]


Direct link Reply with quote
 

Yngve Roennike  Identity Verified
Local time: 14:24
Danish to English
+ ...
TOPIC STARTER
Slow execution! Jun 21, 2008

I am going to highlight this problem with slow execution. Is it reasonable to sometimes wait a minute or so for a segment to close and open by pressing the corresponding macro (Alt + plus key on the numerical keypad), or just closing out of a segment or canceling segments (Alt Del). The problem only gets worse with long sentences, it seems.

This is frankly unacceptable, but maybe there is a fix.

Could I be the only one experiencing this go slow situation?
Maybe things will speed up in Tag Editor for Russian - any opinions on that?

[Edited at 2008-06-21 07:00]


Direct link Reply with quote
 

Sergei Tumanov  Identity Verified
Local time: 21:24
English to Russian
+ ...
one of possible problems Jun 21, 2008

Maybe your file has too much graphics in it?
I had similar problem when translating a manual with many photos.


Direct link Reply with quote
 

Yngve Roennike  Identity Verified
Local time: 14:24
Danish to English
+ ...
TOPIC STARTER
No graphics! Jun 21, 2008

No, no graphics, a few tables though. I saved it in the least complex format allowed by ABBYY, the OCR program.

I am baffled, may ask Trados directly for an explanation, though.

They gotta come off their high horse and help clueless customers with basic, root, core issues such as this.

Sergei Tumanov wrote:

Maybe your file has too much graphics in it?
I had similar problem when translating a manual with many photos.


Direct link Reply with quote
 

Boris Popov
Local time: 22:24
English to Russian
+ ...
Word is the culprit Jun 21, 2008

Yngve Roennike wrote:

No, no graphics, a few tables though. I saved it in the least complex format allowed by ABBYY, the OCR program.

---skipped---

Looks like the OCRed file you have contains too many formatting tags.
There are many ways to get rid of these - do some RTFM.
You can start here:
http://www.necco.ca/dv/word.htm
Read everything about "rogue codes"


[Edited at 2008-06-21 15:12]

[Edited at 2008-06-21 15:13]


Direct link Reply with quote
 

Yngve Roennike  Identity Verified
Local time: 14:24
Danish to English
+ ...
TOPIC STARTER
Housekeeping chores! Jun 21, 2008

You mean (quite) a few housekeeping chores before kicking off.
Actually, at one point Trados Workbench crashed through all these travails, and I sent a report to Microsoft. Today, there is an automatic update of my Windows XP system waiting. I wonder if there is any correlation. Would be nice to think. Let's see if it my system is more spry today.

Spacibo!


[/quote]
Looks like the OCRed file you have contains too many formatting tags.
There are many ways to get rid of these - do some RTFM.
You can start here:
http://www.necco.ca/dv/word.htm
Read everything about "rogue codes"




Direct link Reply with quote
 

Yngve Roennike  Identity Verified
Local time: 14:24
Danish to English
+ ...
TOPIC STARTER
Some final comments. Jun 23, 2008

Definitely an improvement in speed today on my machine. These things are like living breathing animals obviously adapting to an evolving situation

Also, in this document, I don't get the annoying diminutive subscript TW4.. font, when editing or going through the document again reopening segments. I've noticed that a particular font, i.e., arial, is especially prone to this misbehavior, whereas Times New Roman is less. Could be my imagination, though.

Has any of you Russian Trados translators noticed this sort of thing?
Would be very interesting to know.

Regards,
YR


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Alignment Russian to English file in Trados, how?

Advanced search


Translation news in Russian Federation





Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs