Pages in topic:   [1 2] >
Cannot open MT termbase in Word 2003
Thread poster: Jakub Suchocki
Jakub Suchocki
Local time: 19:09
English to Polish
+ ...
Mar 24, 2008

Hello,

I have Trados 7 and MultiTerm 7 installed. When I begin to translate in MS Word, I open a termbase in TWB and everything is ok but when try to open it in Multiterm (located on Word toolbar) I can only choose "Local sample" termbase which is of no help to me.

I tried many solutions but none of them helped.
Of course I can always open stand-alone Multiterm but adding entries in this way is much more time-consuming.

It can be not a big problem but still annoys.

I'd grateful for any tips and solutions.

Regards!


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 13:09
English to French
+ ...
Confusion Mar 25, 2008

I think you are confusing TMs and TDBs. A TM (translation memory) is a file that stores the segments you translate. This is what you produce as you open and set segments in Word. A TDB (terminology database) is a glossary of terms (words or word strings). These are not produced using Workbench and they are not picked up automatically. This is what you would use MultiTerm for. Workbench and MultiTerm are two separate software and are used for two separate sets of tasks.

Workbench and Word can interface with MultiTerm, that is, you can look up, insert and add terms to your TDB from Word (or TagEditor). But in order to be able to do this, you have to activate the MultiTerm toolbar in Word and also link to your TDB through Workbench.

In other words, terms (MultiTerm) can be parts of segments (Workbench). You can use Workbench without using a TDB (MultiTerm), and you will still produce a TM (Workbench).

Please, read the appropriate sections in the File formats reference guide and in the Translator's Workbench user guide to better understand what Workbench does and how it works. Also read the appropriate sections of the MultiTerm user guide to understand what MultiTerm does and how it interfaces with Workbench.

Please, check if your problem is caused by not knowing these tools well enough. If it is the case, use the above guides to know your way around. If you still have problems, post here again and we'll see if one of us can fix you up.

All the best!

[Edited at 2008-03-25 04:21]


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 19:09
English to Czech
+ ...
Create a termbase first Mar 25, 2008

Hi Jakub,
you should create a new termbase first. But note that this termbase will be empty. If you are a newbie to Trados yet have some Excel glossaries or similar, you can start by importing them to MultiTerm.

If only the "Sample" termbase displays, it means there is no other termbase there.

[Upraveno: 2008-03-25 09:58]


Direct link Reply with quote
 
Jakub Suchocki
Local time: 19:09
English to Polish
+ ...
TOPIC STARTER
Clarifications Mar 26, 2008

I did created new termbase via stand-alone Multiterm.

Maybe I'll explain what my problem is about one more time.

1. I start translating. Open TWB, open MS Word with the file i want to translate.
2. Then, I go to "Options/Term Recognition Options/", in TWB, and browse for my Termbase, then select languages (for example English->Polish). Click OK. Note that I can set and see from here the termbase previously created in Multiterm.
3. Next I go to Word and click on "Select Termbase" (or Ctrl+Shift+O) in the Multiterm toolbar.
4. A window pops up. Here I can click on that green + and set the same termbase i did in TWB.
5. My problem is: I cannot see and set the termbase except for this "Local Sample" which is of no use to me.

What is causing that? I tried to set termbase in Multiterm toolbar first, but it doesn't help.
Regards.


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 19:09
English to Czech
+ ...
Now I can see your point Mar 26, 2008

but still don't understand why you need to connect MultiTerm to Word. I've never needed it, because the best way of running active terminology recognition is just in Workbench. In other words, you don't need to connect MultiTerm termbases to Word to use active terminology recognition.

Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 13:09
English to French
+ ...
Yes, but... Mar 27, 2008

Stanislav Pokorny wrote:

u don't need to connect MultiTerm termbases to Word to use active terminology recognition.

[/quote]

No, but if you want to be able to add terms on the fly, then you do need to use the MultiTerm toolbar in Word. I now understand what the problem is.

When you click on the Select termbase button on the MultiTerm toolbar in Word, you get a small window that lets you pick your termbase. In that window, you sometimes already have a few choices and somtimes no (depends if a termbase is already loaded or not). If the termbase you want to use is not in that list, you need to click on the small green plus symbol and browse to the termbase you want to use. This should fix the problem.

Please, tell us if you still are having trouble.


Direct link Reply with quote
 
Jakub Suchocki
Local time: 19:09
English to Polish
+ ...
TOPIC STARTER
Still.... Mar 27, 2008

I did as you wrote but still I don't see the termbase previously created in Multiterm.
It is loaded in TWB, maybe I just cannot load the same termbase in this 2 programs at one time?


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 19:09
English to Czech
+ ...
Yes, but... Mar 28, 2008

Viktoria Gimbe wrote:

Stanislav Pokorny wrote:

u don't need to connect MultiTerm termbases to Word to use active terminology recognition.



No, but if you want to be able to add terms on the fly, then you do need to use the MultiTerm toolbar in Word. I now understand what the problem is.

[/quote]

Hi Viktoria, you can also add new terms by right-clicking on a term in TWB. It's a bit more clicks but it works too.


Direct link Reply with quote
 
Michael McCain  Identity Verified
France
Local time: 19:09
Arabic to English
+ ...
Termbases not accessible from MultiTerm tab in Word 2007 nor from Synergy new project wizard Apr 8, 2008

I have the same problem as Jakub. I have multiple termbases which can be accessed in MultiTerm and Translators Workbench, but NOT from the MS Word MultiTerm tab and NOT from the Synergy new project wizard. The "Termbases" tab is also corrupt under SDL Trados Synergy/Projects.

I have SDL Trados Synergy 8.2.132.0 Professional and Word 2007.


Direct link Reply with quote
 

Sandra& Kenneth  Identity Verified
Israel
Local time: 20:09
Member (2009)
French to English
+ ...
This was solved long ago - and you will need this later too... Apr 9, 2008

Hi Yakub,

You need to go to
C:\Documents and Settings\[User Name]\Application Data\Trados\MultiTerm
and delete MultiTerm7dot.xml.


This is a file that will recreate itself. Please note that the problem will possibly recur each time you install an update or reinstall MT (it does to me), so it's a good idea to save this little procedure for later.


HTH,
Sandra

[Edited at 2008-04-09 16:12]

[Edited at 2008-04-09 16:12]


Direct link Reply with quote
 

Alaa Zeineldine  Identity Verified
Egypt
Local time: 19:09
Member (2002)
English to Arabic
+ ...
Any solution yet? May 28, 2008

Has anyone solved this problem yet?
I tried deleting the xml file, but that did not help.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 19:09
English
Try this... May 28, 2008

Hello Alaa,

Perhaps this will help:

1. Make first sure if the Termbase folder path is C:\Documents and Settings\All Users\Application Data\SDL International\MultiTerm\Termbases and make sure the "MTMaster.mdb" is placed in here.
2. Copy this path
3. Open START --> Run.
4. Type in: regedit
5. A window opens
6. Now goto: HKEY_LOCAL_MACHINE --> SOFTWARE --> TRADOS --> MultiTerm --> ServerDataBaseInfo
7. At the right window you now must see:
(Standard)
Location
MasterDBz
TemplateFile
8. Double click on Location and a new window will open.
9. There you should be able to paste your copied path C:\Documents and Settings\All Users\Application Data\SDL International\MultiTerm\Termbases\ to your MTMaster.mdb (Please
don’t forgot the backslash at the end of the path)
10. Close the Registration Editor
11. Now open Word again
12. When you click on select Termbase the window will open
13. Click on the "+"
14. Now you should be able to see your termbases

Please note, the file paths are different for Windows Vista. The file path would be C:\ProgramData\SDL International\MultiTerm\Termbases\

I hope this helps.

Many Thanks,

Gareth Powell


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 19:09
French to Polish
+ ...
Gareth, optimize :) May 28, 2008

SDL Support wrote:

Perhaps this will help:

1. Make first sure if the Termbase folder path is C:\Documents and Settings\All Users\Application Data\SDL International\MultiTerm\Termbases and make sure the "MTMaster.mdb" is placed in here.
2. Copy this path


3. Save a .reg file as included between the begin and end lines below (EXCEPT the begin and end lines).

The examples below come from MT 2007 SP1.
It may be some differences between specific builds (the SDL support should track it and provide more versions, if necessary).

a) Windows XP
=========================================== begin
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Trados\MultiTerm\ServerDatabaseInfo]
@="JET Engine"
"Location"="C:\\Documents and Settings\\All Users\\Application Data\\SDL International\\MultiTerm\\Termbases\\"
"TemplateFile"="C:\\Documents and Settings\\All Users\\Application Data\\SDL International\\MultiTerm\\Termbases\\MultiTermMtTemplate.mdb"
"MasterDB"="MtMaster"
=========================================== end

Take in account the Gareth's note:
Please note, the file paths are different for Windows Vista. The file path would be C:\ProgramData\SDL International\MultiTerm\Termbases\


b) Windows Vista
=========================================== begin
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Trados\MultiTerm\ServerDatabaseInfo]
@="JET Engine"
"Location"="C:\\ProgramData\\SDL International\\MultiTerm\\Termbases\\"
"TemplateFile"="C:\\ProgramData\\SDL International\\MultiTerm\\Termbases\\MultiTermMtTemplate.mdb"
"MasterDB"="MtMaster"
=========================================== end

4. Copy and paste the correct paths from the point 1.
Attention.
All the backspace chars in the path should be repeated...

[...]

11. Now open Word again
12. When you click on select Termbase the window will open
13. Click on the "+"
14. Now you should be able to see your termbases


I hope

Cheers
GG


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 19:09
French to Polish
+ ...
User rights? May 28, 2008

Jakub Suchocki wrote:

Hello,

I have Trados 7 and MultiTerm 7 installed. When I begin to translate in MS Word, I open a termbase in TWB and everything is ok but when try to open it in Multiterm (located on Word toolbar) I can only choose "Local sample" termbase which is of no help to me.

You see other termbases?
You have administrative rights?
Vista or XP?

I suppose it's a user rights problem problem.
The scoundrel who decided to put the MT files in the [Documents and Settings]/[Users]\All Users branch should be hanged.

If you give more details about your config, I'll try to dig in.

Cheers
GG


Direct link Reply with quote
 

Alaa Zeineldine  Identity Verified
Egypt
Local time: 19:09
Member (2002)
English to Arabic
+ ...
Didn t work May 28, 2008

I am using Vista. The registry already had the correct path, so this was not the problem.

Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Cannot open MT termbase in Word 2003

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums