Mobile menu

customer cannot open xml.ttx-files/has problems seeing the special charactes in .xml
Thread poster: Sommersonne

Sommersonne  Identity Verified
Sweden
Local time: 02:08
English to German
+ ...
Mar 28, 2008

Dear All!

I am currently working on the translation of numerous xml-files with TagEditor. I received the specially prepared TagEditor-files as well as an ini-file and the original xml-files. So far everything according to normal procedure. I also can translate and save without no problems the bilingual xml.ttx-files. And that's about where the problem starts.
Trying to save only in the target language as xml-files changes all the special characters to tags like "& uuml" for "ü" and so on. Now, is that normal (I think I never stumbled upon it before)?

Second, the customer fails to open the bilingual xml.ttx-files - though I do not have any problems with that after I save them and they do look - at least at my end - totally normal.

Am I overlooking here some minor settings, can I do something wrong in the procedure, should I pay attention to anything special? Anybody else stumbled upon these problems already???
Thanks in advance!!!

All the best,

Stefanie

[Edited at 2008-03-28 16:58]


Direct link Reply with quote
 

Alexey Ivanov  Identity Verified
Russian Federation
Local time: 04:08
Member (2004)
English to Russian
The only thing I can think of Mar 28, 2008

is that you did not properly connect the .ini file you received to the TWB.
The path is TWB Menu/Options/Translation Memory Options/Tools/Tag Settings Manager.
When you are there, if you see the .ini file among other tag settings files in the big window on the left, select it either using "Select" from the options on the right, but if it is greyed out, it means that the option is unavailable. Then you have either:
a. to select "Default" option (bottom right), or:
b. to select "New" and following the prompts to add the new .ini file to the list on the left and then to use "Select" option.

To counter-check open the same window via the TTX file (path: Menu/Tools/Tag Settings) and see which of the XML schema files is selected (it should be the .ini file received from the client). If it is not the case, select the right .ini file as described above.
Good luck.

[Edited at 2008-03-28 20:17]


Direct link Reply with quote
 

Sommersonne  Identity Verified
Sweden
Local time: 02:08
English to German
+ ...
TOPIC STARTER
TagEditor doesn't change ini-file Mar 29, 2008

Hi Alexey!

Thanks a lot for your detailed explanation. I meanwhile figured out that indeed in TagEditor itself the HTML ini-file is automatically choosen as soon as I open one of the ttx.files. I even tried removing all the other ini-files except for the project specific one but the HTMl-ini.file reappears as soon as I open the file for translation again and is set as applicable (standard?) ini-file. Unfortunately I have no idea how I can change that. I even set the project specific ini-file in Workbench as STANDARD already but it does not seem to help.


Direct link Reply with quote
 

Alexey Ivanov  Identity Verified
Russian Federation
Local time: 04:08
Member (2004)
English to Russian
How to change tag settings properties in "Tag Settings" window in TWB Mar 30, 2008

Stefanie Neubert wrote:
Unfortunately I have no idea how I can change that.


Hi Stefanie,

You are right TagEditor automatically selects the tag settings set in the "Tag Settings" window in TWB. Try to go through all the steps below:

1. Open Trados TWB/Menu/Options/Translation Memory Options/Tools/Tag Settings, and if you don't see your .ini file,
2. Click on "New" which will open the Tag Settings Wizard, and
3. Click on "Next" which will open the "Settings Name and Type" window. Give a name to the new Tag Settings Schema file (in this case it will be an .ini file). The name can be just any name (no extension, that will be assigned automatically at a later stage), and click "Next". That will take you to the "Import Tag Definitions" Window. Read the explanations there and click on "Import". That will take you to the "Select Files to Import Tag Defititions From" window. Browse to find the .ini file received from the client.
4. After you select your .ini file as the file for import, it will take you to the next window: "Import Tag Definitions" listing all the elements of this file, just click "OK" here. Again click 'OK". It will open a small window informing how many changes have been made and it will take you back to the "Import Tag Definitions" Window. Click on "Next in all the following dialog windows until you reach the last "Save As" window and save it under any name. You can save it under the same name as the file received from the client. But in this case you will be prompted that such file already exists, and you will be asked whether you want to overwrite the existing file, or save it under a different name. You can safely choose "Overwrite" a it is an identical file.
5. CLOSE TRADOS TAGEDITOR AND TRADOS TWB and open again. In Trados TWB "Tag Settings" window you will see the imported file. Select it and then select "Default" option from the list on the right.

That should do it. I had the same problem several times and following the above I successfully solved it.


Direct link Reply with quote
 

Sommersonne  Identity Verified
Sweden
Local time: 02:08
English to German
+ ...
TOPIC STARTER
finally solved! Mar 30, 2008

Hello Alexey!

Actually, already your first reply was the solution but thanks for the deeper insight into the functions of the TagSettings, it was surely of great help and I will be able to use these informations for the future!!!
After I followed your advices in your first answer, the final solution to the problem was that I had to delete the files for translation, download them again, put them into a new folder (giving them a new path) and then open them in TagEditor where the right ini-file was finally taken as standard-file for the Tag Settings (which I already had set in TWB). Without your help it probably would have taken me a couple of more days to come up with the solution!!!


All the best,

Stefanie


Direct link Reply with quote
 

Alexey Ivanov  Identity Verified
Russian Federation
Local time: 04:08
Member (2004)
English to Russian
You are welcome Mar 31, 2008

Hi Stefanie,

I am glad I could help.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

customer cannot open xml.ttx-files/has problems seeing the special charactes in .xml

Advanced search


Translation news related to SDL Trados





CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs