Mobile menu

Is there any way to change the font color in TagEditor?
Thread poster: Claudia Digel

Claudia Digel  Identity Verified
Germany
Local time: 08:25
English to German
+ ...
Mar 31, 2008

Hi all,

I have a problem which has been bugging me for a while and, unfortunately, I haven't been able to find a solution for this. Can anybody tell me if it's possible at all to change colors in TagEditor?

A client regularly sends me html documents for translation in TagEditor. These files contain white font on a black background. When I open the files in TagEditor, I get white text on a white background, which is not exactly easy to read (or rather completely illegible ). Things don't relly get better when I open the translateable segments because then I have white text on a light yellow background, which is just as bad.

Is there any way to change any color setting in TagEditor? - I don't really care what I change (background color of the entire window, background color of open segments or font color), as long as I end up with something that I can acutally read on screen. Unfortunately, I haven't found any way to do this.

Trados 8.2.0.835 on Windows XP SP2

Any help is highly appreciated.

Thanks and regards,
Claudia


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 09:25
Member (2003)
Finnish to German
+ ...
Don't bother Mar 31, 2008

Colors and fonts have nothing to do with your translation. They are coded in html and will appear when the file is saved as target and opened in your browser.
Regards
Heinrich


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 02:25
Member (2002)
English to Hungarian
+ ...
I can't reproduce the problem Mar 31, 2008

I am not sure I understand what kind of source files you are working with.
Are you getting an HTML file, and that file itself is saved with black background and white font? If that's the case, when you open it with Tageditor, all text shows up with black font on white background. The color attributes are going to be specified inside the tags only.
I just tried this, to be sure. So, since I can't reproduce the problem, I am just guessing here.

The only thing I can think of is that your Tag definition file is messed up, and that specifies these weird font colors.

Are you getting TTX files from this client? Are you using a special .ini files for this client?

Is this a problem with only this client?
Have you tried opening another HTML file with your Tageditor?

The Tag definition file specifies how certain parts of the TTX file displays on your screen. So, if the white text on black background only applies to certain parts of your text, then it is likely that the type of text defined there by the tags has those colors specified in the tag file.

Tageditor -> Tools -> Tag Settings
Where Root Element is HTML, that is the Tag def file for HTML.

If you look this up while you have the translatable doc open, you will see which one is in use.
Close the doc file, and go back to the tag Settings.
Then click on Properties, and look under Defaults, and then see the color setting there.
Next, look under elements, and see if any of those are set with black background. You can step through the list with the Down arrow and check the sample text.

The Predefined HTML settings that came with Trados does not have any elements set with black background.

(Disclaimer: I have SDL Trados 2006, so things may be a bit different on yours.)


Direct link Reply with quote
 

Sylvain Leray  Identity Verified
Local time: 08:25
German to French
Colours... Mar 31, 2008

Hi CLaudia,

I'm really surprised by the behaviour you describe, since TagEditor normally displays all texts in black, regardless of the colour in the source document (the colours are then set by the tags).

The only workaround I can imagine is to change the colour of the text in the source document without forgetting to set it back after translation. AFAIK, there is no such possibility to change displaying options in TE.

If I remember correctly, you are a SDLX user ? Perhaps you can use the Exchange utility to convert ttx into SDLX, translat and then convert back to ttx ? It works quite good !

HTH,
Sylvain


Direct link Reply with quote
 

Claudia Digel  Identity Verified
Germany
Local time: 08:25
English to German
+ ...
TOPIC STARTER
Seems to be an issue with the tags in the files Mar 31, 2008

Hi Katalin,

Thanks for your input.

Are you getting an HTML file, and that file itself is saved with black background and white font? If that's the case, when you open it with Tageditor, all text shows up with black font on white background. The color attributes are going to be specified inside the tags only.
I just tried this, to be sure.


Yes, this is what I get, and no, I'm afraid the text doesn't show up as black font on white background.

What I should have mentioned in my first post is that each and every string starts with a tag defining the font color. They all begin with a font color="#FFFFFF" size="1" face="Verdana, Arial, Helvetica, sans-serif" tag which makes the following text appear in white.

So, what I really need would be some kind of function that let's me set back the text after a tag to the default style, i.e. black text on white background.


@Sylvain: I do use SDLX and I know that the Exchange option is very reliable but I'd prefer a solution that I can use within TagEditor for a number of reasons. However, if there isn't any other option, I will surely resort to this one.

I hope this makes things a bit clearer.

Best regards,
Claudia


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 02:25
Member (2002)
English to Hungarian
+ ...
Which tag settings (.ini) file are you using for Tageditor? Apr 1, 2008

Claudia Digel wrote:


Are you getting an HTML file, and that file itself is saved with black background and white font? If that's the case, when you open it with Tageditor, all text shows up with black font on white background. The color attributes are going to be specified inside the tags only.
I just tried this, to be sure.


Yes, this is what I get, and no, I'm afraid the text doesn't show up as black font on white background.


What I should have mentioned in my first post is that each and every string starts with a tag defining the font color. They all begin with a font color="#FFFFFF" size="1" face="Verdana, Arial, Helvetica, sans-serif" tag which makes the following text appear in white.


But is should not.
If you are using a proper tag settings file, the font color tags should be treated as tags, and should not affect the text display in Tageditor.
I also do not understand the tags, those make text appear in Italics.

Could you please check what tag settings file you are using? I described in my previous post, how to do that.

Katalin


Direct link Reply with quote
 

Claudia Digel  Identity Verified
Germany
Local time: 08:25
English to German
+ ...
TOPIC STARTER
I have tried several ini files Apr 1, 2008

Hi Katalin,

I am using a tag settings file provided by the client. However, I have also tried other .ini files (among them Predefined HTML file) but the font color doesn't change, no matter what .ini file I use.

Sorry for confusing you with the italics in my previous post, I only put the actual tag in italics to highlight it - the tag displayed in TagEditor is

Code:
<font color="#FFFFFF" size="1" face="Verdana, Arial, Helvetica, sans-serif">



Sorry, if this wasn't clear.

I think, the problem might be that the font type and the font color are defined in the same tag. When font color and font type are defined in separate tags, everything seems to work fine - i.e. the color tag is not included into the translation segment and the text is displayed in black.

Does this make sense?

Best regards,
Claudia


Direct link Reply with quote
 

Roberta Anderson  Identity Verified
Italy
Local time: 08:25
Member (2001)
English to Italian
+ ...
Same problem - fixed with "Disable formatting for FONT tags" option Nov 17, 2009

Hi Claudia

I'm resuming this old thread because I have just come across the same behaviour:
I'm using TagEditor 2007 and Trados predefined HTML ini file with default Tag Settings for black text (Tag Settings Properties dialog > Defaults tab > Colour: black)
The strings preceded by tag "FONT COLOR = FFFFF" display as white and are therefore unreadable (in open segments, you can just about make out the source text on the light blue background, but the target white text on yellow backgound is totally unreadable).

After some searching I found the option that can fix this:
In Tools > Tag Settings, selct your ini file, click on Properties, go to the Elements tab, click on Advanced and select "Disable formatting for FONT tags" (about half way down the dialog).
Unfortunately this does not change the font display for existing ttx files, but if you convert the original source file to ttx again, you will see that all text is now displayed as black.

Hope this will help anyone who will come up against the same issue!
Roberta

[Edited at 2009-11-17 15:37 GMT]


Direct link Reply with quote
 

Anna Sylvia Villegas Carvallo
Mexico
Local time: 00:25
English to Spanish
This might help Nov 17, 2009

I'm not sure, but it might!



Direct link Reply with quote
 

Wilmer Brouwer
Netherlands
Local time: 08:25
Member (2006)
English to Dutch
+ ...
My solution Feb 4, 2010

Just in case anyone is reading this in the future, I solved this by opening the file in notepad. Search for "ffffff" and replace that with "111111". Open the file again. Everything should be black now.

Direct link Reply with quote
 

Rob Latchford
United Kingdom
Local time: 07:25
Member (2011)
French to English
+ ...
Change properties to your tag settings file Nov 29, 2010

Just to confirm that Roberta Anderson's solution works and is the best option to avoid altering the original file.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Is there any way to change the font color in TagEditor?

Advanced search


Translation news related to SDL Trados





memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs