Mobile menu

Problem with diacritic signs in Trados
Thread poster: mari pet

mari pet  Identity Verified
Spain
Local time: 12:24
Member (2012)
Spanish to Slovak
+ ...
Apr 5, 2008

Since some months I have problem with diacritic signs in Word document when I open tag in Trados, make translation and close the tag, some (almost all) diacritic signs in source (Polish) and target (Slovak) texts change into another signs which doesnt exist in these languages. I always have to correct it after cleaning up the document, but it costs the time... Maybe somebody have an idea what to do or what to change in settings?
Thanks


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 12:24
Member (2003)
Polish to German
+ ...
Version of Trados? Version of the document? Languages set? Apr 5, 2008

In general: the local formatting in Word must match the styles and the target language in the document must be properly set both local and in styles.
Such changes has been discussed and described in this forums numerous times.
Just please search this forum for "font changes" or "corrupted charatecrs" and you will find a lot of usefull tips for that.
The best tip I can give you is to switch to Tageditor and forget about all problems.

Regards
Jerzy


Direct link Reply with quote
 

mari pet  Identity Verified
Spain
Local time: 12:24
Member (2012)
Spanish to Slovak
+ ...
TOPIC STARTER
Trados 6.5, Office 2003 Apr 5, 2008

Hello,
I use Trados 6.5, but I am more beginner than advanced user. I changed style settings, but what I dont know is how to set the target language in the style. In the style I have Arabian and Polish. Maybe it is stupid question, but how to remove Arabian from the style? Because it appears also after opening new document in Word.

Many thanks in anvance.
marianna


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 12:24
Member (2003)
Polish to German
+ ...
Not a stupid question at all... Apr 6, 2008

And of course the real reason for your trouble - the Arabian language in the style.
You can only get rid of it, if you rebuild exactly the same style in a clean document, created on your PC.
For example, if your document has for example styles based only n the "Standard" (Normal or hovewer it is called), what you need is to copy this style (so a style with the name "Standard", "Normal" or so) from a clean and empty document into your document, which is to be translated.
You need the "Organiser" function for that.
To go there, press ALT+F8, you will see this:

Here press "Organise" or however it is called in your Word.
You will see this:


There you can organise styles - on the left side you have styles in your current document, on the right styles in your reference document. You can open there any document you need. So just create a new one on your PC. Then rebuild styles from your document there, using exactly the original names and attributes of the styles.
Then copy the styles from your reference document into your document to be translated. This way the styles there will be overwritten and the Arabic language canceled.

This is not very easy to describe, but quiite easy to do. You can learn this in our SDL Trados training sessions, which will take place in Poznań on April 25 and 26, than in Cracow on May 30 and 31, possibly Wrocław on June 1 and 2, and then in Warsaw on June 20 and 21. You can already register for Poznań here.

Regards
Jerzy

[Edited at 2008-04-06 11:51]


Direct link Reply with quote
 

Katalin Horváth McClure  Identity Verified
United States
Local time: 06:24
Member (2002)
English to Hungarian
+ ...
It happened to me once, too - Office Language Settings Apr 6, 2008

mari pet wrote:
Maybe it is stupid question, but how to remove Arabian from the style? Because it appears also after opening new document in Word.


Something similar happened to me once, too.
I resolved the problem by doing this:
Start menu -> Programs -> Microsoft Office -> Microsoft Office Tools -> Microsoft Office 2003 Language Settings

Open this, and look at the window on the right side. This shows the enabled languages. I had a whole bunch of weird languages set here, after I removed everything except the languages I needed, everything was OK.

I am not sure that your problem is the same, but it may worth a try.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 12:24
Member (2003)
Polish to German
+ ...
OLS will not help here Apr 6, 2008

Due to the fact, Arabic (or other non-european) language is in the styles.
In this case Word sees diacritic characters, which need another code page, than the standard one, than it takes into account, that a non-european language is needed, so it changes the CP to one suitable for this language - and the characters get corrupted. At least this is how I understand the behaviour, which I know since I started to use Trados many years ago.
In any case replacing the styles with ones without this non-european language helps. Or the better way is to use Tageditor, but for that you need a more recent version of Trados.

Your solution with Office Language Settings is however a nice one, as it helps for less "heavy" cases.

Best regards
Jerzy


Direct link Reply with quote
 

Wojciech Froelich  Identity Verified
Poland
Local time: 12:24
English to Polish
Ones and threes in supersript? Apr 6, 2008

mari pet wrote:

Since some months I have problem with diacritic signs in Word document when I open tag in Trados, make translation and close the tag, some (almost all) diacritic signs in source (Polish) and target (Slovak) texts change into another signs which doesnt exist in these languages.


What are these signs? Are there any ones and threes in superscript? AFAIR they might appear instead of Polish ą and ł.


Direct link Reply with quote
 
Daniel García
English to Spanish
+ ...
Add Arabic to your Office Language Settings Apr 6, 2008

In case it helps, I have had similar problems in the past.

We received document which, for some reason, had Japanese added to the styles of the document and this caused corruption for some Eastern European languages.

Our solution: Ask the translators who were having problems to enable Japanese in their Office Language Settings, even if they don't work with Japanese at all.

It is strange but this was the solution to the problems we had with those documents.

In your case, try adding Arabic to the list of your enabled languages through Microsoft Office Language Settings, reboot the PC and see if you still have the problem.

Daniel

PS. I also wanted to add that making sure that you have "Arial Unicode MS" font installed will also help, even if you don't use it. If you don't see it, you can install it from your Microsoft Office CD.

[Edited at 2008-04-06 18:32]


Direct link Reply with quote
 

mari pet  Identity Verified
Spain
Local time: 12:24
Member (2012)
Spanish to Slovak
+ ...
TOPIC STARTER
I think I partially solved the problem Apr 6, 2008

In Office Language Settings I removed (now it wasnt Arabic) one non-european language (I dont remember which was) and maybe because I before set the styles in the document to translate, now display correct signs in the target language - Slovak (at least). In the origin language still happens the corruption (@Wojciech: yes these are the superscript numbers, ¿, æ etc.), but the target language is more important for final effect
I am not sure about Organizing the styles, and prefer not put wrong anything, so I leave it for the next time.
Jerzy, I also thought about the Trados training, so maybe there I will learn how to do it. However, Krakow is nearer for me, so I will wait a bit.


Many thanks to everybody for your help,
marianna


Direct link Reply with quote
 

Wojciech Froelich  Identity Verified
Poland
Local time: 12:24
English to Polish
Could you check the exact build number? Apr 6, 2008

Could you simply go to Workbench, Help, About dialog and check your Workbench build?
Older 6.5 builds had nasty bug related to CE languages.


Direct link Reply with quote
 

mari pet  Identity Verified
Spain
Local time: 12:24
Member (2012)
Spanish to Slovak
+ ...
TOPIC STARTER
build number Apr 7, 2008

build number 438 (6.5.5.438)

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem with diacritic signs in Trados

Advanced search


Translation news related to SDL Trados





Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs