Mobile menu

Multiterm turns Swedish letters å ä ö into symbols •
Thread poster: Susanne Lomander

Susanne Lomander  Identity Verified
Sweden
Local time: 11:18
Swedish to English
+ ...
May 7, 2008

I have just managed to convert an Excelsheet and import it into Multiterm 2007 (7.5.0.444 (Build 448), but when I open it in MT all the Swedish letters å ä ö have been turned into symbols (squares), in all 1266 entries!

The process was long and arduous, as I had to uninstall + reinstall MT + Trados to remove error messages in Convert, but this is what I did:

1) Exported old termbases into Excel
2) Fixed them up into proper columns with the first row as headings
2) Opened in Excel 2007 and saved as .csv files (as per MT 2007 manual)
3) Converted them using MultiTerm convert (spreadsheet format)
4) Created a new termbase in MT using the same database definition from the conversion
5) Imported the xml-file created in the conversion into MT

First I thought the error was because the index fields were stated as sublanguages (EN-US, SV-SE etc) in the convesion database definition and I removed those language denominations when creating the dabase and exchanged them for non-sublanguage fields EN and SV instead (that's how I want it). But I repeated the process leaving the sublanguage definitions under "Available index fields" and the result was the same.

Now I don't know if the error takes place during MultiTerm Convert or the actual importing, but in the CSV file everything is correct.

Anyone know how to solve this?

Thanks!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:18
Member (2003)
Polish to German
+ ...
Do not save as CSV! May 7, 2008

CSV does not support special diacritics, as the Swedish for example (or Polish).

Just convert the Excel sheet saved as XLS and things should be perfect.
You can find a brief description of the conversion of Excel file to Multiterm here.

BR
Jerzy

[Edited at 2008-05-07 18:00]


Direct link Reply with quote
 

Susanne Lomander  Identity Verified
Sweden
Local time: 11:18
Swedish to English
+ ...
TOPIC STARTER
If I use just XLS files, I get another bigger error message May 7, 2008

Hi Jerzy,

Thanks for your response and pdf-guide, which I reviewed (I had done all the steps correctly, thank goodness!).

But according to the Multiterm 2007 User Guide (page 66, Section 2 - converting Terminology data to Multiterm XML), it says to convert Excel 2007 files to *.csv format. Only Excel 2002+2003 are supported, and if you have Excel 2000 (I have 2000+2007), you must prep the files by saving them as a tabdelimited text file .txt, open it in a Unicode text editor (?) and save as a UTF-8.

Now, having only Excel 2007 and Excel 2000, I chose to save as .csv and try converting using format alternative 5 in Multiterm Convert step 3/7 (spreadsheet or database exchange format). This gave me the garbled åäö.

I have also tried just saving it as .xls and selecting format alterantive 6 (Microsoft Excel format), but then all hell broke loose and I got a huge error message..

Assertion Failed: Abort=Quit, Retry=Debug, Ignore=Continue
Opening: Attempted to read or write protecte memory. this is often an indication that other memory is corrupt.

at ExcelREader.InitREader()
at ExcelReader...ctor(String fileName)
at ExcelToMtiX.InitReader() ..... and so one for another 15 rows (I have an image I can email you if you want).

This may be because it was in Excel 2000 format, but it seems I am screwed, if you are indeed correct about .csv not accepting diacritics. I only have 2007 and the .csv import creates garbled Swedish (even though the Swedish words in the .csv file are fine); saving them as .txt creates the same garbled results, and trying just XLS as you suggested creates the above error message.

What do I do now? =(

*************

Actually, I downloaded NotePad2, supposedly a Unicode-enabled text editor, opened the .txt file in that and changed the coding to UTF-8, saved it and then converted that file using Multiterm Convert, and it worked!

Some workaround, but at least I have a result that doesn't garble my Swedish!

If someone else has a better suggestion, let me know. Otherwise, this seems to be what is required to transform a simple Excel sheet to Multiterm nowadays.... Ridiculous!! =l



[Edited at 2008-05-07 19:53]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:18
Member (2003)
Polish to German
+ ...
What you do is sending me the file May 7, 2008

and I'll save it for you in Excel 2003 format.
This will most probably solve all your problems.
Please send Excel 2000, not 2007.

My email is info at doku minus trans dot de

BR
Jerzy


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:18
Member (2003)
Polish to German
+ ...
CSV is text-only format May 7, 2008

and thus it does not save the diacritics, which are outside of the ridiculous 128 bit character set (or was it 258 bit, but what does that matter?).
I often have this problem, when people send us csv files for translation.

My soultion for working with SDL Trados was Office 2003 - and after what I've read here and in some other topics here on ProZ I will keep this as long no once forces me to upgrade to 2007! And above all I will stick to my good old Windows XP Pro


Direct link Reply with quote
 

Peter Linton  Identity Verified
Local time: 10:18
Member (2002)
Swedish to English
+ ...
UTF-8 is standard practice May 7, 2008

Susanne Lomander wrote:
. . . and if you have Excel 2000 (I have 2000+2007), you must prep the files by saving them as a tabdelimited text file .txt, open it in a Unicode text editor (?) and save as a UTF-8.

I agree it is not very user-friendly, but once you have discovered the procedure, it is straightforward enough. I use Excel 2000 and have converted several Swedish to English glossaries in this way, complete with the correct Swedish characters.

The easiest solution is of course an Excel 2000 XLS file, though I recently discovered that is not supported in later versions of Trados. Instead you have to handle it as a database file in MultiTerm Convert.

I don't think you need a Unicode editor - just an editor that allows you to save a text fuile either in ANSI or UTF-8. I use Uedit, which can also save in Unicode, and is much more versatile than Notepad..


Direct link Reply with quote
 

Susanne Lomander  Identity Verified
Sweden
Local time: 11:18
Swedish to English
+ ...
TOPIC STARTER
Thanks for your replies! May 8, 2008

Thank you Jerzy and Peter, for helping me find my way. I think I am finally on the right track!

As you say, Peter, once you have all the steps down pat, it is pretty straight-forward. Although I can't help but wish it were easier, to just select Microsoft Excel format in Multiterm Convert and be done with it!!! =)


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Multiterm turns Swedish letters å ä ö into symbols •

Advanced search


Translation news related to SDL Trados





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs