TagEditor doesn't recognize combo boxes in XML
Thread poster: Doron Greenspan MITI

Doron Greenspan MITI  Identity Verified
Israel
Local time: 19:52
Member (2005)
English to Hebrew
+ ...
May 18, 2008

I've just translated quite a few XML files in TagEditor, easlily and successfully. The client provided a tag settings file, and I used it without a hitch.

However, I realize now that TagEditor missed several text elements, under 'combo' tags.
For example, the word "before" in the following example (for a single tag text) wasn't offered for translation in TE:

[I can't send xml tags here, so I'll say it in words:

the xml tags: select value="before",
inside "items",
inside "combo",
inside "item"

They also don't show on Word, when Saved as Target.

How do I translate these then?

Thanks, Doron

[Edited at 2008-05-18 12:07]

[Edited at 2008-05-18 12:10]


Direct link Reply with quote
 

tectranslate ITS GmbH
Local time: 18:52
German
+ ...
Your client sent a suboptimal settings file then May 19, 2008

In the tag settings, you can define the attributes for each element that require translation. Seems the client forgot to do that for the "combo" attribute.

Sans tags, I can't quite picture what your XML structure is like, but you should be able to change the setting based on the info given above. If not, please let us know.

HTH,
Benjamin


Direct link Reply with quote
 

Doron Greenspan MITI  Identity Verified
Israel
Local time: 19:52
Member (2005)
English to Hebrew
+ ...
TOPIC STARTER
I played with the settings file quite a lot, but May 19, 2008

couldn't get these tags' content to show.

Under time pressure I simply went to the target XMLs and did the translation there. Since the client only wanted these anyway, it's not so bad, only tedious...

Next time I'll check incoming XML files more carefully, and demand a good settings file in advance.

Thanks, Benjamin!

Doron


Direct link Reply with quote
 

Wojciech Froelich  Identity Verified
Poland
Local time: 18:52
English to Polish
Have you re-converted XML with new settings? May 19, 2008

Have you re-converted XML with new settings? You have to do that, changing settings in INI file will not affect TTX files that were created with different INI settings.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TagEditor doesn't recognize combo boxes in XML

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums