Mobile menu

TagEditor not showing metadata
Thread poster: michiko tsumura

michiko tsumura  Identity Verified
Canada
Local time: 19:21
Member (2006)
English to Japanese
May 22, 2008

Hi everyone,

I have recently translated htm files using TagEditor. I opened the files using TagEditor, opened each segment and translated them, cleaned the files and sent them back to my agency.

The agency came back to me saying I've missed metadata. This is actually the second time this happened.

Why my TagEditor doesn't show (or open) metadata? I'm guessing it's some sort of setting problem. Does anyone have an answer for me?

Thanks!


Direct link Reply with quote
 
xxxOlaf
Local time: 03:21
English to German
You might need to change the tag settings May 22, 2008

I'm assuming that the customer was referring to the metadata at the beginning of the document. Metadata might be document specific and they're hidden by default, because many of them don't need to be translated.
If the metadata wasn't shown as translatable you'll need to change the tag settings. You may want to ask the agency which metadata in particular should be translated. They also might have already defined a customized Tag Settings INI file that exposes these tags for translation.
If not you'll need to add the tag definitions in Tag Editor. To do that open Tag Editor and double-click the line that starts with Predefined HTML settings. Then click the Elements tab, double-click the HEAD entry and then click the Attributes tab and add the elements that need to be translated. For more information refer to the context-sensitive help.

Olaf


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 21:21
Partial member
Spanish
+ ...
Metadata May 22, 2008

Hello,

First of all you have to be VERY careful, you don't want to mess up the settings. Also, you need to know what part of the metadata you need to translate.

Depending on the kind of information you want to translate (it's usually the description, keyword), you can modify what part of the metadata information can read as translatable text. You could modify your existing HTML settings, although I strongly suggest you don't, it's better to create a new one.

Go to Tag Settings>New. Click next and select a name for the new set of settings, select New Settings for SGML/HTML and click Next. In the Import Dialog, click on Import and select HTML4.ini. The location of the ini files is under File Name. Click OK to accept the definitions. Select Next twice until you get to the 4th step: Elements and Attributes; scroll down to META and click Properties. Go to the Attributes tab and select 'content'. Click OK and Finish. Give it a name and save it. Select the setting you just created and open your file. The contents of the metadata should be visible now.

I don't know if there's a better way to do it, but this is how I do it.

Good luck,

Claudia


Direct link Reply with quote
 

michiko tsumura  Identity Verified
Canada
Local time: 19:21
Member (2006)
English to Japanese
TOPIC STARTER
Metadata settings May 23, 2008

Olaf, Claudia,

Thanks so much for your quick reply. I've tried to do tag settings and to be honest with you, haven't been able to make metadata translatable yet...I'm pathetic.

However, I think that I now know what I should be looking at. I have created a new tag setting as instructed and I'll try to do a few things with it.

Thanks for your help. I'm still a Trados beginner so it is very much appreciated!

Michiko


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 21:21
Partial member
Spanish
+ ...
The highway... May 23, 2008

If you want to just modify your existing HTML settings, just go to Tag Settings, double click on Predefined HTML Settings, go to the Elements tab, and keep going from there:

Claudia Alvis wrote:

Elements and Attributes; scroll down to META and click Properties. Go to the Attributes tab and select 'content'. Click OK and Finish. Give it a name and save it. Select the setting you just created and open your file. The contents of the metadata should be visible now.


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 03:21
English to Czech
+ ...
Metadata May 23, 2008

Hi Mitchiko,
first of all, if you are translating the files for an agency, then it should be THEIR responsibility to prepare a correct INI file for you to use.
Anyway, you can open the HTML file in any text editor (such as the Notepad in Windows) and edit the metadata manually there. All metadata are in fact tags with the following structure:

meta name="name_of_metadata" contents="translatable text"

A practical example:

meta name="keywords" contents="translation, translations, Japanese translations, reliable Japanese translations"

In the above example you would edit "translation, translations, Japanese translations, reliable Japanese translations".

Hope this helps.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TagEditor not showing metadata

Advanced search


Translation news related to SDL Trados





Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs