Mobile menu

Trados changes fonts
Thread poster: Elena Ghetti

Elena Ghetti  Identity Verified
Italy
Local time: 23:00
Member (2003)
English to Italian
+ ...
May 7, 2003

Hi, I hope this has not been discussed yet, I tried a search in the forums database but couldn\'t find anything.



I received an .rtf document created by S-tagger (exported from FrameMaker). whenever the segment starts with an Trados changes the style to an horrible SimSun font, which also modifies Italian letters with accents and obliges me to reopen the segment everytime to restore the original font and accents - does anybody know the problem and do you have a solution?

thanks!

Elena





Update - no it does change also units not starting with , I still have not understood the reason why certain segments are modified and others are not... help



[ This Message was edited by: ely4581 on 2003-05-07 21:29]


Direct link Reply with quote
 

Jerónimo Fernández  Identity Verified
English to Spanish
+ ...
Try in this forum May 8, 2003

Hiya.



I don\'t know the answer, but maybe somebody at http://groups.yahoo.com/group/TW_users/ can help you.



I hope this helps.


Direct link Reply with quote
 

Marijke Mayer  Identity Verified
Netherlands
Local time: 23:00
Dutch to English
+ ...
I leave it and change it ater May 8, 2003

I know that Trados has this horrible problem! You might try and make the desired font the standard font in Trados, if it can be done at all like in Word.



Good luck!

Marijke


Direct link Reply with quote
 
lilijana
Croatia
Local time: 23:00
French to Croatian
+ ...
same problem May 28, 2003

Marijke Mayer wrote:

I know that Trados has this horrible problem! You might try and make the desired font the standard font in Trados, if it can be done at all like in Word.

Good luck!
Marijke


Direct link Reply with quote
 

Alaa Zeineldine  Identity Verified
Egypt
Local time: 23:00
Member (2002)
English to Arabic
+ ...
Has this been resolved? Jul 3, 2004

While this thread seems quite old, I am experiencing the same problem now while translating into Arabic. The font in the Word file seems fine when I close the translation unit, but when I display the TU through Workbench using Concordance or Maintenance, most of the translated text appears in simsung. A cleanup later updates the Word file with Simsung and renderes it unreadable.

Any ideas?


Direct link Reply with quote
 

Elena Ghetti  Identity Verified
Italy
Local time: 23:00
Member (2003)
English to Italian
+ ...
TOPIC STARTER
File > Setup > Fonts Jul 4, 2004

It is not a final solution, but with me it works 95% of times.
In File > Setup > Fonts set the main font of your document as "source default font" and "target default fount", then tick the box "translate into target default for all other fonts. If necessary set fonts which you don't want changed into target default under the window "font translation list".
good luck!!
Elena


Alaa Zeineldine wrote:

While this thread seems quite old, I am experiencing the same problem now while translating into Arabic. The font in the Word file seems fine when I close the translation unit, but when I display the TU through Workbench using Concordance or Maintenance, most of the translated text appears in simsung. A cleanup later updates the Word file with Simsung and renderes it unreadable.

Any ideas?


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:00
Member (2003)
Polish to German
+ ...
Set the styles in your document properly Jul 4, 2004

Alaa Zeineldine wrote:

While this thread seems quite old, I am experiencing the same problem now while translating into Arabic. The font in the Word file seems fine when I close the translation unit, but when I display the TU through Workbench using Concordance or Maintenance, most of the translated text appears in simsung. A cleanup later updates the Word file with Simsung and renderes it unreadable.

Any ideas?


Prove, if the font and language in your document do match the settings of the corresponding style. If you get SimSUN font, this means, you got your document from some Asian country. I have no patented solution for such case, as it depends strongly, on what happens in your document. What I would not do, is to advise Trados to change any fonts, as this mostly does not bring the necessary results.
If your translation appears OK, do not clean in the Workbench, but clean in Word. Or if you clean up in Workbenc, don´t let your document to be updated, but choose "uptade TM" instead.

This problem has ben often dealt with here on ProZ and there are some proposed soultion in other threads - try the search function.

Regards
Jerzy


Direct link Reply with quote
 

Alaa Zeineldine  Identity Verified
Egypt
Local time: 23:00
Member (2002)
English to Arabic
+ ...
Need clarififation Jul 5, 2004

Jerzy Czopik wrote:

If your translation appears OK, do not clean in the Workbench, but clean in Word. Or if you clean up in Workbenc, don´t let your document to be updated, but choose \"uptade TM\" instead.

This problem has ben often dealt with here on ProZ and there are some proposed soultion in other threads - try the search function.

Regards
Jerzy


Thanks Jerzy. The file was sent to me from a US agency, but I believe that it does a lot of business with Asian languages.

What did you mean by cleaning in Word instead? The one thing I did with a previous document was to edit the document in Word and remove the source text and tags using edit/replace, a fairly laborious and error prone process with a large document. Is there an automated way to clean the document in Word?

Thanks again.


Direct link Reply with quote
 

Alaa Zeineldine  Identity Verified
Egypt
Local time: 23:00
Member (2002)
English to Arabic
+ ...
Cleaning in Word Jul 5, 2004

I found out how to clean in Word based on a global search and replace for hidden font http://office.microsoft.com/assistance/preview.aspx?AssetID=HA010349061033&CTT=6&Origin=EC010553071033.

I will continue this project without Trados since most of the saved TUs are useless anyway. I sent a report to Trados support and will see if they come up with a solution for the future.

Thanks Elena and jerzey for your help.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 23:00
Member (2003)
Polish to German
+ ...
Cleaning in Word Jul 5, 2004

Just use the Trados macro.
Press ALT+F8 and select tw4winClean.Main and let it run.
You will need to clean all footers and headers in this way too, as it does this not in automated way. The same applies to text boxes.
Be aware, that your TM will NOT be updated, so you better clean up in this way after any changes in your translation are saved in the TM.
The advantage is, that you do not save the whole document as RTF, what usually causes a lot of problems.

Regards
Jerzy


Direct link Reply with quote
 

Raphael Schory
Local time: 00:00
English to Arabic
+ ...
This is the truly the definite solution Dec 23, 2009

Elena Ghetti wrote:

It is not a final solution, but with me it works 95% of times.
In File > Setup > Fonts set the main font of your document as "source default font" and "target default fount", then tick the box "translate into target default for all other fonts. If necessary set fonts which you don't want changed into target default under the window "font translation list".
good luck!!
Elena


As to the fonts question, this is the best (if not the only true) solution. One must, however, take into account the strings that were already screwed up. Sometimes (more often then never...) they have to be fixed through the TM itself, by opening the corrupted string from the concordance or the maintenance window, then Edit Segment, then copying the content into Notepad, for example, then copying it back to the TM's Advanced Edit window, then saving it (after putting the tags back in order of course).

As to the new strings, according to the solution quoted above, they're expected to be OK, but occasionally the font does change, due to some other reasons, which are obscure to me, but this can also be solved. Sometimes Copy Source helps, and sometimes pressing backspace in the column (place in the string) where the font changes solves the problem as well.

Also, when importing/exporting/exchanging TMs, the File > Setup > Fonts > Translate into target defautl etc. setting clears itself, thus it must be checked when opening an imported/exchanged TM to ensure that it's ticked.

The danger of unchecking it is much worse than simply font changes. These font changes subsequently cause the TagEditor to insert extra spaces in the string, doubling them each time the string is opened, till there are to many spaces, which cause the TE to crash.

Personally, I've tried all this on Arabic and Hebrew and it works excellent.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados changes fonts

Advanced search


Translation news related to SDL Trados





SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs