Mobile menu

Pages in topic:   [1 2] >
Macro not found or disabled??
Thread poster: Nicole Y. Adams, M.A.

Nicole Y. Adams, M.A.  Identity Verified
Australia
Local time: 02:21
Member (2006)
German to English
+ ...
Jun 26, 2008

Hello,

I have searched the forums and found some similar questions but no solutions, so I'm posting a new topic. (If I have overlooked something could you please point me in the right direction, thanks.)

I am using Vista, MS Word 2003 and SDL Trados 2007. Since yesterday I have not been able to use Trados with Word, I get the following error message:

***

"The macro cannot be found or has been disabled because of your Macro security settings.

This message can appear if:

The macro was deleted from the template.
The template was not loaded or referenced in the Templates and Add-ins command.
The macro was turned off by the macro security settings of your system.
If the macro security settings are not allowing the macro to run, you should confirm the origin of the macro to be sure it can be trusted (contact the developer or the source for the macro). You can temporarily lower your macro security level to Medium, close the file, and then re-open it and enable each of the macros that you want to run. If you do change your macro security settings, be sure to raise them again after you accept the macro or trust the template the macro is stored in (usually requires copying the template to the same folder as other trusted templates).

If the macro is not accessible because the template is not loaded, click Tools | Templates and Add-ins and browse to the template and click either Attach or Add. If the macro is not in the template, you may need to copy the macro from one template to another. Click the Organizer button at the bottom of the Templates and Add-ins dialog to start the Organizer utility."

***

I have already set the macro security settings to medium, but I am not a macro expert and really don't know what to do, i.e. which macros to enable etc.
Under Templates & Add Ins I see Trados7.dot ticked.
One of the suggestions I found when googling mentions the start up folder. In my case this folder is empty, should there be something in it??

I would urgently need to use Trados in Word, so any suggestions would be much appreciated. (But as I say, I'm not a macro expert, so please could you give me the Macro for Dummies explanation.) Thank you!


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 17:21
English to Czech
+ ...
Security Center Jun 26, 2008

Hi Nicole,
have you tried lowering the macros security within the Vista Security Center? I am using XP, so I can't give you a more precise description, but I know that high macro security setting in the Vista Security Center might be causing your problem.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 17:21
English
Trados8.dot... Jun 26, 2008

Hello Nicole,

You seem to be using an old Trados template, please follow these instructions in order to fix this problem:

1. Please locate the Trados8.dot template file in:

C:\Program Files\SDLInternational\T2007\TT\Templates and copy the Trados8.dot file.

Then go to C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Word\Startup
and copy the Trados8.dot file over.

Note: Please delete any other Trados templates, such as Trados7.dot.

2. Go to C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Templates
and delete the normal.dot file

Restart Word 2007

I hope this helps.

Many Thanks,

Gareth Powell
SDL Support Team

[Edited at 2008-06-26 14:54]


Direct link Reply with quote
 

Nicole Y. Adams, M.A.  Identity Verified
Australia
Local time: 02:21
Member (2006)
German to English
+ ...
TOPIC STARTER
Thank you!! Jun 26, 2008

Hello Gareth,

Thank you very much for your suggestion.

It worked and all is well again.

Thanks a million!

Nicole


Direct link Reply with quote
 
Vincent Knobil
France
Local time: 17:21
English to French
Same problem, fix doesn't work... Nov 11, 2008

I'm seeing the same error message.

I'm using SDL Trados 7.5.0.759 and Office 10 (on XP SP2).

I've tried the fix suggested above, using the Trados7.dot from the TT folder. To no avail.

Any other ideas?

Thanks in advance,

Vincent.

[Edited at 2008-11-11 08:53]


Direct link Reply with quote
 

Suzanne Smart  Identity Verified
United Kingdom
Local time: 16:21
Italian to English
+ ...
Salme problem, cannot find those files! Oct 13, 2009

Please help me! I need to send a job tomorrow morning and I cannot get Trados to work. it was working fine all day until about an hour ago when it crashed and now is giving me the error message: The macro cannot be found or has been disabled because of your Macro security settings.
I cannot find the files that Gareth cites. I don't seem to have any files called App Data or Roaming nor do I have a templates file under SDL.
I am using windows XP, Word 2007 and Trados 7 Freelance.


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 17:21
English to Czech
+ ...
Have you searched your HDD? Oct 13, 2009

Hi Suzanne,
have you tried the Windows Search or any other HDD searching tool? If you installed Trados properly, the files must be located somewhere on your HDD, unless you deleted them manually. Also, please make sure the respective folders are not hidden.


Direct link Reply with quote
 

Suzanne Smart  Identity Verified
United Kingdom
Local time: 16:21
Italian to English
+ ...
sorted! Oct 13, 2009

No worries, I've managed to sort it now. The solution that Gareth gave was absolutely correct, my files were in a different place for some reason and it took me ages to find them!

Direct link Reply with quote
 
Michael McCain  Identity Verified
France
Local time: 17:21
Arabic to English
+ ...
SDL MultiTerm Desktop 2009 "MS Word integration" component was the cause in my case Nov 3, 2009

I removed "MS Word integration" and Word is working again.

I have Vista and Microsoft Office Word 2007.

Has anyone had success with MultiTerm Desktop 2009 and Vista/Word 2007?

Michael


Direct link Reply with quote
 
Macro cannot be found or has been disabled because of your macro Settings Feb 8, 2011

Windows 7 64bit and Office 10 64bit
I receive the above message and after trying many different suggestions, it was suggested that I rename my normal.dotm folder so that word would recreate a new one. This also did not work, but lead me down the path to another file AVWiz12s.dotm, I deleated this file and rebooted my computer and actually had to unplug is as it began to start and stop. After replugging in the computer came up and was fine. Turns out I had download Avery Wizard prior to the install but it only works on Office 10 32bit. So check all your addins they may be the culprit in the error above


Direct link Reply with quote
 

Kathleen Misson  Identity Verified
Spain
Local time: 17:21
Member (2009)
Spanish to English
Office 2010/Trados 2011 Apr 23, 2012

I had the same error message popping up three times every time I opened Word.

As well as another message when I closed Word...

Object library invalid or contains references to object definitions that could not be found.

I was also unable to load the word 2.0 spellchecker in tageditor.

I went into this folder...

C:\Users\(username)\AppData\Roaming\Microsoft\Word\STARTUP

And moved these three files...

MultiTerm9.dotm
TRADOS8.dot
TRADOS8.dotm

Into a new folder (named 'old') in the same directory.

Fingers crossed, it all seems to be ok now.


Direct link Reply with quote
 
TRADOS latest SP Apr 23, 2012

I just uploaded the latest SP for TRADOS (so I am now on 10.1.2878.3) and I have lost my WORD integration just as others have described. I deinstalled and reinstalled from the TRADOS download I had stored, taking it back to 10.1.2861.1, but still no joy. Any ideas? Should I go back to their website and download again from the beginning?

Direct link Reply with quote
 

Claudia Schreiner  Identity Verified
Austria
Local time: 17:21
Member (2009)
English to German
+ ...
macro problem solved Jun 26, 2012

I'm so grateful for this forum! Thank you Kathleen for your precise description of how to stop this macro-problem. I was about to despair. But luckily I found your very useful advice.

Direct link Reply with quote
 

LEXpert  Identity Verified
United States
Local time: 11:21
Member (2008)
Croatian to English
+ ...
Same issue solved - but with MultiTerm Jun 26, 2012

Thank you Kathleen - and Gareth. In my case it was the MultiTerm template that was causing the problem.

Direct link Reply with quote
 
Karen Henke  Identity Verified
Local time: 17:21
Member (2006)
English to German
+ ...
Another perspective Jun 29, 2012

Hello!

I had the same problem with Win7 and Trados 2007 Freelance - in my case I also got other errors (object librairy not found/not valid - not the precise wording).

This was linked to a recent Security Update - and I removed all files ending on .exd from my system (intensive search).

After that the problem with the macro was gone as well - so maybe this is linked somehow.

I hope that this is helpful ...

Kary


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Macro not found or disabled??

Advanced search


Translation news related to SDL Trados





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs