Mobile menu

I cannot open multiterm 2007 database in word 2007
Thread poster: Zhengli Zhou
Zhengli Zhou  Identity Verified
Local time: 21:08
English to Chinese
+ ...
Aug 15, 2008

When I tried to open database in word 2007, I could not find my own database in the selection except the sample database. How can I add my database to the selection box? Thanks for any suggestion.

Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 14:08
French to Polish
+ ...
Bug in the MultiTerm design... Aug 15, 2008

Zhengli Zhou wrote:

When I tried to open database in word 2007, I could not find my own database in the selection except the sample database. How can I add my database to the selection box? Thanks for any suggestion.


It's a bug in the Multiterm design due to a lack of competence and imagination of MultiTerm architects.
It takes at least 7 years the bug is still not corrected.

ORIGINE

I start my mantra...
The guy who decided to put the MT files in the [Documents and Settings]/[Users]\All Users was an idiot.
The path is hardcoded, you can't change the MTMaster.mdb file location (it was intended in order to prevent the termbases sharing and force the MT Server sales).

EXPLANATION

The problem is this folder should be used only for administrative/shared data (read only for standard users).
So, if your users rghts are insufficient, you can't write nothing in the MTMaster file.
As all the information Word needs is stored in the MTMaster, you see the effect...

XP

The Win XP typical scenario was a message "Cannot complete the termbase creation" or something like this.
It was sufficient to grant the full control rights to the specific user for the
"C:\Program Files\SDL International\MultiTerm\Termbases" folder and for all the files in this folder.

VISTA

In Vista, the situation is more complex.
MS introduced the User Account Control (UAC) feauture (intended to prevent the execution of some tasks without the explicite user confirmation in order to prevent virus proliferation etc.).
So, even if you have sufficient rights, it blocks the write access to the potentially vulnerable Users\All Users branch (especially to the "C:\ProgramData\SDL International\MultiTerm\Termbases" folder), even MultiTerm is unable to write data in his own MTMaster
I.e. the new termbase names are not added to the MTMaster.

I have no idea where these data are stored for Workbench and for the main MT application but Word uses still the traditional method (it reads the MTMaster.mdb), so why only the Sample termbase is listed

In few words, MT 2007 is not fully compatible with Vista because of the UAC.

SOLUTION:

So, the only solution is to disable UAC in Vista.
Control Panel-> Users -> Accounts -> Turn Usr Account Control on or off.
A restart is needed.
Then, you may grant the appropiate user rights to the "C:\ProgramData\SDL International\MultiTerm\Termbases" folder, if necessary.

When the termbase is created, you can switch back on UAC (the termbase will be shown in the MultiTerm toolbar in Word 2007) but it may affect some MT functions.

Cheers
GG


[Edited at 2008-08-15 08:55]


Direct link Reply with quote
 
xxxOptiproz Pri
Local time: 14:08
English
Microsoft users own fault.... Aug 15, 2008

Hi both

@ Zhengli Zhou

This is not really a bug.

It´s the way how you use your own OS.

The easiest solution would be that you start Multiterm 2007 and Word 2007 everytime with a right click on the icon and choose "run as administrator".
So you are not forced to disable the complete UAC.


@Grzegorz Gryc

If you have turned off UAC it´s your own fault when you don´t have access to all files an locations on your system and since this is a Microsoft Vista feature why it should be a MultiTerm bug???

How can you say that this takes at least 7 years to correct this? Windows Vista was released when?.....you surely know it. Also how can you expect that MultiTerm architects should find a fix that circumvent a Vista feature that is build up for security reason since you can use the "Run as administrator" feature when you have turned on the UAC?


Direct link Reply with quote
 
Zhengli Zhou  Identity Verified
Local time: 21:08
English to Chinese
+ ...
TOPIC STARTER
Thanks! Aug 15, 2008

Thanks for the detailed analysis of the problem. The multiterm toolbar is shown in my word 2007, but my own termbase cannot be found in the termbase selection box. I'd like to know how to add my termbase to the selection box.

Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 14:08
French to Polish
+ ...
Well, it's a SDL bug in the design.... Aug 15, 2008

Optiproz Prime wrote:


If you have turned off UAC it´s your own fault when you don´t have access to all files an locations on your system and since this is a Microsoft Vista feature why it should be a MultiTerm bug???[/quote]
I dont't turn out UAC.
Simply, I don't use the Word workflow.

How can you say that this takes at least 7 years to correct this? Windows Vista was released when?.....you surely know it.

Windows NT (4.0) was released in 1997, AFAIR.
The security schemas for the access rights were introduced even earlier.
As you see in my precedent post, you have the XP section.
In fact, it's related to all the precedent Windows versions based on the NT technology (i.e. 2000, NT).
The guy who put the files in the "All users" branch didn't respect the basic security principles.
They had a lot of time to discover it.

And your solution (Run as admin) proves the lack of competence of SDL programmers in another way.
If you need to elevate the rights for an application in order to run it correctly, the application is not well designed,
Sorry.

Also how can you expect that MultiTerm architects should find a fix that circumvent a Vista feature that is build up for security reason since you can use the "Run as administrator" feature when you have turned on the UAC?

Vista only put in evidence another time the stupid choice their made.
They should permit to store the main data base in the location selected by the user.
E.g. on the network.
But in this case, the sales of the MT server could be affected.
So they prefer to maintain carefully this bug.

Cheers
GG

[Edited at 2008-08-15 10:41]


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 14:08
French to Polish
+ ...
Edit the MTMaster file. Aug 15, 2008

Zhengli Zhou wrote:

Thanks for the detailed analysis of the problem. The multiterm toolbar is shown in my word 2007, but my own termbase cannot be found in the termbase selection box. I'd like to know how to add my termbase to the selection box.


You should open the MTMaster file in Access and add the termbases you created manually.
It's simple, you need to put the paths and names in the Termbases table, but be carefull and save a copy of the file before you proceed.
IMHO Access 2007 may behave in an erratic way.

The new termbases will be added automatically if UAC is disabled.

In fact, if you put the paths to your termbases in the MTMaster file and if you don't plan to create another ones, you can enable back UAC.
The Multiterm interface for word needs only a read access to the MTMaster.

Cheers
GG


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

I cannot open multiterm 2007 database in word 2007

Advanced search


Translation news related to SDL Trados





Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs