Deleted default termbase; can't recreate in Word
Thread poster: TrM Hungarian Translations

TrM Hungarian Translations
Hungary
Local time: 19:00
Member (2007)
English to Hungarian
+ ...
Nov 3, 2008

Hello,

I am having problems with my Trados 2007 SP2:

I've deleted the default Termbase from the Multiterm standalone app. Now I am unable to select another one to replace it within the MS Word Multiterm interface ... in other words the Multiterm interface in MS Word has no TBs assigned to it so I can't enter new terms on the fly.

Thank you for any ideas in advance.

Regards,

Istvan
TrM Hungarian Translations


[Edited at 2008-11-03 14:39]


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 19:00
English to Czech
+ ...
Default? Nov 3, 2008

Hi Istvan,
do you mean you've deleted the Default.mdb file? Then it should be enough to reinstall MultiTerm. OK, it does take a couple of minutes but it should be working.

Oh, wait, have you emptied the Windows Recycle Bin? If not, try to restore the file from there.


Direct link Reply with quote
 

TrM Hungarian Translations
Hungary
Local time: 19:00
Member (2007)
English to Hungarian
+ ...
TOPIC STARTER
Default selection Nov 4, 2008

Stanislav Pokorny wrote:

Hi Istvan,
do you mean you've deleted the Default.mdb file? Then it should be enough to reinstall MultiTerm. OK, it does take a couple of minutes but it should be working.

Oh, wait, have you emptied the Windows Recycle Bin? If not, try to restore the file from there.


Dear Stanislav,

Thanks for the response.

Basically, I had a TB selected in the Word interface. Then I opened the Multiterm app and deleted that specific TB. And now the Word interface does not work.

(This is the TB I called default, I am sorry that I was misleading.)

Does a reinstall solve this problem? (My recycle bin is empty)

Thanks for your help.

Istvan


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 19:00
English to Czech
+ ...
termbase Nov 4, 2008

Hi Istvan,
to be honest, I rarely work with MT interface in Word; it's too unreliable.
So if I get it right, you deleted one of your termbases and this has caused the MultiTerm macro to stop working in Word.
The first thing I would try is to re-register MultiTerm. But one important piece of information needed: do you get any error messages? If so, what are they?


Direct link Reply with quote
 

TrM Hungarian Translations
Hungary
Local time: 19:00
Member (2007)
English to Hungarian
+ ...
TOPIC STARTER
Erros messages Nov 4, 2008

Stanislav Pokorny wrote:

...
So if I get it right, you deleted one of your termbases and this has caused the MultiTerm macro to stop working in Word.
The first thing I would try is to re-register MultiTerm. But one important piece of information needed: do you get any error messages? If so, what are they?


This pretty much covers the probelm.

The errors I get when trying to select termbase:

At first it's a visual Basic Run-time Error -2147418113 (8000fff).. and the only button I can press in the error window is "END".

On the second attempt the selection window can be opened. Selecting another TB here results in an "Object Variable or With Block not set" error... Run-time error 91.

And that's it

I have tried re-registering just now but it does not help.

Istvan


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 19:00
English to Czech
+ ...
Some suggestions... but far from being sure Nov 4, 2008

Hi Istvan,
this is just a blind shot, but try to decrease security settings in Word to "Low".

Then, if you deleted your termbase from your harddrive directly (via a file manager or so), i.e. not from MultiTerm, delete/detach the termbase from within MultiTerm. If this is the case, it may well be that the macro finds a description for a non-existent termbase, i.e. tries to refer to a non-existent referent (object). This might be the reason for your "Object Variable or With Block not set" message.

If this doesn't work, locate the MultiTerm7dot.xml file (usually located in C:\Documents and Settings\Your User Name\Application Data\Trados\MultiTerm) and delete it. This file is usually causing problems to MT-Word interaction.

That's all about my suggestions. Anyway, if you want to use the Word macro to add new terms, you can do that also by selecting the term in Workbench and adding it from there.

[Upraveno: 2008-11-04 09:36]


Direct link Reply with quote
 
FarkasAndras
Local time: 19:00
English to Hungarian
+ ...
trick Nov 4, 2008

Try making a new termbase with the same name in the same location?
It's so crazy it might just work.
You could try and make the mdb have the same name as the old one you deleted, that may matter as well.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 19:00
English
Try this... Nov 4, 2008

Hi Istvan,

You could try deleting the Multiterm7dot.xml file to reset the connection as described in the following SDL knowledge base article:

http://talisma.sdl.com/article.aspx?article=1315&p=1

I hope this helps.

Many Thanks,

Gareth Powell
SDL Support Team


Direct link Reply with quote
 

TrM Hungarian Translations
Hungary
Local time: 19:00
Member (2007)
English to Hungarian
+ ...
TOPIC STARTER
Thanks ! Nov 4, 2008

Gareth, Thank you, this did indeed solve the problem!

Stanislav, a great díky moc to you for all you efforts, too


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 19:00
English to Czech
+ ...
My previous post still not published Nov 4, 2008

Hi Istvan,
není zač. For some reason, my previous post where I'd suggested the same as Gareth remained not published.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Deleted default termbase; can't recreate in Word

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs