Pages in topic:   [1 2] >
Help - characters become purple and small
Thread poster: CDenisot
CDenisot
United Kingdom
Local time: 08:07
English to French
+ ...
Dec 22, 2008

I am not sure what is happening with Trados but sometimes when I am translating a segment in Word, as soon as I have finished translating and click on the button to go to the next segment, it transforms the segment before into a small purple line of characters and I don't know how to revert the line back to normal. Many thanks for your help!

[Edited at 2008-12-22 10:37 GMT]


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 09:07
English to German
+ ...
More details, please Dec 22, 2008

Please help others to help you by providing the details required on the Post new topic page.

Specifically, are you translating in Word?
Are you referring to text being formatted as tags?

Best regards,
Ralf


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 09:07
Member (2003)
Polish to German
+ ...
Some very probable guesses Dec 22, 2008

You are most certainly translating in Word. You do not show all formatting characters and especially you do not show hidden text. Then, when you start writing, you are overwriting segments delimeters.
Please stick to what is REQUESTED (I do not say recommended, because if you do not follow recommendations you see what happens) to work with Trados in Word: go to Tools, Options, select the View tab and make sure, all non printable characters are SHOWN (select all possibilities there). What you describe will then never happen to you again.
Please also read something about styles in Word help to understand what for you have tw4external and tw4internal and other Trados styles in Word.


Direct link Reply with quote
 

Rod Walters  Identity Verified
Japan
Local time: 16:07
Japanese to English
Careful with your cursor! Dec 22, 2008

I'm not sure exactly what situation you have, but I had similar sorts of problems before I knew better.

You have to be careful where your cursor is at any given time with Trados and Word.

If you unthinkingly put your cursor at the end of an already translated and closed sentence and begin typing, you may be be typing in a Trados tag, in which case you will get small purple characters.

If prevention of this sort still doesn't help, you can actually go back to where you were before you started typing by hitting Control + Z (Undo) many times (I've never bothered counting, but it's about 10 or more). All sorts of weird things flash on the screen, but keep going with Control + Z until things look normal again. Then you can reopen the segment and see what you have. Edit as necessary.

But most importantly, you need to watch carefully to see which actions cause the phenomenon.

Jerzy's advice about showing everything is sound, but it can be ugly to look at. If you take care at the edges of sentences, you can hide the tags and not have any problems.


Direct link Reply with quote
 
FarkasAndras
Local time: 09:07
English to Hungarian
+ ...
- Dec 22, 2008

The small purple characters are surely the trados tag characters (font is tw4win, and they are probably protected ie you can't delete them). I don't know what causes the error. It's either what Jerzy and Rod Walters are saying or some Trados bug.
Tips: if it is a trados bug, then apart from Undo, you could try "fix document" from the trados menu, or, if you want to delete the purple intruders, turn off tag protection in the trados menu.


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 03:07
English to French
+ ...
May be a glitch Dec 22, 2008

The above advice given by colleagues is valid. However, the solutions proposed may not be sufficient in certain cases.

This has happened to me a long time ago. Some Word documents, especially those that have poor formatting or that are the result of OCR, cause this kind of problem, and I've never found a way to circumvent this problem in Word. That is why I don't use Word as an editing environment anymore - I use TagEditor. TagEditor isolates the parts of the document that need to be processed and leaves out all the parts that are not meant to be processed. In Word, there is no way to make sure you are not touching something you aren't supposed to, whereas TagEditor simply doesn't give you the chance to manipulate parts of the document that are not translatable (like the spaces between sentences).

In case of doubt, try using TagEditor. In many cases, it will save you a lot of trouble.

[Edited at 2008-12-23 07:22 GMT]


Direct link Reply with quote
 
CDenisot
United Kingdom
Local time: 08:07
English to French
+ ...
TOPIC STARTER
Fix document does not help Dec 24, 2008

Hello,
Many thanks for all your replies. I do have the feeling that it could have something to do with OCR as this tends to happen only with certain documents but not others. The 'fix document' function doesn't help and if I undo the tag protection, I can delete what is written in the segment but still can't write 'normally'as what I write afterwards is still in small purple characters.
So far, I can only go back to my source text and use my memory to translate the text up to where the problem happened again and sometimes it doesn't happen a second time for that specific passage but it is very time consuming.
Many thanks for your input though. The Tageditor could be the solution but unfortunately I am still not familiar with using Tageditor


Direct link Reply with quote
 
FarkasAndras
Local time: 09:07
English to Hungarian
+ ...
- Dec 24, 2008

If I were you, I'd try copying the text to a new document.
If there is no complex formatting, copy it to notepad, then from there to a new empty document, and recreate the formatting needed.
Then, whatever weirdness is creating the problem, it will be gone. (In notepad, no formatting exists. Not even italics or font size. So it strips all the junk and leaves nothing but the text, line breaks and tabs. With Word, you never know what unseen strangeness is going on, confusing Trados.)

[Edited at 2008-12-25 12:21 GMT]


Direct link Reply with quote
 

Rod Walters  Identity Verified
Japan
Local time: 16:07
Japanese to English
Change the Style Dec 24, 2008

I think you have a problem with Style.

What FarkasAndras suggests is a very global approach, and you'll have to go back and format the document afterwards.

For a more local approach, where you get little purple characters, you should be able to select them with the cursor, then go the the Style pull-down in the Word tool-bar and change it from the Trados style (tw4win...something or other) to Normal or whatever style it should be. Or you can use the Format Painter tool to select normal text and then paint over the purple text.


Direct link Reply with quote
 
CDenisot
United Kingdom
Local time: 08:07
English to French
+ ...
TOPIC STARTER
Style issue Dec 29, 2008

Dear Rod,

It seems indeed that it is a problem of Style. Your suggestion so far has been the closest to a solution in that I can change the style back to 'Normal' every time the problem happens but for some reason it reverts back to twin4 something right afterwards (could there be a default setting somewhere??) and I cannot highlight the whole text and change it to 'Normal' as the Trados tags between each segment otherwise change as well and cannot be cleaned afterwards.
I could do this after cleaning the text but for the present assignment my client wanted the unclean file so that solution was not possible. I ended up highlighting each sentence one by one at the end and changing the style to Normal, which was very time-consuming.
I have tried to observe when it happens the most (good tip there) and it seems to happen mostly, if not only, when I go back to an already translated segment to make a change to it.
Thank you FarkasAndras also for your suggestion, I tried to take away all the formatting in notepad as you suggested but it did not seem to help in this case.
I am tempted to uninstall and reinstall Trados.
If anyone has any more suggestion after those additional details, thanks in advance and thanks to all of you for your valuable help and contribution.
Happy New Year to all


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 09:07
Member (2003)
Polish to German
+ ...
Put in a nutshell: this is a classical "user"-issue Dec 29, 2008

You do not need to deinstall and reinstall anything.
Just use the software as it was designed for.
When you try to edit a billingual document in Word, you have to pay attention to the segment delimeters (those purple small text).
When you click at the beginning of the sentence and even have the impression you are just in front of the first letter and then start typing, the letters will be formatted with the tw4winMark style. Now instead of starting typing there, click at the beginning of the sentence, now use the right arrow key to move the cursor behing the first letter of the sentecne and then move it back with the arrow key. When you now start typing, the letters will no longer be formatted as tw4winMark.
This is just normal behaviour of Word and has NOTHING to do with Trados.
Imagine, how the text is stored in the Word file.
Look at the following example:

This word is bold.

You see a bolded word in it. Please rewritte exactly the same sentence in Word.
Now start from the beginning of the sentence and move the cursor with the right arrow key, until it stops directly before "word". Observe the formatting button in Word for bold. It is still disabled. Move one step to the ritght, the formatting button will now be activated. Move to the end of "word". The formatting button is still activated. Move one step more to the right. Now move the cursor one step to the left. The formatting button, which was activated previously at this place is now DEACTIVATED.

Look how the text is stored in Word:

This word is bold.

Let this "I" represent the cursor.
We are now moving from left to right, the cursor stops in front of the bolded "word":

This I<b>word</b> is bold.

Now the cursor stops behing the bolded "word":

This <b>wordI</b> is bold.

You move one step to the right:

This <b>word</b> Iis bold.

Now you move one step back to the left:

This <b>word</b>I is bold.

This is the whole "issue".

[Edited at 2008-12-29 20:36 GMT]

[Edited at 2008-12-29 20:37 GMT]


Direct link Reply with quote
 
CDenisot
United Kingdom
Local time: 08:07
English to French
+ ...
TOPIC STARTER
Thanks but... Dec 30, 2008

Thanks Jerzy for your very detailed explanation however as I explained in my last posting this does only happen when I go back to a segment or when I save a segment that was typed in perfectly normal font. Moreover, I fully admit my lack of competence with Trados but this problem never used to happen to me before when I was even less competent but keeps on happening to me now almost everytime so I believe that I might have changed a setting inadvertently or something, hence I thought I'd reinstall the software and wanted everyone's thought on that.
many thanks again


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 09:07
Member (2003)
Polish to German
+ ...
Please make some screenshots Dec 30, 2008

If the font changes when closing segment and the text becomes formatted with tw4winmark style, then it is indeed very strange.
However I've never seen this kind of changes happen.
So maybe you would be able to make some screenshots of an opened segment and then what happens when you simply close it.
Please post them here or send me to info at doku minus trans dot de.


Direct link Reply with quote
 
CDenisot
United Kingdom
Local time: 08:07
English to French
+ ...
TOPIC STARTER
Screenshot Dec 31, 2008

Hello Jerzy,

I have just sent you a screenshot of what happens in Trados at the e-mail address you indicated in your posting.
Many thanks for your help, it is very much appreciated


Direct link Reply with quote
 

Rod Walters  Identity Verified
Japan
Local time: 16:07
Japanese to English
I had that problem once Jan 5, 2009

I had a similar problem once I think, and if I remember correctly, it's a recognized problem. You may find something about it in the SDL knowledge base.

In my case, Times was randomly interspersed with Arial, my font of choice, when closing a segment. The same thing happened with cleaning up too. It left a very messy memory. I also got memories from other translators with evidence of that problem strewn about. However, Times is less of a problem to deal with than what you've got.

The problem was solved for me when I upgraded and so basically threw out my old installation. Reinstalling might work for you too, but before you do that, I'd look at the SDL site first.


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Help - characters become purple and small

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs