Mobile menu

SDLX - I want auto-propagate to take precedence over 100% match from applied TM
Thread poster: Yeti_fr
Yeti_fr
Local time: 14:13
English to French
Jan 19, 2009

Hi,

I have .itd files on which TM were applied.
My problem:
- a segment is repeated several times in the .itd file
- when the TM was applied, this segment was a 100% match, so all occurences of it are now gold color (translated but not confirmed)
- the context is not the same as the TM so I want to change the translation
- I edit the 1st occurence, confirm the translation, so I expect every following occurence to become orange color and use the translation I just entered (I selected auto-propagate in SDLX options)
- but no, they stay gold color with the translation from the TM

Is there anything I can do if I don't want to enter the same translation again and again.
Ie, I want auto-propagate to take precedence over a 100% match from an applied TM.

Thanks


Direct link Reply with quote
 

Soonthon LUPKITARO(Ph.D.)  Identity Verified
Thailand
Local time: 14:13
Partial member (2004)
English to Thai
+ ...
Automation in option menu Jan 19, 2009

I SDL Edit program option menu, go to Automation tab.
Select TM auto-apply, TM auto-update, TM auto-propagation etc.
Soonthon L.


Direct link Reply with quote
 

Annelise Meyer  Identity Verified
France
Local time: 08:13
English to French
+ ...
Unconfirm all Jan 20, 2009

Hi,
I think the only way to do this is to first unconfirm all of your 100% segments. To do this, choose Edit>Confirm/Unconfirm>UNconfirm all. Thus your 100% segments will appear as new ones again (only the color changes to grey, not the content). Once this is done, autopropagate can apply to these segments.
Hope it helps,
Annelise


Direct link Reply with quote
 

Claudia Digel  Identity Verified
Germany
Local time: 08:13
English to German
+ ...
Apply an empty TM to the file Jan 20, 2009

Annelise Meyer wrote:
I think the only way to do this is to first unconfirm all of your 100% segments. To do this, choose Edit>Confirm/Unconfirm>UNconfirm all. Thus your 100% segments will appear as new ones again (only the color changes to grey, not the content).


I don't think this suggestion will work. Unconfirm all will not unconfirm 100% matches but only confirmed (blue) segments.

I think the only way to do what you want to do is to apply an empty TM to the pre-translated file so that it will not contain any matches. This of course means that you will have to enter all 100% and fuzzy matches manually during translation (which is rather cumbersome if there are a lot of them).

Kind regards,
Claudia


Direct link Reply with quote
 
MonikaB  Identity Verified
Germany
Local time: 08:13
English to German
+ ...
Unconfirming 100 % matches Jan 20, 2009

Claudia is right that "Unconfirm all" won't have any effect on 100 % matches.

One possible workaround for unconfirming these is to search for a space and replace it with a apace. This will leave any segment in which a space appears unconfirmed without losing the existing translation.
(If you have a lot of short segments without spaces, you can of course also search for any other frequent character, but don't forget to tick the "Match case" option.)

Regards,

Monika


Direct link Reply with quote
 
Yeti_fr
Local time: 14:13
English to French
TOPIC STARTER
I'll try the replace solution Jan 20, 2009

Monika Braje wrote:

Claudia is right that "Unconfirm all" won't have any effect on 100 % matches.

One possible workaround for unconfirming these is to search for a space and replace it with a apace. This will leave any segment in which a space appears unconfirmed without losing the existing translation.
(If you have a lot of short segments without spaces, you can of course also search for any other frequent character, but don't forget to tick the "Match case" option.)

Regards,

Monika

This seems to be the best solution, I'll try it on my next .itd.
Applying an empty TM is problematic, because for this to work I'd have to delete existing translations, and when doing that it also deletes translations of locked segments (which is pretty stupid).

Thank you all, I'll report back later on Monika solution.


Direct link Reply with quote
 
Yeti_fr
Local time: 14:13
English to French
TOPIC STARTER
Monika's solution is working fine Jan 23, 2009

I tried Monika' solution (replace by the same character) and it's doing the job.

Thank you all.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDLX - I want auto-propagate to take precedence over 100% match from applied TM

Advanced search


Translation news related to SDL Trados





TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs