Mobile menu

Adding an entry from MultiTerm causes Java "null" error
Thread poster: Alan Frankel

Alan Frankel  Identity Verified
United States
Local time: 19:32
German to English
Jan 26, 2009

I have a brand-new installation of MultiTerm (just downloaded the Trados 7 Freelance suite this past Friday). After creating a termbase, when I go to the "Entry" menu and select "Add", I get an error window with a title "Windows Internet Explorer" and an error dialog window that says only "null". I click "OK" and see "java.lang.NullPointerException". Clearly, something is very wrong. I don't see other people reporting this problem.

[I thought I had another problem where Microsoft Word couldn't seem to find this termbase, but I eventually figured out that I had to go into "Terminology Recognition Options" to set the termbase.]

Where do I go from here? I didn't buy a special support agreement from SDL, but I must be entitled to some form of support from them because there seems to be a bug here. At the very least, their error-handling is deficient.

In terms of version information: When I choose "Help/About", I see the following info:

"MultiTerm 7.5.0.444 - (Build 448) ... This is a component of SDL MultiTerm 2007."

Any guidance would be welcome.

[Edited at 2009-01-26 23:01 GMT]


Direct link Reply with quote
 

Ulf Norlinger  Identity Verified
Sweden
Local time: 01:32
English to Swedish
+ ...
MultiTerm incompatibility with JAVA release Jan 27, 2009

(From SDL knowledge base)

Problem:

When you try to add or edit and then save a termbase entry in SDL MultiTerm 2007 Desktop, a Microsoft Internet Explorer dialog box is displayed with the message null.

When you click on Ok the following message java.lang.NullPointerException is displayed.

---
Explanation:

This behavior is caused by the install of Update 10 and 11 of JAVA 6 version (Java Runtime Engine/JRE) and how Sun Java technology handles automatic updates.

JAVA 6 has introduced a "next generation Java plug-in" is producing these errors in SDL MultiTerm and this is the reason for this error:

SDL MultiTerm 2007 has been developed and tested with JRE 1.5_10 and is not compatible with JRE version 6 Update 10 and 11. However, as of JRE 5.0 Update 6, it is no longer possible to specify the exact JRE release and SDL MultiTerm is forced to use the latest version of Java, even when an earlier version is installed. For more background information, please consult the SUN Microsystems Release Notes.

---
Resolution:

Alan, do this to correct your your problem.

If you have JAVA 6 Update 10 and/or Update 11 version installed, you need to disable the "Enable the next-generation Java plug-in" feature.

To fix this problem:

Click Start and then select Control Panel from the menu. The Control Panel is displayed.
Double-click on Java. The Java Control Panel is displayed.
Click on the Advanced tab.
Clear the Enable the next-generation Java plug-in check box.
Click OK to save your changes and close the Java Control Panel.
Reboot your PC.

The error messages should not appear anymore and you are able to work with your termbase again without problems.
---

[Edited at 2009-01-27 01:48 GMT]


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 18:32
Partial member
Spanish
+ ...
Multiterm Jan 27, 2009

I had the same problem. Actually, I've had it twice for each time I installed Multiterm. Try deleting this file: MultiTerm7dot.xml, then restart everything again.

I don't remember exactly how I fixed it because I did a lot of things, so something must have worked. What I do remember is that I found the fix in this thread: Yet another Multiterm 2007 glitch.

Where do I go from here? I didn't buy a special support agreement from SDL, but I must be entitled to some form of support from them because there seems to be a bug here. At the very least, their error-handling is deficient.

Been there, thought that. But that's not how SDL does things--it's very frustrating.

You might also want to check the Knowledge Base from your SDL account, but IMHO these forums are far more helpful.

Good luck.

Claudia


[Edited at 2009-01-27 01:55 GMT]


Direct link Reply with quote
 

Alan Frankel  Identity Verified
United States
Local time: 19:32
German to English
TOPIC STARTER
Ulf's suggestion fixed the problem Jan 27, 2009

Thanks a lot, Ulf, that fixed the problem! Now when I go to the SDL knowledge base ( http://talisma.sdl.com -- I've bookmarked it), I see that the question/answer pair that you quoted is listed under the "hot topics". I don't know why I didn't see it there before. Perhaps it wasn't "hot" a few hours ago? It might have just crossed over the threshold, since it is near the bottom of the "hot" list.

Thanks also, Claudia, for your suggestion. However, I don't have any files ending in *dot.xml on my machine, and I wasn't seeing the same type of problems that some of the people saw in that thread. It could well be that in the time since those people wrote their posts, SDL fixed the problems. My download is effectively brand-new.

Thanks again, both of you!


Direct link Reply with quote
 

Ulf Norlinger  Identity Verified
Sweden
Local time: 01:32
English to Swedish
+ ...
Only glad to help Jan 27, 2009

You are right, I couldn't see it either among the "hot topics".

Direct link Reply with quote
 

Robert Schlarb  Identity Verified
Local time: 01:32
German to English
+ ...
Word of thanks Feb 2, 2009

I became aware of this problem for the first time today (I don't open up MultiTerm often). Not finding any help in the SDL Trados Knowledge Base (is there an indexing issue here?), I checked here and... of course, there was Ulf's answer.
This is not the first time I have found the only really helpful Trados help at proz.
Many thanks

Robert


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 01:32
Member (2004)
English to Slovenian
+ ...
Ulf, your No 1 Feb 11, 2009

++

Thanks


Direct link Reply with quote
 

Dialekt  Identity Verified
Poland
Local time: 01:32
Member (2007)
English to Polish
+ ...
The good-news domino rolls on Feb 12, 2009

I was stuck with very same problem. Thanks to Vito (who found this thread and gave me a hint) and thanks to Ulf the problem is gone. Thank you both - your help is certainly appreciated.
Wojciech


Direct link Reply with quote
 

Winged Words  Identity Verified
Belgium
Local time: 01:32
English to Dutch
+ ...
Superb help Ulf Aug 25, 2009

+++
Thanks a lot!!


Direct link Reply with quote
 

LingCom
Argentina
Local time: 20:32
English to Spanish
+ ...
Thanks ulf! Oct 10, 2009

Thanks for your help! I had the same problem and could solve it now!

Direct link Reply with quote
 

Tomás Cano Binder, CT  Identity Verified
Spain
Local time: 01:32
Member (2005)
English to Spanish
+ ...
Not always the solution Oct 11, 2009

Ulf Norlinger wrote:
If you have JAVA 6 Update 10 and/or Update 11 version installed, you need to disable the "Enable the next-generation Java plug-in" feature.

In theory this should work, but in fact (at least in my environment, with SDL Multiterm 2007 on Vista), the only final solution was to uninstall (from the Control Panel) all versions of Java other than the 1.5 version originally expected by Multiterm.

I had tried everything else (the next-generation thing, the memory-more-than-the-physical-memory thing, etc. etc.) with no success, and the only solution was to uninstall Java 1.6 and anything else later than 1.5.


Direct link Reply with quote
 

Kim Sanderson  Identity Verified
United Kingdom
Local time: 00:32
German to English
+ ...
Java changes - best way to fix this now? Apr 29, 2010

Dear all

I am very grateful to have found this thread

(same info. on Trados Knowledge Base Article ID: 2362)

However, I can't follow the instructions as it seems Java has changed and I can't find the check box to 'disable the "Enable the next-generation Java plug-in" feature'.

Any ideas what I can do?

NB I'm not using Windows Vista

Kim


Direct link Reply with quote
 

Tansy  Identity Verified
Local time: 01:32
Member (2008)
German to English
Same problem Jul 9, 2010

I had the same problem, but every time I try to uncheck the box in question, I get an error message saying that (to translate the German roughly) "Java Plug-In settings cannot be changed because at least one browser is being used". This happens when nothing else is open - even when I have just rebooted!

Does anyone have any suggestions about what I could do here? I have Trados 7.0.0615 and Multiterm 7.1.0.361 running on Windows XP.

Thanks


Tansy


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Adding an entry from MultiTerm causes Java "null" error

Advanced search


Translation news related to SDL Trados





PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs