Mobile menu

Marking text parts in InDesign untranslatable
Thread poster: Jerzy Czopik

Jerzy Czopik  Identity Verified
Germany
Local time: 05:08
Member (2003)
Polish to German
+ ...
Feb 17, 2009

This is quite easy for Word or for Framemaker.
Formatting text in Word as hidden (similar in Framemaker) makes it untranslatable in TTX.
Now I've got InDesign from customer with the note in document "please translate only MAGENTA parts". So I would like to format all text formatted as black in a way to make it untranslatable. This should be possible, but how?
I use InDesign CS3, SDL Trados 2007 Suite Pro (8.3.0.863)

Many thanks in advance
Jerzy


Direct link Reply with quote
 

tectranslate ITS GmbH
Local time: 05:08
German
+ ...
Why should it be possible? Feb 17, 2009

You can put the black stuff on a layer that is hidden and/or locked. But of course, you can only do this story by story.

That's the only method I know.

HTH,

Benjamin

P.S.: Make sure the stories on hidden and non-hidden layers aren't linked to each other or strange effects will occur.

edit: sorry, not the magenta stuff, the black stuff. You know what I mean.

[Edited at 2009-02-17 14:44 GMT]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 05:08
Member (2003)
Polish to German
+ ...
TOPIC STARTER
Black stuff of course Feb 17, 2009

but I want to do this in automated way(Search&Replace) - and did not found there any possibility to move text to a different layer.

To answer your question "Why should it be possible?" - because it would be easier to have only translatable text in Tageditor and not the mixture of both.

Thanks
Jerzy


Direct link Reply with quote
 

Jabberwock  Identity Verified
Poland
Local time: 05:08
Member (2004)
English to Polish
Not easy... Feb 17, 2009

A quick look at the InDesign filter settings tells me that the filter itself does not provide such functionality...

I guess the only way to do it (semi-)automatically is to edit the ttx file. However, this is only possible if the segments to be omitted can be easily located.

One way to do it:

  • Pretranslate the file with an empty TM and save the ttx.
  • Locate the segments with the relevant tag (black? - have no idea how it might look in INX!)
  • For those TUs change the attribute Origin="manual" to "xtranslate"

This will make TagEditor skip the relevant segments, both from editing and from analysis.

Of course, it might be easier to turn it around and change all "manual" to "xtranslate" and revert it only for magenta TUs.


[Edited at 2009-02-17 17:38 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Marking text parts in InDesign untranslatable

Advanced search


Translation news related to SDL Trados





CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs