Mobile menu

"Tag-protect" content between {...} in TRADOS 7 FREELANCE
Thread poster: Marco Calcaterra
Marco Calcaterra  Identity Verified
Italy
Local time: 03:06
English to Italian
Mar 3, 2009

Dear Proz members,
is there any way to protect a portion of text that's between curly brackets within Tag Editor?

E.g. I have a txt file (which I can convert to .doc or .rtf of course) and this is a sample line:

Dear {NAMECODE}, how are you?

I want {NAMECODE} to be treated as a protected tag. Can this be done with TRADOS 7 FREELANCE?

I'm sure SDL TRADOS does this from the Filter Settings menu, but TRADOS 7 FREELANCE doesn't have the same number of options there (e.g. is missing RegExp and the like).

Thanks in advance,
Marco


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 03:06
English to Czech
+ ...
Setup in Word Mar 3, 2009

Select the "DO_NOT_TRANSLATE" style in MS Word and apply it on any text you want Workbench to skip. Save the document and open it in TagEditor.

Alternatively, you may also apply the style "tw4winInternal". In this case, all untranslateable text will be shown as internal tags.


Direct link Reply with quote
 
Marco Calcaterra  Identity Verified
Italy
Local time: 03:06
English to Italian
TOPIC STARTER
Some progress... Apr 8, 2009

Alternatively, you may also apply the style "tw4winInternal". In this case, all untranslateable text will be shown as internal tags.


Thanks a lot Stanislav and sorry for the late reply.
Actually, I needed some way to automate the process instead of doing it manually. I found that Plustools (a tool developed for Wordfast actually) does this quite fine.
There is still a weird TRADOS behaviour though:

When within Word I open a TU containing an internal tag marked as "tw4winInternal", TRADOS lets me edit it, while it shouldn't let me do that.
I tried toggling tag protection on and off, but nothing changed, the "tw4winInternal" text is visualized (correctly) in red, but TRADOS lets me modify it... Very weird.

Wordfast (5.53), on the other hand, skips the red text correctly. Probably I just have to select some option within TRADOS but I really couldn't find which one.
Thanks,
Marco


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"Tag-protect" content between {...} in TRADOS 7 FREELANCE

Advanced search


Translation news related to SDL Trados





Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs