Mobile menu

Source text and target text are stuck to each other (hidden text is off)
Thread poster: Radu Cazac
Radu Cazac
Local time: 00:02
Apr 11, 2009

I am a newbie with Trados, so please bear my unitiated language. This doesn't have to do anything with the hidden text issue, which was discussed here. I work in Workbench and Word 2003.

This is what happens: In certain paragraphs of a 100 page text, I insert the translation in the target section, I hit Set/close or Close, but the source text does not replace the target text (hidden text in Word is off) but they remain stuck to each other.

I'll try to explain 'stuck'. Let's say that ABC is the source text, and DEF is the target text. Normally, ABC should be replaced by DEF, but in my case the remain like ABC.DEF The point represents the end of the source text. I put a space at the end of the source sentence, then the source and the target became separated, like ABC . DEF, but they remain stuck to each other.

It happens only in a few paragraphs. The strange thing is that I copy pasted thos paragraphs in a new Word window, and they behaved the same. It looks like a problem with the text formatting, but how do I fix it in Trados?

If I didn't make myself clear, please let me know. Thank you in advance.


Direct link Reply with quote
 

Cecilia Carrizo
Argentina
Local time: 19:02
English to Spanish
+ ...
try cleaning up the text Apr 11, 2009

I have encountered the same problem before, I have no idea why it happens, but it should go away when you clean up the text. What I usually do when I have this problem is to translate the text as usual, and when I finish I just clean up the text and voilá, problem solved. I would really appreciate it if somebody could tell me why it happens in the first place...! I hope it helps, adiós!

Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 23:02
Member (2004)
English to Slovenian
+ ...
use "repair document" Apr 11, 2009

Radu Cazac wrote:
---
This is what happens: In certain paragraphs of a 100 page text, I insert the translation in the target section, I hit Set/close or Close, but the source text does not replace the target text (hidden text in Word is off) but they remain stuck to each other.
...


If you turn hidden text on, you will notice that the questionable source-segment pairs do not look the same way as the rest (the special TRADOS tags <0}, <{0}>, {0> are missing or in wrong order, or there's a hard break in somewhere). It happens - to me at least - for instance when correcting the beginning or the end of a text in a segment, that's not active.

Use the macro "repair document" from the TRADOS menu and things will improve.

Re "cleaning the document" - wonders do happen (g), but usually, what's broken, remains broken - until repaired.

Regards

Vito


Direct link Reply with quote
 
Radu Cazac
Local time: 00:02
TOPIC STARTER
I will wait then Apr 11, 2009

Thank you. I will wait until I have to clean it up and see what happens.

The "Fix document" option from the Trados menu in Word does not work. The problem persists.

I noticed another strange behavior. So, I have a sentence with this problem, the source and target texts are stuck. But when I open the next sentence, the first one suddenly shows up correctly, i.e. only the target text. Things mess up again when I close the second sentence. This is absurd. Is it possible to attach images to these forum topics? A screen capture would be useful.

The hidden text is not consistent. At the wrong paragraphs, sometimes it says , sometimes it says . The correct paragraphs have only


Toggling tag protection in the Trados menu (Alt+Ctrl+P) would prevent things like this from happening in the future?

[Edited at 2009-04-11 21:30 GMT]

[Edited at 2009-04-11 21:44 GMT]


Direct link Reply with quote
 

Alaa Zeineldine  Identity Verified
Egypt
Local time: 00:02
Member (2002)
English to Arabic
+ ...
copy source then delete both Apr 12, 2009

If you are able to close the TU, you can try the following steps:

1. Make sure tag protection is OFF in the Trados menu

2. Make sure you have a copy of the original source available in some backup file.

3. In Word ** not in TWB ** delete both source and target segments completely, including Trados tags.

4. Copy and paste the original source paragraph from the backup file into your working file in the correct location

5. In Word, turn on "show paragraph marks" (the inverted P symbol).

6. Inspect the paragraph you have restored looking for "new line" symbols (a little arrow with a tiny elbow) and replacing them with new paragraph marks** (by hitting enter) or with suitable punctuation to join the lines together. You can restore original formatting after cleaning up.

7. Now go back to the beginning of that paragraph and try another open/get. You should get an exact match or fuzzy matches from your earlier translation, depending on whether or not the paragraph had been rearranged in step 6. Now set/close and hope for the best.

8. Toggle back tag protection if you prefer to have it ON.



** You can restore these "newlines" after cleaning your document if they are necessary for formatting. You can do that by replacing those paragraph marks with "shift+ENTER".

[Edited at 2009-04-12 07:40 GMT]


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 23:02
Member (2004)
English to Slovenian
+ ...
start from the beginning Apr 12, 2009

Radu Cazac wrote:

Thank you. I will wait until I have to clean it up and see what happens.

The "Fix document" option from the Trados menu in Word does not work. The problem persists.


Looks like a foobar problem (http://de.wikipedia.org/wiki/Fubar) to me.

If the document being translated is messed up that much, then there's hope, the TM is /must still be OK. Proceed as follows:

1) make yourself a new copy of the original document
2) go to TWB>Tools>translate and pretranslate the new, fresh copy
3) continue working with the new version of the document
... and ...
4) repeat the procedure 1-3, when similar things start to happen again (...and make sure, you always have a virgin copy of the original somewhere at hand)

Advice:
1) do not wait, until you are finished - you may be deeper in the morass by then
2) do not turn off the tag protection - it's like turning off the fire alarm.

Regards

Vito


Direct link Reply with quote
 
Radu Cazac
Local time: 00:02
TOPIC STARTER
Problem solved! Apr 12, 2009

Well, the problem is solved, and I'll tell you how I did it.

I looked for any differences in the hidden text of the problematic paragraphs. I found out that the paragraphs never ended with the pillcrow sign ¶. I activated hidden text, I restored the original source, and simply copy pasted the sign at the end of the paragraph. Then I set again the target text that was already saved in the memory. This time it worked and the problem never appeared again. Why this happened and what I actually did, I don't care. I am relieved I finally solved it.

Thanks everyone for your help. I certainly hope that one more Trados "mistery" has been solved.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Source text and target text are stuck to each other (hidden text is off)

Advanced search


Translation news related to SDL Trados





TMreserve
Wake up in the Morning and see that you have sold TMs and made Money overnight



The TM Market Place for Translators
New: Our Instant TM Download
TM owners: Upload your TMs into the online database
Customers: Analyse your text & instantly download a text-specific TM
Well over 1.2 BILLION translation units

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs