Mobile menu

Pages in topic:   [1 2] >
Font Change in Translation Process with Trados 6.5
Thread poster: James Chan

James Chan  Identity Verified
Local time: 08:32
English to Italian
+ ...
Jun 30, 2004

Hi,

I experienced quite a frustrating problem in using Trados 6.5 Work
Bench.

Here is the background information:

Language pair: Chinese (Taiwan) and English (US)
MS Word: 2003

Problem statement: When translating the document, the font of text in
source segement and target segment got altered without any reason.
For instance, (1) the orientation of the text in the source segment
(from left to right) was reversed for certain letters or characters;
(2) the font of text in target segment got changed to italic or bold
while the source text was not. This change of font also happened to
the text of source segment.

Could any help me with this? Will highly appreciate it.

James Chan


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 02:32
English to German
+ ...
Check the style used Jun 30, 2004

Hi James,
I have no idea whether this could be related to the Chinese font used, but a frequent source of problems is related to the authoring of source documents. Check the formatting information contained in the style used for that particular paragraph: Word users often use character formatting (rather than styles) to make general changes.

HTH, Ralf


Direct link Reply with quote
 

James Chan  Identity Verified
Local time: 08:32
English to Italian
+ ...
TOPIC STARTER
Thanks Ralf! Jun 30, 2004

Ralf Lemster wrote:

Hi James,
I have no idea whether this could be related to the Chinese font used, but a frequent source of problems is related to the authoring of source documents. Check the formatting information contained in the style used for that particular paragraph: Word users often use character formatting (rather than styles) to make general changes.

HTH, Ralf


Ralf,

Thanks for your reply. To solve this problem, I specifically read the Setup section of the menu of Trados. It appears Trados already knew that there may be problem mentioned and offered font translation. I configured Trados according to their instruction, but only to find it did not work for certain text.

I agree with you that this is related to style of the Word document, but is there something we can do to prevent this from happening before translation starts? I really feel Trados should correct this problem because most Word users do not apply style in their document.

James Chan


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 02:32
English to German
+ ...
Styles are a Word issue, not a Trados issue Jun 30, 2004

Hi James,
I agree with you that this is related to style of the Word document, but is there something we can do to prevent this from happening before translation starts?

The only thing that comes to mind is to run a few checks on the document structure.

I really feel Trados should correct this problem because most Word users do not apply style in their document.

Which is a Word issue, of course - hence there isn't anything that Trados could do about it. Assuming your problem is indeed related to styles, that is.

Best regards, Ralf


Direct link Reply with quote
 
EKM
Sweden
Local time: 02:32
English to Swedish
+ ...
Chinese font (SimSun) appears in Word despite that the information entered is in Times New Roman Aug 19, 2004

Hi Ralph and all others who pop in,

On a number of occasions while using Trados Workbench / Word 2003 to translate English into Swedish, I have run into this problem:


I am translating a tagged text in rtf format, in Word. I put in my translation between the tags, and before the translation unit is saved, the tags are in Courier New, and the actual text in Times New Roman. However, in case of a subsequent match, Trados presents a translation where the fonts have changed. It is most often the fonts PimLIU and SimSun, and this messes up my Swedish å:s ä:s and ö:s, replacing them with Chinese characters.

From your discussion above I take it that this may be caused by the formatting of the source document, but if possible, could somebody provide me with instructions of to solve this.

I will try Tag Editor to see if this works better.

Time is, as always, of the essence, and any help will be greatly appreciated!

Best regards,
Mårten


Direct link Reply with quote
 

Per Bergvall  Identity Verified
Norway
Local time: 02:32
Member (2002)
English to Norwegian
+ ...

MODERATOR
OF COURSE it's a Trados problem Aug 19, 2004

I find it ludicrous to suggest that this is a Word problem, or a problem caused by the ineffective application of character formatting rather than 'proper' use of Word styles.
Seems to me Trados is trying to be too smart for it's own good. Surely it must be possible for Trados to simply use the formatting of the source text, be it based on a modified paragraph style, a misplaced character style, or (as is frequently the case) whether the entire document is in the 'Normal' style with manual formatting applied?
I find that my translation units during translation have been changed from 10 pts Arial to anything from "4 pts Times, Italic, strike-through" to "38 pts Batang, bold", and it's ridiculous to suggest (as Trados does) that these are just the original paragraph styles which have been restored.

My problem started about the time I began accepting assignments from a Korean agency. The documents I receive, are in (kind of) English, and I translate into Norwegian. There is no need for font changes, and I don't want them. Trados has a very elaborate scheme for font substitutions, but lacks a flag that says "Do not substiturte fonts". The Korea/Taiwan angle seems to be a common denominator, so this may be a good place for Trados to start when effecting a much needed improvement.

I expect the quick and dirty solution is to specify a target default font, and check "Translate into target default for all other fonts", after buiding a list of Times => Times, Courier => Courier etc on the File/Setup/Fonts page. I don't see this stopping Trados from messing with bold/unbold, and reversing character sequences in the translation window, but it might be worth a try.

Myself, I have bought Wordfast 4.2, where this problem is simply unheard of.


Direct link Reply with quote
 

Stefan Gentz
Local time: 02:32
English to German
+ ...
Formatting changes after closing segement / "The ugly SimSun Bug" Aug 20, 2004

A couple of thoughts on these issues (which should be separate topics ...)

Well, Ralf is perfectly right here. One of the major problems is actually, that most Word authors do not know how to work with Word properly. Only few authors know about Word's Object Model and how to work properly with paragraph and character styles, structure documents properly at least on a heading style level for proper TOC and PDF bookmark creation, use templates and do not evel thinks like embedding graphics etc. pp..
Also please consider the following: Let's take a simple one line paragraph. Let's say the pgf style is set to "Normal". Now you can start to make millions of possible combinations of how to change the formatting of this pgf manually. Choose a different font, a new font size, a new font style, set an new font for complex scripts, apply one of the many effects, scale the font, change the char spacing and set up a new kerning, change keep with next/prev flags etc etc etc. And then mark up specific words in this pgf with specific extra formatting that differs from your format overrides.
And now just try to imagine what a Visual Basic based Word DOT like the trados DOT needs to do, when trying to collect all these informations, store them in memory (and still being someway fast), open two neat boxes with simple formatting for easy translation (and hopefully the chance to save the translation pair format independent in your TM) and then reapply all the overrides to the target segment after closing the two neat translation boxes *and* keep it as a bilingual TU (would be a more easy job if the source language would be deleted). And now try to imagine the difficulties you'll face with VBA when it comes to translation of languages with different codepages and maybe even different fonts (lie single and double byte fonts). That all this works more or less reliable in TRADOS is already quite an amazing thing.
So, if you ever did some VBA programming for Word, you will notice that the job TRADOS does in the dot is actually already quite sophisticated. That it sometimes fails with DOCs that are so badly formatted that every pro can only laugh (or cry) about it ... well, no one can be that perfect to consider all the sick formatting ideas greenhorned word users might have. With all due respect, but it's not always ludicrous to call it a Word (or as I'd say User's) problem and I'd even tend to say, that more or less all TRADOS problems with Word DOCs are neither a word problem nor a TRADOS problem, but a problem created by Word users who simply do not care about the (technical, structural) quality of their work when writing their DOCs (uhhhh dangerous theory ...). You should not blame trados for it, but your clients who created the doc.
Therefore I'd tend to give a general recommendation: I'd suggest to check the source DOCs for ugly formatting before you make your quote. In my humble opinion, clients who refuse to hire professional tech writers and graphic designer with the necessary knowledge to create professional source language documentations that are prepped in a professionaly way for translation should not be awarded by charging them the same price you would take for a professional documentation that you can work with smooth and properly. Word Count and Matches are finally not everything. Working on a terribly formatted DOC may take you a multiple of time - and translation should be therefore much more expensive. I'd say: Let the tight-fisted clients with their ugly DOCs that make our live so difficult fork out for it.

Now, the SimSun problem ....

Regarding the SimSum problem (corrupted special charaters in target segments in languages like SE, FR, PT/PB, DE etc): Afaik this only happens with tagged files and Word 2k and above. Also it seems to happen only with segments that have tw4winInternal tags. As far as I have isolated the problem until now, a couple of preconditions need to come together: First: It seems that it only happens with RTFs that were processed in any way (even if it's only a simple save (as)) in Word 2k and above. Sample: You create RTFs with S-Stagger from MIFs. You do not have any "complex script" languages supported in MS Office Language Settings. Translate the files as usual and it's very unlikely that you will face the SimSun problem. But: If the person who created the RTFs with e.g. S-Tagger did have support for complex script languages installed or was working on an arabic or asian Windows and did any changes (e.g. pretranslation) on the RTFs, it's likely that you'll face the problem.
There seem to be a couple of other reasons for this problem, too. As far as I can tell for now it's due to Word's support for complex scripts. Check the Font Tab in the > Format > Fonts dialog. If you can see there the section "Complex scripts" where you can specify a different font for double byte languages, it's likely that you will face the SimSun bug after closing a segment. Obviously Word (not TRADOS for sure!) does some automatic codepage changing of the text (seems to me that Word does some wrong mapping of unicode values, resp. missinterpretes the text: If you have tw4winInternal Tags Word assumes that the sentence is actually in a complex script language).
I have actually spend weeks of research on this issue as I know many, many TRADOS translators who have the SimSun problem (while TRADOS of course told me that they have never heard of ot before and cannot replicate it ...). I finnaly came to the conclusion to NOT use MS Word 2k or above for translation of tagged TRADOS RTFS, but only use TagEditor (where you do not have this problem and also do not have a lot of other problems).
Nevertheless for "real" Word Docs I did not find a solution until know. The only solution seems to be to make a fresh Word Install without any support for double byte languages (which you can as mentioned verify by checking if you have the complex scripts section in the font tab in the character designer).

Well, regarding font substitution: As far as I can tell, there is actually no font substituion unless you have specified one in TMW setup. Nevertheless WORD (and not trados) might change the fonts when closing a segment. Check out the many options Word offers. One of the very first steps if you need to translate "real" Word Docs (i.e. not tagged rtfs) should be to turn off "Automatically update styles". Assumed that it's clear what this pgf style flag does and that you know that it might be a tedious work to check this for big docs with tons of styles, here you go with a small macro that does this job in a second:

Sub KillAutoUpdate()
' Turns off "Automatically update" for all Paragraph Styles
For I = 1 To ActiveDocument.Styles.Count
If ActiveDocument.Styles(I).Type = wdStyleTypeParagraph Then
With ActiveDocument.Styles(I)
.AutomaticallyUpdate = False
End With
End If
Next I
End Sub


Well, enough now, this was already too long anyway

Cheers,
*Stefan.


Direct link Reply with quote
 
EKM
Sweden
Local time: 02:32
English to Swedish
+ ...
Solved! Aug 20, 2004

This is what I did (all in TRADOS):

1. Went to File > Setup > Fonts, selected "SimSun" as source font, and "Times New Roman" as target font, and then clicked "Add". Presto! Everything is now clockwork, bliss and happy-clappy... like it SHOULD HAVE BEEN from the beginning.

Thank you Stefan for your very long and interesting post - I learned something new, and will definitely sit down and learn more about style definitions in Word until next time I write a document...

It would be interesting to hear whether this fix works for other people with the same problem too?

You can of course always blame people instead of the software. My personal opinion is that it is the software that should be adjusted to people's behaviour. There is already too much adjustment by people to our machines.

I am sure Trados (or Microsoft) could work around this problem if they put their mind to it. After all, Microsoft own part of Trados, n'est-ce pas?

Is it really that hard for the two companies to communicate with each other?


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 02:32
English to German
+ ...
Response from Trados Aug 20, 2004

Hi all,
Thanks to Stefan for the detailed analysis.

I brought this to the attention of Daniel Brockman at Trados; here is his response:


Re. the font changes etc.: In T6.5.5 development (and again looking very closely at our Word integration), we found that depending on the language settings in your OS and the language settings in Word, Word sends *very* different data to Workbench, which can result in font changes, character corruption and other issues. We have attempted to make Workbench much more robust in T6.5.5 in this respect, but would still highly recommend users to deactivate any languages they do not work with both at OS and Word level. For instance, in English-Swedish translation, when users see SimSun appearing all of a sudden, it often helps to look at the language support in the OS and deactivate support for Asian languages, at least when working English-Swedish (since then you definitely do not need Asian support). It also helps to clear up styles (as you rightly suggest), and it can help to copy the document content into a new, "fresh" document. Especially if only relevant languages are installed at OS and Word level, such a copy procedure effectively cleans the unnecessary language information from the RTF; for instance it will remove SimSun references.


Also see the comments posted in www.proz.com/topic/22571?start=15, and the request for feedback regarding the preferred handling of Word documents.

Best regards, Ralf


Direct link Reply with quote
 

Per Bergvall  Identity Verified
Norway
Local time: 02:32
Member (2002)
English to Norwegian
+ ...

MODERATOR
Not so desperate any more Sep 6, 2004

It seems I am slowly coming to grips with the apparently arbitrary font substitutions, which I still maintain is a Trados problem. Technical chitchat aside, if Wordfast can translate a document perfectly, without any of the problems encountered in Trados, then Trados must answer for their decision to modify fonts during and after translation. I wouldn't mind the occasional switch between normal fonts and attributes, but when the changes make translation work impossible (maybe you have a screen where 4 pts Times, Italic, double strike-through is legible, but I don't), and my customers complain that I have messed up their documents, I'm stuck with an ugly problem.

Anyway - before I start any translation in Trados these days, I study the document carefully.
I open Styles and formatting, and rest the cursor on each style in the list to review its properties. I make sure the Normal style uses nice, clean fonts for straight text and complex scripts. I select a style or two, select all occurrences, reapply the style and look for changes. If there's a style there that has a 'complex script' font defined that I don't like, I simply delete the style. If a non-deletable style has a Unicode font defined, as standard or complex script, I change it to Arial. And don't worry if the drop-down box in Complex script fonts seems to contain only the offensive fonts - just type Arial.

When I have a list of styles with only fonts I know and trust, I close Styles and formatting, and start translating. I then see only the 'normal' amount of still annoying font changes - unbold to bold or the other way around, but these are usually cleaned up after translation.

I'm happy for those who have found a solution in Trados, to force a particular font to be used. This never seemed to work for me - and why this feature couldn't be extended to say 'force the source font' is a mystery to me, as the source font never seems to be the problem - but rather the way it came to be applied.

Finally, I wish someone would post a procedure to rid my machine of every bit of support for Oriental languages, as I don't need it, and it's causing me problems. I don't know how many times I've uninstalled the Batang font, but it seems to reinstall itself each time there's a job from Mr Lee.


Direct link Reply with quote
 

Salit Levi  Identity Verified
Israel
Local time: 03:32
Member (2005)
English to Hebrew
+ ...
partial solution... Mar 24, 2005

Mårten Dalhed wrote:

This is what I did (all in TRADOS):

1. Went to File > Setup > Fonts, selected "SimSun" as source font, and "Times New Roman" as target font, and then clicked "Add". Presto! Everything is now clockwork, bliss and happy-clappy... like it SHOULD HAVE BEEN from the beginning.


I tried that, too, and the translation in the file seems ok (for a change). However... the TM entries where ruined, still. Even entries that where ok before (i.e. 100% matches), are now ruined with the chinese characters, and are no more usable.
Have you checked what your TM entries look like after the translation?

I work on English source, translating into Hebrew. The chinese characters in the TM and SimSun font in the target text appear most often when translating "normal" Word files - with no formating and no nothing. Just plain text. My Trados really does not like it.

The quick fix that I found, for what it's worth, is copying the text to a file with text that was previously tagged by Trados, and there everything worked just fine. When I have finished translating, I copied the text back into the original file and cleaned it.

just my 2 cents...

Apart from the Chinese characters and fonts, when translating into Hebrew we oftem get Arabic characters as the target text. after closing a string. I have no idea why it happens (only with some stings, and not with others) or how to correct it.


Direct link Reply with quote
 
xxxdgmaga
English to Spanish
WordFast does not handle internal formatting in the segments Mar 24, 2005

It seems I am slowly coming to grips with the apparently arbitrary font substitutions, which I still maintain is a Trados problem. Technical chitchat aside, if Wordfast can translate a document perfectly, without any of the problems encountered in Trados, then Trados must answer for their decision to modify fonts during and after translation.


Hi,

Just to be fair with Trados, WordFast has fewer problems with fonts because it does not retrieve nor store any formatting information in the translation memory.

This means that if you have to translate a sentence like this ten times in a document:

In the File menu, click Open.

(with the words "File" and "Open" in bold), you will have to apply the bold formatting in your translation everytime you get them as "100%" with WordFast.

Trados, on the other hand, manages to keep the formatting information. When get a 100% from the TM, if will keep the internal formatting in isolated words.

To achieve this, the Workbench has to handle the formatting information it receives from Word, which, as pointed out in Ralf's message above, it's not always consistent, depending on the Word version, on the (poor) author's formatting decisions, etc.

Anyway, I tend to agree with you, on the other hand, that, even if it's a problem originated in Word by poor authoring of documents and even if it could not have been foreseen by the programmers, it's a problem that occurs when using Trados with Word. It should be possible to find a solution, specially when, according to the Trados web site, one of the Workbench features is its "seamless integration with Microsoft Word". According to the Webster's dictionary "seamless" means "having no awkward transitions or indications of disparity : perfectly smooth"...

Maybe they should change their brochures to something like "seamless integration with Microsoft Word, provided that Microsoft Word is used properly"...

Daniel


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 02:32
Member (2003)
Polish to German
+ ...
Ehm, it works perfectly smooth Mar 24, 2005

if the document is formatte as it should be.
You cannot blame Trados and its programmers for the bad formatting of documents by our clients.
Everybody knows, that indents are not to be made using hard line breaks and spaces, or that you shouldn't define a style and then change its properties localy by hand.
But most of Word documents coming from my clients are formatted in that bad way. What to do? Sometimes it is worth to reformat the document, making the formating "Trados compatible".
When this does not help, there are various tricks one can use, starting from copying the whole text to a brand new document until completly removing the formatting and translating the whole as plain text.
I have not tried Wordfast, so I cannot tell, if it would handle documents with that bad formatting, which causes problems with Trados. This was allready explained before - Trados keeps the main formatting for the text, making working with the text usually much easier.
A lot of poblems may be avoided, if you do not clean in Workbench. For cleaning purposes the whole document is saved as RTF. If you do not get the template belonging to the document you are translating, you may encounter problems I had recently. All formatting get mad, automatically changing after reopening the document. Everything looked OK on my screen, and after reopening by my customer everything was weird again... I have contacted Trados on this issue and they told me, that all this was caused by missing template in conjunction wit conversion to RTF while cleaning.

Trados 6.5.5 does not cause any major problems anymore, at least not for me. However, if the document comes from Far East and has two languages set, first ie Chinese and second English or oher, the only help is to overwrite the styles using a template generated on my PC (menu Format - Templates and add ons - Organise) and reformatting the whole.

Regards
Jerzy


Direct link Reply with quote
 

Morten Narboe  Identity Verified
Local time: 02:32
English to Norwegian
+ ...
Well Mar 30, 2005

I'd say it's a Trados problem. Yes, the Word documents are formatted incorrectly, and yes, if formatted correctly it works fine. But why can't Trados handle this, considering that it's a well known problem that huge amounts of documents (most of them?) are, indeed, formatted incorrectly. Why can't Trados go "hmmm, the source segment is written with Arial, then I must use Arial when saving the segment, I'm a genius!!". Instead it goes "hmmm, source segment is written with Arial, but style says it should have been Times New Roman, so I'll use that and annoy everybody, I'm an evil genius, muahahaha! ".

Maybe there's no way for Trados to check for the actual font, only the style (sounds unlikely, but hey), but if it's fixed with 6.5.5 I guess that proves there is a way around it for Trados after all


Direct link Reply with quote
 
Mpoma  Identity Verified
United Kingdom
Local time: 01:32
French to English
a contribution to this thread Aug 22, 2005

Hi all,

I don't know whether this is the right thread but one of about 4 serious problems I have with Trados 6.5 concerns what happens when a "character style" has been applied to a bit of a paragraph and then, on top of that, one or more manual font changes...

In such a case the Trados engine (6.5) always seems to return the character style stripped of the additional manual formatting changes (e.g. font size).

The comments of the bloke who ranted on about "professional document writers" or whatever are completely irrelevant. In the real world people of all kinds a) write documents of all kinds, and in all kinds of ways and b) have no knowledge nor ever will have of that vile, clunky language Word VBA. Cease and begone!

It is simply the case that Trados should offer an option "do not remove manual formatting from character styles". Bear in mind that writers of documents, professional or not, do not have the option in Word of applying a character style which simply sits on top of whatever manual formatting currently applies... all Word character styles have to make reference to a particular paragraph font...

And Trados currently sees fit to return such character styles to that font without asking any permission... this is wrong, and I ask the Trados people to change it ASAP

Mpoma


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Font Change in Translation Process with Trados 6.5

Advanced search


Translation news related to SDL Trados





WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs