Mobile menu

Pages in topic:   [1 2] >
Trados: font changes when closing a segment
Thread poster: Valeri Serikov

Valeri Serikov  Identity Verified
Local time: 15:58
Member (2003)
English to Russian
+ ...
Jul 2, 2004

Hi all,

I have the following problem: if the text is Arial and I close a segment, the whole sentence turns out to be Times New Roman. Is there any turnaround to this problem? I changed the registry key c1252 into c1251 (Codepage/Nls) to properly display Cyrillics, but I do not think the problem is here. I tried to change the fonts in the Fonts tab with no effect...


Direct link Reply with quote
 

Valeria Verona  Identity Verified
Argentina
Local time: 09:58
Member (2003)
English to Spanish
+ ...
feedback Jul 2, 2004

It is a usual problem with TRADOS. Unfortunately I never heard of any solution.
Can anyone help?


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 13:58
English to German
+ ...
Formatting problem in Word Jul 2, 2004

Hi Valery and Valeria,
I assume you're referring to Word documents? You didn't say so...

It is a usual problem with TRADOS.

Er... usually it isn't: this problem generally occurs if the Word document isn't properly formatted. Many word users are oblivious of styles and paragraph formatting: to change their document from TNR to Arial, they highlight everything and use character formatting to make the change. The proper way would be to change the font of the Standard style to the desired font.

Have a look at the style definition of that paragraph: if there's a difference, you know where your problem comes from.

One caveat: this could be a codepage/Unicode issue as far as CEE characters are involved. Which Trados version are you using?

Best regards, Ralf


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 13:58
Member (2003)
Polish to German
+ ...
Check the format settings in documet Jul 2, 2004

Very often customer format their documents in horrible way. They define hundreds of styles and then go and reformat each piece of text manually. Often this is the reason for Trados behaving in this way, as Trados restores the original formatting after closing the segment.
There is no real workaround for it, AFAIK. What you can do is simply translate the document without taking care about the formatting changes, clean up the document (in Word, NOT in WB, as then you would adapt the format changes to your segments in TM) and reformat it to the way it looked before. This helps to save your nerves...
This occurs very often (I woul say every time), when I get documents created in Asia. In such case even if you reformat the document to the proper font settings, the language setting keeps the asian language and sets your language as the second one. In such case there is no way to get rid of this problem, you only can manually reformat the document after translating.

Regards
Jerzy


Direct link Reply with quote
 

Valeria Verona  Identity Verified
Argentina
Local time: 09:58
Member (2003)
English to Spanish
+ ...
Word, yes... Jul 2, 2004

Ralf Lemster wrote:

Hi Valery and Valeria,
I assume you're referring to Word documents? You didn't say so...
Best regards, Ralf


I'll take a closer look at the original document format next time to implement what you are suggesting, Ralf.


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 13:58
English to German
+ ...
Tell your customers... Jul 2, 2004

I'll take a closer look at the original document format next time to implement what you are suggesting, Ralf.

The problem is usually with your customer...

Cheers, Ralf


Direct link Reply with quote
 

Judy Rojas  Identity Verified
Chile
Local time: 09:58
Spanish to English
+ ...
Also, check your TM setup Jul 2, 2004

In File/Setup go to Fonts and make sure that "Translate into target default for all other fonts" is no checked.

What that that will do is replace the target font with the default font if you don't happen to have the source font installed in your PC.

HIH,

Ricardo


Direct link Reply with quote
 

Monika Coulson  Identity Verified
Local time: 05:58
Member (2001)
English to Albanian
+ ...
Who likes to be responsible? Jul 3, 2004

Ralf Lemster wrote:
The problem is usually with your customer...


But the customer will not accept that.
I told once one of the client that the problem was on their formatting and her [lame]excuse was: "Other translators did not have this problem, it's only you!"
p.s. Well, if I was the only one of her translators who used Trados, then she was probably right.

Monika


Direct link Reply with quote
 

Hynek Palatin  Identity Verified
Czech Republic
Local time: 13:58
Member (2003)
English to Czech
+ ...
Trados Jul 4, 2004

Was Trados required by the customer to do the job? If not, then it's unfortunately your problem. The customer is expecting final translation with the same formatting and doesn't care about problems caused by using a CAT tool.

For me, this the most unpleasant aspect of using Trados. I wish it was possible to open Word documents in TagEditor the same way Excel and PowerPoint documents can be opened.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 13:58
Member (2003)
Polish to German
+ ...
This would not be that good Jul 4, 2004

Hynek Palatin wrote:

Was Trados required by the customer to do the job? If not, then it's unfortunately your problem. The customer is expecting final translation with the same formatting and doesn't care about problems caused by using a CAT tool.

For me, this the most unpleasant aspect of using Trados. I wish it was possible to open Word documents in TagEditor the same way Excel and PowerPoint documents can be opened.


Well, I for one wouldn´t like that. Word docs can be very well processed in Word, and only in some very bad cases editing in TAG Editor would give you some advantages. One can get used to all those font changes and get rid of them mostly in very simple way. And if you believe, TAG Editor does not change fonts - well, I´ve allready had textes with font changes in TAG Editor. My polish characters were corrupted then. The reason is nearly allways the asian story of the document.
Sometimes saving as RTF, closing Word and opening the document then with saving as Word helps, but one should be carefull about links and so on.

Regards
Jerzy


Direct link Reply with quote
 

Selçuk Budak  Identity Verified
Local time: 15:58
English to Turkish
+ ...
This is a standard problem with code pages other than standard latin. And there is a simple solution Jul 5, 2004

Yes, the problem is related to code pages. But changing fonts would not soleve the problem.

The problem arises partly from the way that Word treats and handles "styles"

In word, every paragraph has a "style," that also predefines the style for the next paragraph. And this style definition also includes information about the default language of that paragraph.

In sum, the paragraph style includes such information: font, font size, properties (bold, italic, etc.) position, alignment, and last but not least, LANGUAGE.

Trados opens and closes every segment (sentence) not as a sentence, or a part thereof, but as a "paragraph."

Problems arise while working with Trados when the style in question is in different language (or font) than your "target language"

For example, if your default paragraph style is in English, and your target language is, say, Russian, it is sure that you will experience the problem. The same holds true for the fonts.

There are two ways to circumvent the problem:

1. Place the cursor on the paragraph, open the format menu, click "Style," and delete the current style.

OR:
2. Place the cursor on the paragraph, open the Format menu, click "Style," then "Modify," "Format," "Language"
and modify language as required.

OR
3:
There is a third way which requires a certain knowledge on styles:

You can define another paragraph style for your target language.

For example, if your original text is in "Normal Style," you can create a paragraph style called, lets say, "newNormal" defining your target language as the default language.
Then, you should modify the normal style as follows:

Format / Style / Modify
"Format for the following paragraph" [choose newNormal you have just created]

Any of the above would solve the problem.

This is a common problem that I encounter frequently. And I follow the simplest way: Just delete the current paragraph style out of laziness.

h.i.h.


Direct link Reply with quote
 

Valeri Serikov  Identity Verified
Local time: 15:58
Member (2003)
English to Russian
+ ...
TOPIC STARTER
There are lots of styles... Jul 5, 2004

...in the source document. Is there any trick to change the target language in them in batch?

Direct link Reply with quote
 

Anil Gidwani  Identity Verified
India
Local time: 18:28
German to English
+ ...
Language Settings for complex scripts may be causing the problem Jul 31, 2004

Check out Technical Forums>Trados support>Unwanted Font Changes

The solution outlined there worked for me.


Direct link Reply with quote
 

Stefan Gentz
Local time: 13:58
English to German
+ ...
Try this macro to change the language in all Paragraph Styles Aug 20, 2004

Valery Serikov wrote:
there are lots of styles in the source document. Is there any trick to change the target language in them in batch?


Try this macro:

Sub ChangeAllStylesLanguages()
' Changes the language for all pgf styles
For I = 1 To ActiveDocument.Styles.Count
If ActiveDocument.Styles(I).Type = wdStyleTypeParagraph Then
With ActiveDocument.Styles(I)
.LanguageID = wdRussian
End With
End If
Next I
End Sub


You may of course change .LanguageID = wdRussian to any other language supported by word. Delete "= wdRussian", type in again "=" and check the appropriate lanuage names VBA will list.

Cheers,
*Stefan.


Direct link Reply with quote
 

Stefan Gentz
Local time: 13:58
English to German
+ ...
TRADOS, CodePage issues, Unicode and VBA Aug 20, 2004

I'd like to bring in a new thesis: Actually there is no need to change Arial to e.g. Times New Roman when it's about translation "Western Language" Russian, CE Languages, Greek. Both Arial and TNR (at least if you do not have some very outdated ttf versions by accident) are OpenType Fonts and both provide full character support for Central European Languages (Windows CodePage 1250), Russian (CP 1251), "Western Languages" (CP 1252), Baltic (CP 1257), Greek (CP 1253) and Turkish (CP 1254). You may like to check Microsoft FontProperties Extension to check if your versions of Arial and TNR do support these languages.

Therefore there is absolutely no need to change Arial or TNR when you translate languages that are within these supported codepage ranges of these two fonts when you are translating in MS Word or TagEditor. MS Word and TE support the Unicode Standard. Please also note that Word will only show you OpenType Fonts as e.g. "Arial" while you are actually only using one or more codepage subgroups of these fonts (e.g. for non-unicode FrameMaker, PageMaker, Quark etc you'll need to "release" these subgroups in the registry by using e.g. WGL Assistant).

While I was able to solve the problem with corrupted characters after closing a segment by simply copy & pasting the whole source RTF into a new empty doc (worked for me now on a couple of projects), right now a new idea came to my mind ... As mentioned Word's text engine does support Unicode. I.e. Word's able to adress and display all Unicode values and therefore characters of a Unicode font. So, for Word everything is fine. Now let's have a look at a TU in the TMW.

E.g. german "Sicherheit" shows up in the "Edit Translation Unit" as "Áåçîïàñíîñòü" (1) which is actually russian "Безопасность" (2 - not sure if this will make it into the post). While (1) is a string of western codepage 1252 characters (latin characters with accents, cedilles, ring-above, tildes etc.), the "real" russian word (2) exists form "real" unicode values and shows up properly with cyrillic characters.

This brings me to the following: Is it possible that TRADOS TMW does NOT support unicode properly? The "corrupted" segments usually will look like (1) - which cannot be a problem of Word's text and Unicode engine (at least in theory). My hunch is, that when you get a translation from TMW you will get it as a CP 1252 (or whatever your system local setting is) string like in (1). This will look fine as long as you have the segment open. If you close it, Word probably maps these characters to the "theoretically" correct Unicode Code Points (and for (1) these are values in CP 1252 (or whatever your system local setting is) CodePage). I might be completely wrong, but sounds to me like a new approach, TRADOS might like to check. Maybe it would be worth a try to get the target segment from the TMW not "as is" (which probably needs to go through the codepage of your system local and therefore will be automatically "converted" when it arrives in VBA) but to convert the TMW Target Segment to Unicode on a pre Word-insertion level first (i.e. before they process it as a string with VBA). After this get the Unicode String from the TMW into VBA, convert the Unicode Values to Characters and insert them into the open TU Target Segment in Word.

Just as a first approach a small function that converts a selection (TargetSegment) into a string of unicode values ...

Function ConvertStringToUnicodeHex(TargetSegment As String) As String
Dim vStringChrCount As Integer, i As Integer
Dim vCurrentChar As String
For i = 1 To Len(TargetSegment)
vCurrentChar = Mid(TargetSegment, i, 1)
ConvertStringToUnicodeHex = ConvertStringToUnicodeHex + _
Replace(Format(Hex(AscW(vCurrentChar)), "@@@@"), " ", "0")
Next i
End Function

Especially Ralf: Maybe you'd like to adress this post to TRADOS? I have that feeling, that the whole problem is with the system local codepage and VBA. It might be actually worth a try to check this.

Cheers,
*Stefan.


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados: font changes when closing a segment

Advanced search


Translation news related to SDL Trados





Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs