Mobile menu

Why do I lose half of my TM when importing it?
Thread poster: avsie

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
Aug 10, 2004

Hello everyone,

I'm experiencing a great problem. I was a Wordfast user, and I moved
on to Trados recently (I have version 6.5). I'm trying to import my
WF memory into Trados.

First I have exported my WF memory in a TMX format.

When I tried to create a new TM in Trados and import that TMX memory,
I basically lose almost half of my units. Mind you, my memory
contains 136 000+ units!!! After the import, I'm down to 86 000.

What goes wrong? I'm not getting any error messages, not even about
units being invalid or anything. Nothing!

I have checked my WF memory for language codes errors, and I
corrected them (there were a few). But still, the import gives me
pityful results.

Are the units really lost? How can I know which units weren't
imported? Does it means I have to basically align 15 months worth of
work?

Many thanks for your help!!!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 02:34
Member (2003)
Polish to German
+ ...
What kind of message is displayed in Workbench after finishing the import? Aug 10, 2004

In the status bar of the Workbench you should read:
136000 units read, 86000 units imported, nn ivalid

Possibly there are repetitions in your TM and you have set Workbench not to import repetitions...
Maybe some of units are invalid.
Check the import settings in WB.

Regards
Jerzy


Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
Thanks! Aug 10, 2004

Tayfun Torunoglu wrote:

I think In wordfast there are TM rules re-entering a TM entry already exsiting among previous ones. Perhaps import is merging those the same TMs to single one. I think there must be a setting for this repetitive import in Trados too.
But on the other hand the amount missing in your TM import is a little too much for thinking this. Is it likely to have so much same TM units?


I thought about that too, but before exporting it from WF, I did "clean" it up by deleting the redundant segments (with same source/same target).

Could it be possible that this deletion of redundant segments didn't really work? (it did delete only 237 segments... which I have found strange, I expected much more!) So when I'm putting it into Trados, it deletes them...

I'm trying the import again, just out of curiosity. I want to check what message I get in the status bar of Trados, the last time I didn't pay attention...

Thanks for your help


Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
Text in the status bar Aug 10, 2004

The text of the status bar says:

136411 TUs read, 271 updated, 84238 added, 11 invalid


When I imported the file, I chose the options:

- large import (with reorganization)
- merge

I created a "new" TM before importing the TMX.

Any clues?


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 02:34
Member (2003)
Polish to German
+ ...
Merge Aug 10, 2004

You merged segments, so this will possibly be the reason for the shrinking.
AFAIK different CATs handle numbers in segments in diferent way. There must be a difference in handling of standard chains between Trados and Wordfast.
For example, while Trados automatically translates matches as "Point 1" "Point 100" ans so on, Star Transit Satellite PE stops at each such segment and wishes manual confirmation.
I do not know the beahviour of Wordfast on such situations, but possibly Trados has recognised repetitions of this kind.

Regards
Jerzy


Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
ah ha! Aug 10, 2004

Jerzy Czopik wrote:

You merged segments, so this will possibly be the reason for the shrinking.
AFAIK different CATs handle numbers in segments in diferent way. There must be a difference in handling of standard chains between Trados and Wordfast.
For example, while Trados automatically translates matches as "Point 1" "Point 100" ans so on, Star Transit Satellite PE stops at each such segment and wishes manual confirmation.
I do not know the beahviour of Wordfast on such situations, but possibly Trados has recognised repetitions of this kind.

Regards
Jerzy


Thanks Jerzy!

Yes, WF does changes it automatically to "Point 100", or at least it offers it to you as a match

What option should I check instead of Merge, then? "Keep unchanged"?


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 02:34
Member (2003)
Polish to German
+ ...
Try "keep unchanged" Aug 10, 2004

Maybe this will change the situation.
This is only guessing, as I never imported a Wordfast TM into Trados - was never necessary.

Good luck
Jerzy


Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
Nope... Aug 10, 2004

Even with "keep unchanged", I actually obtained 4000 TUs less... strange...

Playing around with the different options now...!


Direct link Reply with quote
 

Ivan Eikås Skjøstad  Identity Verified
Norway
Local time: 02:34
Member (2002)
English to Norwegian
+ ...
Do a tmx export from Trados Aug 10, 2004

Try to export to tmx from Trados. Then take a look at the tmx-file. Copy the first lines before the TU's start (containing the information used by Trados to do the import). Paste these lines into the top of the tmx-file you want to import, replacing the text already there (Int the tmx-file you exported from Wordfast).

This should work. If not, try to use an older (or newer) version of Wordfast. Which ver. do you use?

I have tried this method once, and it actually worked. Good luck.


Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
Thanks Ivan! interesting! Aug 10, 2004

Ivan Eikås Skjøstad wrote:

Try to export to tmx from Trados. Then take a look at the tmx-file. Copy the first lines before the TU\'s start (containing the information used by Trados to do the import). Paste these lines into the top of the tmx-file you want to import, replacing the text already there (Int the tmx-file you exported from Wordfast).

This should work. If not, try to use an older (or newer) version of Wordfast. Which ver. do you use?

I have tried this method once, and it actually worked. Good luck.



I shall try this at once!

I\'m using WF 4.20 build 40...


Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
Again... nope! Aug 10, 2004

I've ticked the "Allow multiple translations" box, just to make sure, after having done what you suggested, Ivan.

And again, I get the same number of segments as stated above.

Then it must be some repetitions that I don't know of...

Thanks


Direct link Reply with quote
 

Ivan Eikås Skjøstad  Identity Verified
Norway
Local time: 02:34
Member (2002)
English to Norwegian
+ ...
Strange Aug 10, 2004

My last tip will be to try an upgrade to 4.22 t22. I am not sure if this will help, but I won't hurt to give it a try. I know that tmx was an issue some time ago.

Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
Very strange! Aug 10, 2004

Ivan Eikås Skjøstad wrote:

My last tip will be to try an upgrade to 4.22 t22. I am not sure if this will help, but I won't hurt to give it a try. I know that tmx was an issue some time ago.


I'll see what I can about upgrading to the other version. I'm in-house, so it always takes forever before we can install softwares...

Thanks for helping, I very much appreciate it


Direct link Reply with quote
 

avsie  Identity Verified
Local time: 02:34
English to French
+ ...
TOPIC STARTER
Update! Aug 16, 2004

I've got now the very newest version of Wordfast, and the very newest version of Trados, on my computer.

With the exact same result as for the "losing half of my TM"!

Many thanks for those you helped me, the mystery still continues...!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Why do I lose half of my TM when importing it?

Advanced search


Translation news related to SDL Trados





TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs