Mobile menu

TagEditor error message shows different languages in document
Thread poster: Jianjun Zhang

Jianjun Zhang  Identity Verified
United Kingdom
Local time: 19:52
English to Chinese
+ ...
Nov 6, 2004

The message, after the converted RTF document was loaded into TagEditor, appeared: "The open translation memory has
different languages than the document. Interaction with translator's workbench will be disabled until a matching translation memory is opened."

I know the source language was English UK, and my TM was from UK English to Chinese (PRC). However, the document refused to be translated, I even couldn't type in any Chinese characters at all.

I believe it was a problem with the file itself. It was converted by my client from FrameMaker to RTF using S-tagger. I think she forgot to set the target language to Chinese (PRC) when processing that file.

Any ideas from you - my colleagues and friends here - are welcome. And TIA!

[Subject edited by staff or moderator 2004-11-06 09:19]


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 20:52
English to German
+ ...
Check the language settings of the TTX file Nov 6, 2004

Hi Jianjun Zhang, and welcome to ProZ.com.

You can double-check the language settings by opening the TTX file in a text editor: search for the SourceLanguage and TargetLanguage tags. These must match the settings in your TM. If they don't (compare to the language codes in a TM export if necessary), it's possible to change these tags (remember to remove any .txt extension which the text editor may add to the file name).

HTH, Ralf


Direct link Reply with quote
 

Jianjun Zhang  Identity Verified
United Kingdom
Local time: 19:52
English to Chinese
+ ...
TOPIC STARTER
TargetLanguage tag is not available Nov 6, 2004

Ralf Lemster wrote:

Hi Jianjun Zhang, and welcome to ProZ.com.

You can double-check the language settings by opening the TTX file in a text editor: search for the SourceLanguage and TargetLanguage tags. These must match the settings in your TM. If they don't (compare to the language codes in a TM export if necessary), it's possible to change these tags (remember to remove any .txt extension which the text editor may add to the file name).

HTH, Ralf


Hi Ralf,

Thank you for the reply. I currently only have the RTF file sent from my client, and I couldn't find a TargetLanguage tag in the RTF file. I don't have a TTX file for this doc. A new discovery: I opened it with WORD and found tags like this:


{0>Climate controlled enclosuresClimate controlled enclosures Enclosures:KTS
Enclosures:KTS


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 20:52
English to German
+ ...
Create a TTX file... Nov 6, 2004

Hi again,
Your answer wasn't fully displayed, as the forum software cannot display the tags (they get confused with BBCode).

Jianjun Zhang wrote:
Thank you for the reply. I currently only have the RTF file sent from my client, and I couldn't find a TargetLanguage tag in the RTF file. I don't have a TTX file for this doc. A new discovery: I opened it with WORD and found tags like this:
...
It seems that this document has already been translated, but from English to English. What might be wrong with my client's conversion operation? Thanks.


I don't work with FrameMaker files, so I cannot answer this one, I'm afraid...

Ralf[Edited at 2004-11-06 13:00]

[Edited at 2004-11-06 13:01]


Direct link Reply with quote
 
xxxdgmaga
English to Spanish
Create TTX file (how to...) Nov 6, 2004

Hi,

Just to add to Ralf suggestion, you may find it useful to have a look at a document called "TRADOS file format reference guide". If you don't find it in your TRADOS CD, you can download from the TRADOS download center (www.trados.com).

There you will see that you have two options:

a) Translate the document in Word.

b) Convert the file to TTX by performing an analysis with your translation memory and activating the option "Convert workbench RTF to TTX" (I'm writing from the top of my head, the exact name of this option might be different). After the analysis finishes, TRADOS will have converted your RTF to a TTX file with the correct source and target language.

I hope this helps!

Daniel


Direct link Reply with quote
 

Wojciech Froelich  Identity Verified
Poland
Local time: 20:52
English to Polish
Thanks for the solution Nov 6, 2004

b) Convert the file to TTX by performing an analysis with your translation memory and activating the option "Convert workbench RTF to TTX" (I'm writing from the top of my head, the exact name of this option might be different). After the analysis finishes, TRADOS will have converted your RTF to a TTX file with the correct source and target language.


Thanks for the solution
Seems like opening RTF file directly in TagEditor is not a good idea - I have encountered similar problems while opening English-Polish S-Tagged RTF files in TagEditor (message about different target language, multiple target languages etc.).

Wojtek


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 20:52
English to German
+ ...
Save Workbench RTF as TRADOStag Nov 6, 2004

Hi Daniel,
Thanks for the suggestion - I just looked it up:
b) Convert the file to TTX by performing an analysis with your translation memory and activating the option "Convert workbench RTF to TTX" (I'm writing from the top of my head, the exact name of this option might be different).

Not much different: it's in Options - Translation Memory Options, in the General Options field group, and called Save Workbench RTF as TRADOStag.

Best, Ralf


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TagEditor error message shows different languages in document

Advanced search


Translation news related to SDL Trados





Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs