Mobile menu

Translation of XML attributes
Thread poster: Oleksandr Studenyak

Oleksandr Studenyak
Czech Republic
Local time: 22:04
English to Ukrainian
+ ...
Mar 6, 2006

Hello,
Maybe somebody can advice me how can I translate attributes of XML file in TagEditor? I'm using Trados 6.5, whenever I open XML file in TagEditor the text in attributes is hidden, so it's not possible to translate it. Should I change the *.ini file somehow? Or it's a problem of TagEditor settings?
Thanks,
Alex


Direct link Reply with quote
 

Gusztáv Jánvári  Identity Verified
Hungary
Local time: 22:04
English to Hungarian
+ ...
Are you sure? Mar 6, 2006

Hi,

Are you sure you want to translate XML attributes? It is quite an unusual thing. These attributes are processed by programs and they might not work with localized attribute names (but if they are prepared to interpret localized attribute names). Also, if you go ahead, you should not forget that attribute names may only contain standard ASCII characters, so no your fancy c letters (and no our accented characters) are valid in attribute names.


Direct link Reply with quote
 

bohy  Identity Verified
France
Local time: 22:04
English to French
+ ...
Tag Settings Manager Mar 6, 2006

[quote]e-Musty wrote:

Are you sure you want to translate XML attributes? ...they might not work with localized attribute names


There are two things in attributes : a name and a value.
Of course, names should not be modified (unless you modify the DTD too), but attributes values could.

I have come across some files where obviously some attributes where hidden which should have been translated (for instance "title" attributes)

I have not modified the settings in any .ini file by myself, but I think that you can do that in TagEditor, under
Tools>Tag Settings
Select the .ini file that you want to modify, then click on Properties, then Elements, then Add,
in General tab define the name of the XML element : by default, attributes are hidden, but if you go to the Attributes tab you can define which attributes you want to translate.

I have no time to experiment this right now, but please let me know if it solves your problem.


Direct link Reply with quote
 

Oleksandr Studenyak
Czech Republic
Local time: 22:04
English to Ukrainian
+ ...
TOPIC STARTER
Problem is solved. Mar 7, 2006

bohy wrote:

I have not modified the settings in any .ini file by myself, but I think that you can do that in TagEditor, under
Tools>Tag Settings
Select the .ini file that you want to modify, then click on Properties, then Elements, then Add,
in General tab define the name of the XML element : by default, attributes are hidden, but if you go to the Attributes tab you can define which attributes you want to translate.

I have no time to experiment this right now, but please let me know if it solves your problem.


Hi Bohy,

Thanks a lot! It solved the problem.

Cheers,
Alex


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Translation of XML attributes

Advanced search


Translation news related to SDL Trados





CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs