Strange behaviour of Trados TagEditor
Thread poster: Antoní­n Otáhal

Antoní­n Otáhal
Local time: 18:54
Member (2005)
English to Czech
+ ...
Apr 20, 2006

I have Trados 7.5; I received an rtf file in US English and a TM from my customer; the TM's source language is EN-US, target CS.

Fine. They want to get back the translated ttx; so I opend the rtf in TagEditor, saved bilingual to ttx; but when I wanted to pretranslate the ttx, it said "incompatible language codes" (between the file and the TM)

When I opened the ttx in a notepad-like editor, I could see in its header that its source langue was set as "CS" and the taget language was empty. After manually correcting the language codes in the ttx header I was able to continue normally, but I do not understand how the problem was created. I even exported the customer's TM to txt, created an empty TM with the proper language codes and imported the txt to this new one - I got the same behaviour with this TM for which I am sure of the language codes.

I always thought that if I open a file in TagEditor and save it as ttx, the created language codes are governed by the TM that is currently open - or am I wrong here? I cannot see where I can change the settings of the resulting language codes in TagEditor itself...

Antonin


Direct link Reply with quote
 
xxxOlaf
Local time: 18:54
English to German
Source and Target languages are not encoded in RTF files Apr 20, 2006

Antoní­n Otáhal wrote:
I always thought that if I open a file in TagEditor and save it as ttx, the created language codes are governed by the TM that is currently open - or am I wrong here? I cannot see where I can change the settings of the resulting language codes in TagEditor itself...


I don't think that TE uses the languages of an open TM to determine which languages to use when saving files. After all, you can theoretically open TE and work without a TM and still save RTF files as TTX files. Since Tag Editor often cannot tell what the source and target languages in RTF files are, files are often saved with the wrong language encodings. Therefore, simply opening an RTF file in TE and saving it as TTX often won't work as intended.
If you want to convert an RTF file to a TTX file, it would be better if you translated it using an existing or blank TM with the proper language combination and direction. This will ensure that the resulting TTX is properly coded.

Olaf


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 18:54
Member (2004)
English to Slovenian
+ ...
"...so I opened the rtf in TagEditor, saved bilingual to ttx..." Apr 20, 2006

Hmm...

I would first pretranslate RTF in WTB and THEN go to TagEditor for TTX. But then again,this is just as much woodoo as your workaround. And maybe, probably it would not even work...
Sigh...

There's some new exciting checkboxes in WTB mentioning TTX and XML (see Tools/tools). Could be the source of your troubles.


Direct link Reply with quote
 

RWSTranslation
Germany
Local time: 18:54
Member (2007)
German to English
+ ...
languages Apr 20, 2006

Hello,

there is a possibility to set the standard source language in TagEditor. This source language will be the source language of a ttx, file if the ttx file is created without a connection between TagEditor an workbench (or if there i no memory loaded in workbench).
If you create a ttx file with a opened memory, the ttx will have the languages of the memory.

In older versions of Trados, there was sometimes a language setting problem when the Trados software isn'tcorrect regestered in Windows. This can happens if you use more than one Trados version on the same computer.

Hans


Direct link Reply with quote
 

CathyFS  Identity Verified
Local time: 17:54
German to English
+ ...
Check the <Seg L= ...... > setting in your TM export file Apr 21, 2006

Antoní­n - when you exported the customer's TM to a text file and imported it into a blank TM, did you first open the text file to check the language code Trados placed before the relevant segments? Even when you create a blank TM, if you import a text file, it will also import the language codes without changing them automatically to suit the source/target languages of your TM. For example, if I'm using a German - UK English TM and import another TM, in this case one whose target language is US English, into my existing TM to supplement it, Workbench will actually import the US segments as they are into my UK TM ...... I hope this is of some help to you. Cathy.

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Strange behaviour of Trados TagEditor

Advanced search







WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs