Mobile menu

BR tag in TagEditor when translating Excel files
Thread poster: Pavel Lyakhovsky

Pavel Lyakhovsky  Identity Verified
Russian Federation
Local time: 17:12
Member (2006)
English to Russian
Apr 24, 2006

Dear colleagues,

I'm translating a number of Excel files containing long text strings in each cell with many line breaks. These line breakes are recognized by TagEditor as BR tags.

However when I open a segment in TagEditor it opens it from the beginning of the sentence to the first BR tag. While I would prefer to have the whole sentence open with all BR tags inside. I would then translate the whole sentence and then place all BRs manually. 'Expand segment' doesn't work for this case.

Any ideas?

Best regards,
Pavel

P.S. I'm using SDL Trados 2006

[Edited at 2006-04-24 11:14]

[Edited at 2006-04-24 11:14]


Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 15:12
Member (2005)
English to Czech
+ ...
One should not interfere with tags Apr 24, 2006

But, having said that, I would open the ttx file in a notepad-like editor (e.g., jEdit is free) and delete the br tags from it using "search and replace". Of course, keeping a backup of the orginal ttx just in case. I am not sure it will work; it may be worth trying, though.

HTH,
Antonin


Direct link Reply with quote
 

Natalya Zelikova  Identity Verified
Ukraine
Local time: 16:12
Member (2003)
English to Russian
+ ...
may be this will help Apr 24, 2006

Trados Help says:
"Identify the tags that must be internal in order not to break segments, and make sure all other elements are set to external tags."

Try to go to Tools-Tag Settings and choose appropriate *.ini file. Then click Properties-Elements tab. Find BR tag (it should be there as external) and make it internal.

Not sure if it is the correct way but I think I did this some time ago.


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 15:12
Member (2004)
English to Slovenian
+ ...
BR tag as segmentation character Apr 24, 2006

...However when I open a segment in TagEditor it opens it from the beginning of the sentence to the first BR tag.


If you look at TWB (!it's the TWB and not the TagEditor that decides, what a segment is) and open setup/Segmentation rules, you may have a chance to neutralize BR in its unwanted function. I would bet "End of Paragraph" is the offending entry.

let us know, if it works.

smo


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 15:12
Member (2003)
Polish to German
+ ...
This is easier as you think (in Trados 7 and above) Apr 24, 2006

Via "All Programs" go to Trados folder, chose Filters and click on Filter settings. There chose Excel, go to Segmentation and deselect the option "Select after break tags".

In this settings you can also configure the behaviour of other filters, such as S-Taggers or Word filter - very usefull settings indeed they are!

HTH
Jerzy

[Edited at 2006-04-24 12:08]


Direct link Reply with quote
 

Sylvain Leray  Identity Verified
Local time: 15:12
German to French
Thanks! Apr 24, 2006

Jerzy Czopik wrote:

Via "All Programs" go to Trados folder, chose Filters and click on Filter settings. There chose Excel, go to Segmentation and deselect the option "Select after break tags".



Jerzy, once more, you made my day! Thank you so much

What I do in this case is to delete the target segment (Alt + Suppr), manually delete the tag and re-open the segment, which then contains the whole sentence. A workaround to be used case by case.

Sylvain


Direct link Reply with quote
 

Heinrich Pesch  Identity Verified
Finland
Local time: 16:12
Member (2003)
Finnish to German
+ ...
Cells should defined to show the text in rows Apr 24, 2006

Instead of fixed breaks one should define the cell as text and to expand down as needed.
Eliminating fixed breaks is a standard procedure also in Word.


Direct link Reply with quote
 

Pavel Lyakhovsky  Identity Verified
Russian Federation
Local time: 17:12
Member (2006)
English to Russian
TOPIC STARTER
Many thanks, Jerzy! Apr 24, 2006

Your tip was exactly what I needed. Thanks a lot for your help!

Best regards,
Pavel


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

BR tag in TagEditor when translating Excel files

Advanced search


Translation news related to SDL Trados





Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs