Mobile menu

Not able to edit segment despite having Tag Protection switched off
Thread poster: Stefanie Sendelbach

Stefanie Sendelbach  Identity Verified
Germany
Local time: 11:16
Member (2003)
English to German
+ ...
Apr 27, 2006

Hi all,

I am using Trados TagEditor 6.5.5.438. My XML document contains figures with decimal points (in English) that need to be changed to decimal commas (in the German version). All figures in the document are protected, they don't open as translatables in TagEditor. So I turned the Tag Protection off to be able to access these segments. To no avail. I browsed the forums and the Trados documentation, but couldn't find how to get this segment to open in TagEditor.

By now I have everything unticked in Tools > Options > Protection, but it still does not work.

Any idea what I could try?

Thanks in advance,
Stefanie

[Bearbeitet um 2006-04-27 12:28]


Direct link Reply with quote
 
Jalapeno
Local time: 11:16
English to German
Substitution Localisation Apr 27, 2006

Shouldn't these be changed automatically? Translation Memory Options --> Substitution Localisation

Direct link Reply with quote
 

Sylvain Leray  Identity Verified
Local time: 11:16
Member (2003)
German to French
Uncheck "Protect document" Apr 27, 2006

Hallo Stefanie,

Options, Protection : uncheck "protect document".

HTH
Sylvain


Direct link Reply with quote
 

Stefanie Sendelbach  Identity Verified
Germany
Local time: 11:16
Member (2003)
English to German
+ ...
TOPIC STARTER
Everything is unchecked Apr 27, 2006

Hi Sylvain,

I have unchecked everything in Protection, including "Protect Document". That's what leaves me so clueless.

Stefanie


Direct link Reply with quote
 

mónica alfonso  Identity Verified
Local time: 06:16
English to Spanish
+ ...
Is it the bilingual view? Apr 27, 2006

Unless you are in the bilingual view, you cannot edit anything.

Direct link Reply with quote
 

Stefanie Sendelbach  Identity Verified
Germany
Local time: 11:16
Member (2003)
English to German
+ ...
TOPIC STARTER
Yes, bilingual Apr 27, 2006

Hi Mónica,

Yes, I am using the bilingual file.

Stefanie


Direct link Reply with quote
 

mónica alfonso  Identity Verified
Local time: 06:16
English to Spanish
+ ...
Bilingual View Apr 27, 2006

Despite you may be in the bilingual file, if you are not in the bilingual view you cannot edit anything.

Direct link Reply with quote
 

Hynek Palatin  Identity Verified
Czech Republic
Local time: 11:16
English to Czech
+ ...
Notepad Apr 27, 2006

You can simply edit the document (TTX or XML) in Notepad, just be careful about the tags.

Direct link Reply with quote
 

Marie-Céline GEORG  Identity Verified
France
Local time: 11:16
English to French
+ ...
figures on their own cannot be modified in TE Apr 27, 2006

Hi,
If the figures are on their own, Trados doesn't consider them as translatable so you can't open them in TagEditor. AFAIK there's no way to modify a text in TagEditor without opening a segment, so you have to use another software to change the format of numbers.
Do you have access to the final file format? The best way would be to modify the numbers in the target file directly.
HTH

Marie-Céline


Direct link Reply with quote
 

Hynek Palatin  Identity Verified
Czech Republic
Local time: 11:16
English to Czech
+ ...
Direct changes Apr 27, 2006

Marie-Céline GEORG wrote:

AFAIK there's no way to modify a text in TagEditor without opening a segment...


There is - by turning the document protection off. That's what the discussion is about.


Direct link Reply with quote
 

Harry Bornemann  Identity Verified
Mexico
English to German
+ ...
Should be done automatically Apr 27, 2006

Stefanie Sendelbach wrote:
I am using Trados TagEditor 6.5.5.438. My XML document contains figures with decimal points (in English) that need to be changed to decimal commas (in the German version).

The decimal conversion should be done automatically, at least after exporting the target. (I suppose you have not deactivated this option.)
Did you check it in the exported file?


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 11:16
Member (2004)
English to Slovenian
+ ...
should be done automatically - take two Apr 28, 2006

and if does not?...

I have started to use tortoise tagger for this kind of global replace jobs and it starts to make more sense to me than all these rabinic / talmudic options upon options.

http://www.accurussian.net/tagger.htm

smo

PS: forgot to add "5.2/5.2/5.3.../7.1/7.5" to "rabinic/talmudic" above


[Edited at 2006-04-28 22:33]


Direct link Reply with quote
 

Stefanie Sendelbach  Identity Verified
Germany
Local time: 11:16
Member (2003)
English to German
+ ...
TOPIC STARTER
Not automatically Apr 29, 2006

Dear all,

Thank you for your replies.

Jalapeno wrote: Shouldn't these be changed automatically? Translation Memory Options --> Substitution Localisation


In Substitution Localisation I have Numbers activated and in the upper field (Digit grouping symbol) there is a ".", and in the lower field (Decimal symbol) there is a ",". Isn't this the correct setting?

mónica alfonso wrote: Despite you may be in the bilingual file, if you are not in the bilingual view you cannot edit anything.


Sorry, I got that wrong in my first reply to you. But yes, I am in bilingual view.

Hynek Palatin wrote: You can simply edit the document (TTX or XML) in Notepad, just be careful about the tags.


Thanks for the tip, Hynek. I might try this, though I am a bit scared something will go wrong with the tags. The file is almost 40k words big, which means there are lots of tags that can get screwed up.

Harry Bornemann wrote: The decimal conversion should be done automatically, at least after exporting the target. (I suppose you have not deactivated this option.)
Did you check it in the exported file?


Well, I only sent the exported XML file to my client. They noticed that the figure didn't display with a decimal comma, but with a decimal point. When I open the XML file in notepad, this is what my sentence looks like:

Oft ist es schwierig, einen Schein über {price cur="EUR"} 500.00{/price} gewechselt zu bekommen.

Vito Smolej wrote: I have started to use tortoise tagger for this kind of global replace jobs and it starts to make more sense to me than all these rabinic / talmudic options upon options.

http://www.accurussian.net/tagger.htm


Thanks, Vito. I might give this a try.


Again, thank you for all your comments and suggestions.

Stefanie

[Bearbeitet um 2006-04-29 13:26]


Direct link Reply with quote
 

Stefanie Sendelbach  Identity Verified
Germany
Local time: 11:16
Member (2003)
English to German
+ ...
TOPIC STARTER
Simple solution Apr 29, 2006

Hynek Palatin wrote:

You can simply edit the document (TTX or XML) in Notepad, just be careful about the tags.


Hi Hynek,

I just tried out your suggestion and it worked well. Thank you! Strange though that there is no easier way. I find it quite user-unfriendly that you have to keep in mind to once again open the final file in Notepad and do this change manually. Whenever you do a single little amendmend in the TTX file, you also have to open the file in Notepad again and change the figure...

But well, it worked and the figure displays correctly now. Luckily there was only one occurence of this problem in the whole file. I'd be really nervous that something goes wrong if I had to do this several times within one big file.

Have a good weekend, everybody. And thanks again.

Stefanie


Direct link Reply with quote
 

Stefanie Sendelbach  Identity Verified
Germany
Local time: 11:16
Member (2003)
English to German
+ ...
TOPIC STARTER
Update Apr 30, 2006

Dear all,

I used Hynek's way of changing all the decimal points to decimal commas in my file. The problem with this method was, that all the German special characters (ä, ü, ö, ß) somehow got garbled, and the file was not usable afterwards. So if anyone tries this method in future, please be careful about the language settings that you use in Notepad.

I think I'll give it another try with Macromedia Dreamweaver (my client's suggestion).

Stefanie


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Not able to edit segment despite having Tag Protection switched off

Advanced search


Translation news related to SDL Trados





Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs