Boost your career as a professional translator!

Boost your career as a professional translator! SDL hosts a virtual conference featuring a selection of free resources to help grow your freelance business, as well as an update on the new features of the world’s most trusted translation software - SDL Trados Studio 2017

Click for Full Participation

Workbench shuts down w/ MSWord
Thread poster: Paul Kozelka

Paul Kozelka  Identity Verified
Local time: 16:57
Member (2004)
French to English
+ ...
Aug 12, 2006

Using XP Pro and Trados 7.1...I have reviewed/effected all fixes from previous Forum entries and removed NetFramework SDK 1.1 (installed in a vain attempt with SDL Help to get MTConvert to open) and Workbench now closes less frequently, but still shuts down every 10 min or so. Docs are normal formatting with occasional tables (which TW handles o.k.). When I restart TWB, it always opens to the TermBase I was using on a previous job (different lg pair) and I suspect it is maybe not saving transl units from the current job. I am trying to avoid having to remove/reinstall Trados 7.1. Any suggestions welcomed.

[Edited at 2006-08-12 22:38]
Note added later: TWB seems to be fine when working with another TM and with only straight text. Have I created some incompatibility in setting up the "troublesome" TM, or might the problem be due to some formatting in the "troublesome" docs that I am not aware of (they have tables in them but TWB translates the tables with no problem!).

[Edited at 2006-08-12 23:05]


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 16:57
English to German
+ ...
Moving the topic... Aug 13, 2006

...to SDL Trados Support - please use this forum to post topics related to SDL and/or Trados.

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 16:57
Member (2003)
Polish to German
+ ...
Check if you have the following software installed Aug 13, 2006

Java 2 Runtime Environment SE 1.4.2_03
Microsoft Net Framework 1.1
Both are necessary for Trados to run.
You might also have JRE 1.4.2._08 and Net Framework 2 and some patches for NET 1.1, but these are AFAIK not crucial.

If you do have them and WB keeps on crashing:
- If it tends to do so only with one TM, exxport this one to text, create a new one with the same settings, import the old TM and reorganise it.
- Otherwise deinstall Trados and Multiterm. Before deinstalling Multiterm save your termbases! AFAIR the command is "Detach/Export termbase or similar. This is very important, as otherwise you will have some problems with restoring your termbases.
- After deinstalling open the Registry (put regedit in the "run" box from Start menu). Look for Trados entries under HotKeyLocalMachine/Software and HotKeyCurrentUser/Software. Rename them to "_Trados".
- Reinstall Trados. Reinstall Multiterm (keep ths order: first Trados, than Multiterm; or, with bigger reinstallations: first Office, than Trados, than Multiterm).

But just before you start: do you get any error message, when WB closes? Possibly a "R6025 pure virtuall function call"? Which build of Workbench and Multiterm?
Would be interesting to know, as I have some experiences with the "R6025" error

Regards
Jerzy


Direct link Reply with quote
 

Paul Kozelka  Identity Verified
Local time: 16:57
Member (2004)
French to English
+ ...
TOPIC STARTER
Will give it a go Aug 13, 2006

Jerzy, Bardzo djenkuje for the comprehensive suggestions! I think No. 3 (checking regedit and changing to _Trados) might be the key since I recently "cleaned up" my Registry. The error msg I used to get when this happened (infrequently and usually with tough tables) was s.t. like "Run Time error..." but it now flashes so quickly when TWB closes down that I can't read it. I will follow your suggestions and let you know. I appreciate your taking the time! -Paul

Direct link Reply with quote
 

Paul Kozelka  Identity Verified
Local time: 16:57
Member (2004)
French to English
+ ...
TOPIC STARTER
Right on target? R6025 it is! Aug 14, 2006

Jerzy,
I have created a new TM and imported the TU's from the old one and reorganized them. 15 min into a new document of the job, TWB has shut down and produced R6025, which I seem to recall seeing quite a few times in the past when the same problem occurred. Before I go to the time and trouble of removing and reinstalling TWB and MT (+ regedit, etc.), I would welcome your thoughts and experience with this Error Msg. Many thanks, Paul

P.S. After translating some 238 words, I find that the new TM still has the same number of TU's as the old one, meaning it has saved nothing of the new work!

[Edited at 2006-08-14 00:48]
It also seems to have switched back (in Term Recognition) to a MT termbase other than the one I asked it to use. This is getting complicated...

[Edited at 2006-08-14 00:51]

MT = 7.1.0.361(build)
TWB= 7.1.0.719(build)

[Edited at 2006-08-14 02:37]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 16:57
Member (2003)
Polish to German
+ ...
R6025 pure virtual function call Aug 14, 2006

In my case this error seems to be caused by Multiterm build 361.
I use Workbench 7.5.0.756 and had recently some trouble of other kind.
After contacting Trados support I was advised to remove all and install WB 7.5.0.756 in conjunction with Multiterm 7.0.1.361, what I did. I have used this combination previously and encountered this R6025 almost with any TU, so first I did not want to install this combination, as Trados did not find any errors in my opened case on R6025. I had this case earlier this year and it was closed by me without having got a satisfactory solution from the support. I simply switched back to build 320 of Multiterm.
Now (a week ago), after having completly removed Office, Trados and Multiterm from my machine I gave it another try. So I installed WB 756 in conjunction with MT 361. And I got errors - although of a bit different kind as previously. Now WB closed simply without any error message. But it seemed that even the last TU I worked on it was saved in my TM. But it was not very convenient to work with, becase every now and than I had to restart Workbench. And I also got some R6025 errors. So I once again removed Multiterm build 361 and replaced it by build 320. Now I have no trouble with it.

Therefore I would suggest you to make a surgery, remove (including regedit) all Trados applications and reinstall them then (don´t forget to restart the machine after deinstalling). Use Multiterm build 320 instead of 361.
Check, if you have the JRE 1.4.2_03 (possibly also 1.4.2_08) and NET Framework 1.1 - those are necessary for Trados.
JRE 5 update 6 and update 7 does not matter - it does not work for Trados.

Regards
Jerzy


Direct link Reply with quote
 

Paul Kozelka  Identity Verified
Local time: 16:57
Member (2004)
French to English
+ ...
TOPIC STARTER
Careful note taken...and a bit of good news Aug 14, 2006

Jerzy,
I uninstalled and re-installed WB and MT following your instructions, though I couldn't quite figure out where to insert the _Trados extension on the Regedit files since most of them (and there are alot!) were folders. WB shut down only once when I resumed work, and I have now successfully done 200 TU's without a problem. I am crossing my fingers but will also make careful note of your ingenious idea to use different versions of WB and MT, as well as cleaning out Regedit completely, should the need arise. I do have the basic NETFrame and JRE files required but still can't get MTC to run, an issue I continue to plague SDL Help with (it runs on my laptop, which has the same OS and files, but not on the PC!). Should the Devil reappear at my doorstep, where would I go about finding Build 320 of MT?
Thanks again for all your help.
Paul


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 16:57
Member (2003)
Polish to German
+ ...
Sorry for not beeing clear enough Aug 14, 2006

You need to rename folders in Registry, ie the whole folder Trados in HotKeyLocalMachine to _Trados.
This ensures your setting will not get completly lost when something goes wrong.

Please contact me via my profile and I´ll send you the MT build 320 files. They are no more available to download from Trados.

What kind of error do you get when attempting to use MT Convert? I have never had the slightest problem with it, regardless my configuration.

BTW, do you have the proper chipset driver installed on your PC? And other drivers too?

Regards
Jerzy


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Workbench shuts down w/ MSWord

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums