Editing translations with existing TM and glossary
Thread poster: Michaela Müller

Michaela Müller
Germany
Local time: 19:01
English to German
+ ...
Sep 22, 2006

Hi,

I have been searching the forums and also Trados manuals, but simply cannot find the info I need for Trados 6.5.
I have received a TM, a reference glossary (.txt), an English source file and the German translation (cleaned). I have only ever proofread/edited Trados translations (bilingual) in Word, and also cleaned files.
But I'm just confused about all the different terms used in Trados.

So - how do start now? I just don't know where to click to make the first steps ...
I know how to proofread after that, I think.

Thanks!
Michaela


[Bearbeitet am 2006-09-22 14:26]


Direct link Reply with quote
 

Michaela Müller
Germany
Local time: 19:01
English to German
+ ...
TOPIC STARTER
TM is version 7! Sep 22, 2006

Hi,
I have just tried just opening the TM and then starting in Word, but the TM seems to be in version 7 and so my Workbench doesn't accept it.

Does anybody know what to do in such cases (except buying an update, which I won't do)?

Thank you,
Michaela


Direct link Reply with quote
 

Jerónimo Fernández  Identity Verified
English to Spanish
+ ...
To open the TM... Sep 22, 2006

Hi Michaela:

To open the TM, you can ask your customer to send it to you exported as a .TXT file or as a .TMX file. You should be able to import the TXT or TMX file to a new TM and work from there.

I'm not sure if I understand your question, but If you rather proofread the bilingual file in Word, you can create a bilingual file if you run Trados through the English file. (Assuming that the TM contains the translation that you are going to proofread).

To do this, you can:
a) in Trados, go to Tools, then Translate and select the English file; or
b) open Trados, open the English file. In Word, in the Trados bar click the "Translate to Fuzzy" (shortcut: Alt + *).

Both approaches will create a bilingual file.

I hope this helps.
Regards,
Jerónimo


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 19:01
Member (2004)
English to Slovenian
+ ...
send me the TM and I'll send you Sep 22, 2006

... back a 6.5 compatible version

smo


[Edited at 2006-09-22 15:19]


Direct link Reply with quote
 

Michaela Müller
Germany
Local time: 19:01
English to German
+ ...
TOPIC STARTER
.TXT file Sep 22, 2006

Thanks for the info!

Okay, the translators do have problems with delivering an unclean file. Now I have received a .TXT file.

"You should be able to import the TXT or TMX file to a new TM and work from there"

How do I import this TXT into a new TM? File> new?

And once I have the TM and if I want to proofread directly in Trados (because I also have to deliver an updated TM after that), how do I start then?

Michaela


Direct link Reply with quote
 

Michaela Müller
Germany
Local time: 19:01
English to German
+ ...
TOPIC STARTER
Thank you so much for the offer! Sep 22, 2006

Vito Smolej wrote:

... back a 6.5 compatible version

smo


[Edited at 2006-09-22 15:19]


Hello Vito,

Thanks for your kind offer. since I have just received the .TXT file, I'll be trying to use this instead of bothering you with my silly problems. But if this doesn't work, then I would like to get back to you, if this is okay.
It's just that I want to know how to do this, and I don't want to ask other people each time I have problems with this.

Bye for now,
Michaela


Direct link Reply with quote
 

Jerónimo Fernández  Identity Verified
English to Spanish
+ ...
A bit long explanation Sep 22, 2006

Michaela Müller wrote:

Thanks for the info!

Okay, the translators do have problems with delivering an unclean file. Now I have received a .TXT file.

"You should be able to import the TXT or TMX file to a new TM and work from there"

How do I import this TXT into a new TM? File> new?

Michaela


Hi again, Michaela.

To import the TXT into a new TM:

0) Open Trados
1) Go to File > New
2) Select languages (source: English, target: German)
-Make sure that "Allow multiple translations for identical source segments" is not selected- (I'll explain at the end)
3) Click Create
4) Give the TM a name and save it wherever you want (now you have a new, empty TM)
5) Go to File > Import
6) Click OK
7) Look for the .TXT file and click Open (depending on how big the TXT is, this may take a bit)
8) At some point, in Trados you'll get a message saying "Import finished successfully". That's it!



And once I have the TM and if I want to proofread directly in Trados (because I also have to deliver an updated TM after that), how do I start then?



You can use two approaches here:

1) Proofread directly in Trados (not in the Word file)
2) Proofread the bilingual file in Word, and then update the TM

(I wholeheartedly recommend approach number 2)

1) Proofread directly in Trados (not in the Word file):
You can do this, but it's not useful at all: instead of your whole text, you would find unconnected sentences.

You can:
1.1) Open Trados
1.2) File > Maintenance
1.3) Click "Begin Search" (The segments in the TM will appear in batches -5 is the default amount-). When you find a segment that you want to edit:
1.4) Right click any of the flags
1.5) Select Edit Translation Unit
1.6) Edit the sentence
1.7) Click Save
When you have proofed all the segments in the Maintenance screen, click "Next"

As I said, I do not recommend this approach: it is a pain in the neck and it's veeeeery time-consuming.

Now, you said in your first post


I have only ever proofread/edited Trados translations (bilingual) in Word, and also cleaned files.


... and that's approach number 2:

2) Proofread the bilingual file in Word, and then update the TM

First of all, you'll have to create the bilingual Word file. As I said in my previous post, for this, you can either:

a) in Trados, go to Tools > Translate and select the English file; or
b) open Trados, open the English file. In Word, in the Trados bar click the "Translate to Fuzzy" (shortcut: Alt + *).

Once you have the bilingual file, you can:
1) proofread without opening the segments in Trados (you'll update the TM later), or
2) proofread opening the segments in Trados

I'd go for option 1) here:
You proofread the bilingual file as you've done in the past, taking care not to damage any Trados tag.

When you finish your proofreding and you are happy with your version, you want to update the TM so it gets your changes to the segments:
1) In Trados, click Tools > Clean Up
2) Click Add and select the bilingual, proofread file.
3) IMPORTANT: Do not click Clean Up yet
4) Under "Changed translations" you'll see four options. One of them is "Update TM". Select that one.
5) Now, click Clean Up
6) When Trados finishes cleaning up, click Close.

Now all your editing should appear in the TM.

To check if the TM contains your edited version, again two options:
1) In Trados, go to File > Maintenance > Begin search and you'll see the segments in the TM; or

2) In Word, select the English version of one sentence that
you have edited, then
- on the Trados bar, click Concordance (keyboard shortcut: Alt + Up arrow). The Trados window should show the sentence with your corrected German version.

Remember that I said that when you create the TM the "Allow multiple translations for identical source segments" should not be selected?

The reason is, if you select it, after cleaning up the bilingual file, the TM would contain both your version and the version that you wanted to correct.

OK, a bit too log, but I hope everything makes sense and it helps.

Regards,
Jerónimo

[Edited at 2006-09-22 18:58]


Direct link Reply with quote
 

Michaela Müller
Germany
Local time: 19:01
English to German
+ ...
TOPIC STARTER
It works Sep 22, 2006

Hi Jerónimo

You cannot believe how glad I am it works.
Actually I had already done the exact same steps you are describing, up to the successful import.
But I just didn't know what to do from that point on ...
I just didn't check if the English source file (because it keeps the same name, right?) had changed. And I would never have known this without you:

Jerónimo Fernández wrote:

You can:
1.1) Open Trados
1.2) File > Maintenance
...


But since I want to save some time (now that it has taken me so long), I just do as you say and follow the instructions for Word.
This is much more convenient, I think, and msitakes are spotted easier. And as an editor/proofreader, I care for the tags 100%, that's for sure.


*The only problem now is that all Umlauts are scrambled somehow, although I considered giving the TM the same language codes as are in the .txt file.*


I'll let you know if updating the TM and cleaning isn't possible.
I think you've compiled a very nice guide for all beginners or not so frequent users of Trados. Maybe you should compile it as an article so everyone may use this?

Thank you again for your professional help, and let me know in case I can help you some time.

Best regards,
Michaela


Direct link Reply with quote
 

Jerónimo Fernández  Identity Verified
English to Spanish
+ ...
Danke! Sep 22, 2006

Michaela Müller wrote:

Hi Jerónimo

You cannot believe how glad I am it works.


I'm glad it made sense. Thanks.


*The only problem now is that all Umlauts are scrambled somehow, although I considered giving the TM the same language codes as are in the .txt file.*


I reckon something similar was discussed here about accents turning into Chinese characters or something, but I just can't remember the solution now.

Anyway, for Trados-related issues, you can ask in the Trados Yahoo Group at http://tech.groups.yahoo.com/group/TW_Users/. It's free and there's a lot of people there who know a lot about Trados and who are happy to help, plus most of the time they answer pretty quickly.

Good luck and post here if you have any problem.

Regards,
Jerónimo



[Edited at 2006-09-22 19:36]


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 19:01
Member (2004)
English to Slovenian
+ ...
Scrambled Umlauts Sep 22, 2006

whatever the reason, they should be scrambled consistently in TM( sg). Use Maintainance to change globally the wrong chars to the correct form. TM is in Unicode, so no problem from this side.

If the strange umlauts later still persist, then the problem may be the bilingual file being checked. But we can talk it over when and if it turns up.

regards

Vito

[Edited at 2006-09-22 21:45]


Direct link Reply with quote
 

Michaela Müller
Germany
Local time: 19:01
English to German
+ ...
TOPIC STARTER
Maintenance Sep 22, 2006

Hello Vito,

Thanks for the hint! I have found the maintenance function, but somehow the search result window also shows me segments that do not contain the characters I search for. Isn't this strange?

But your idea is fine - I think I'll just search the bilingual file for the charachters and change them there. I have just did a Search and Replace on a character, but there doesn't seem to be difference between capitalized and normal letters.
So I'll be doing it manually, I think.

Thank you for your kind advice!

Have a good night,
Michaela


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 19:01
Member (2004)
English to Slovenian
+ ...
Hint: It could be Word Sep 23, 2006

I am talking on the basis of my own sad experience: for some types of input files (probably pre-Unicode) Word makes up its own mind, what kind of character set to use - western, mideuropean? -.

Example: Slovenian characters are all in the western iso set -save for the character č (German Tsch). The same 8bit number used in Mid European set stands for é in the western character set. Nice - if you do the last polish to the file before delivering and then those ugly e accentees start to pop up...

The way out of it is probably to convert the text file - if such a file is at the start of the pipeline - as soon as possible to UTF8 presentation, which makes sure this kind of mixups will not occur anymore.

Then the TM entries are Unicode as well and the future is bright - until the next cloud turns up on the horizon (g).

And ... it could just as well have to do with TRADOS (pre- and post DotNet) version. With the latest (TRADOS and office 2003) I have not had any of this kind of problems anymore.

Regards

Vito


Direct link Reply with quote
 

Michaela Müller
Germany
Local time: 19:01
English to German
+ ...
TOPIC STARTER
Too late Sep 24, 2006

Hello Vito,

Thanks for sharing your experience and giving hints.
In the meantime, I had to start working on the file and I have been replacing all strange characters by correct Umlauts manually. I think it is too late now to change the .txt file without causing the whole text to be a mess. And I had made sure the coding of the .txt file before I started: it is in UTF-8.

But you are right, the next cloud really came up! The uncleaned file contains some untranslated passages, and I don't know why this happened. There must have gone sth. wrong during the translation process (note that the translators were not able to deliver uncleaned files). But it is me who is at the end of the process and who has to do the cleaning up. I can just hope for the client's understanding.

Thank you and have a nice Sunday,
Michaela


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Editing translations with existing TM and glossary

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs