Mobile menu

Editing MultiTerm termbase entries
Thread poster: Dionysios Divaris
Dionysios Divaris
Local time: 16:32
Greek to English
+ ...
Sep 27, 2006

Hello

This query concerns MultiTerm 7.1.0.361 (MultiTerm 7 Desktop)

After installation, I find that I can create local termbases, add and delete entries, but editing entries is not allowed.

System response "level is read only"


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 15:32
English to Dutch
+ ...
edit input model Sep 27, 2006

"level is read only"


you will find a checkbox in the input model where you can uncheck the Read only setting

(termbase catalogue/input model/edit)


Direct link Reply with quote
 

Jonathan von Zelowitz  Identity Verified
France
Local time: 15:32
French to English
but for the default input model... Jan 9, 2007

Hello! A few months later, I am running into the same thing.
Saitch's reply appears to be valid for a user-defined input model.
However, I would like to take advantage of the predefined "Default input model" which is owned by the system and cannot be edited (Edit button is gray).
According to the Multiterm help files, this is intended behavior: the system default input model cannot be saved.
I have looked for a way to clone this definition and take ownership of it, in order to modify it. Logically there should be a corresponding .xdm file somewhere under the Multiterm folder, but I can't find it.
In my opinion, even if the Edit button is gray for the default input model, the Save As button should not be gray, thus allowing you to clone and adapt this well thought out model to your own needs.
Is there another workaround other than manually re-entering the structure of the default input model?
Thanks!
Jon

(p.s. Exporting an xdx and trying to import it as xdm and edit it crashes multiterm, so that's not the solution!)


Direct link Reply with quote
 

Jonathan von Zelowitz  Identity Verified
France
Local time: 15:32
French to English
the solution Jan 14, 2007

After many hours of attacking this problem, I found that I was wrong from the start, there is no problem.

1. Most importantly, I *can* edit terms in my termbase.

2. I was misled by the Multiterm documentation.
a. When I tried to edit a field, “nothing happened”.
b. Then I tried to find an explanation.
c. The Multiterm help page “Editing an Existing Entry” states: “Some fields may be marked read-only in the termbase definition or in the active input model. You cannot edit or add content to these fields.”
d. I thought this was the explanation and I wasted a lot of time trying to go around it by changing the input model.

3. Finally, I found the key, answer number 1811 in the SDL support database, which states (in relation to a slightly different symptom):
“… all fields (levels) in the termbase entry are write-protected at the moment and none of them has been open for editing. To eliminate this error, open any editable field by clicking on the dot in front of it. Now pressing Enter will not produce any errors.”
In brief, just click the little dot! Everything’s fine.

4. Incredibly, this basic information is not contained in the usually-excellent Multiterm documentation: neither in the help files (search for “dot”), and in particular on the “Editing an Existing Entry” page, nor in the Multiterm User Guide in the section “Editing Existing Content”. Frankly, for a newcomer to Multiterm, it was not obvious to click the dot.

Good luck to other newcomers, I hope this helps.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Editing MultiTerm termbase entries

Advanced search


Translation news related to SDL Trados





SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs