Mobile menu

Multiterm ix: "no target term available"
Thread poster: Mpoma
Mpoma  Identity Verified
United Kingdom
Local time: 01:15
French to English
Oct 10, 2006

Hi,

I'm using Trados Workbench 6.5.1.406
and Multiterm 6.2.0.267 (Multiterm iX)
and Word 2000 (9.0.2720)
and Multiterm is driving me CRAZY!!!
I struggled through the MultiT documentation to find out how to convert an Excel file to an XML and then import this... all well and good...
But when I use MultiT in Word the source word appears but not the target in the termbase I've just created... consequently I can't pop the term in the text using Alt-Down... soooo annoying.
NB crucially, the sample termbase supplied in the MultiT package works OK... the target appears fine and can be popped in... what am I doing wrong in the setup phase?

To my astonishment (not) I couldn't find any answer to this on any Trados or SDL site. But more surprised to find no answers and few problems here on Proz.

Please help...!

Mpoma


Direct link Reply with quote
 

Matt Baird
Germany
Local time: 02:15
German to English
Check the target language setting Oct 10, 2006

Hi there,

If the target language setting is not the same as the termbase setting, then I believe the target term will not show up (i.e. US english vs. UK English). I know that if you are using a TM with two different target languages, the target text will not be displayed if any matches come up in the TM that were originally stored under the other target language. I'll bet this is the same in Multiterm.

Hope that helps!

Matt


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 02:15
English to Dutch
+ ...
default Oct 11, 2006


But when I use MultiT in Word the source word appears but not the target in the termbase I've just created... consequently I can't pop the term in the text using Alt-Down... soooo annoying.


Try setting your termbase as the default termbase (you're using more than one) and the beautiful altDown feature will sing again.

default termbase

in workbench/options/term recognition options/browse

i.e. not in multiterm

[Edited at 2006-10-11 18:56]


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 02:15
Member (2004)
English to Slovenian
+ ...
check the file first in standalone MultiTerm Oct 11, 2006

can you get the target from source? etc

Also - I go Matthew on this - do check the language descriptors. EN_US vs EN vs EN_UK (not to talk about English) in certain shady, all-important places, is all it takes - to have it completely right or completely wrong when creating with Convert.

I still bear burn marks from my learning phase on this subject. The best help was to go again and again through the Convert example - you would wonder how much is overseen the first couple (sorry, dozen) of times.

Regards

smo

[Edited at 2006-10-11 15:18]


Direct link Reply with quote
 
Mpoma  Identity Verified
United Kingdom
Local time: 01:15
French to English
TOPIC STARTER
Thanks to respondees - solution found! Oct 11, 2006

Hi,

Thanks to you guys... yes, burn marks, I think it's the mark of a Trados "Vet"... But I think arcane knowledge of this kind keeps out the hoards of the uninitiated...

In the end I found another thread here on Proz which explained what I was doing wrong... I don't know where the example of setting up a Termbase is... but the crucial thing I learnt is that converting from an XLS glossary you actually get *TWO* files, an XML file and an XDT file, which latter defines the structure required in order to import the XML file... so when you create your termbase you have to say (Wizard step 1) that you're basing its structure on the XDT file... prior to this I had assumed I was simply doing a generic bilingual glossary

God I was so naive back in those days!

After this everything went hunky dory. Target appears, Alt-Left, Alt-Right and Alt-down work fine.

Mpoma


Direct link Reply with quote
 

Luca Tutino  Identity Verified
Italy
Local time: 02:15
Member (2002)
English to Italian
+ ...
What's the use...? Sep 18, 2007

Mpoma wrote:
But I think arcane knowledge of this kind keeps out the hoards of the uninitiated...


Yes. This is probablywas the real main purpose of MT7 code. This, and selling courses and certifications I guess


Direct link Reply with quote
 
Mirzo
Tajikistan
Local time: 08:15
Tajik to English
+ ...
Multiterm or MultiTrouble? Nov 6, 2007

Hi everyone!
Facing the same problems, non of recommendations are suitable. I should try to solve it by my own.
It seems that in SDL Trados they write help files for themselves. If you follow thier helps and manuals, you will definately go to deadlock.
Trados makes money by teaching people how to use thier software, so it should distribute software freely.


Direct link Reply with quote
 

Luca Tutino  Identity Verified
Italy
Local time: 02:15
Member (2002)
English to Italian
+ ...
This is a scandal! Jul 30, 2008

About 4 years and a couple of "upgrades" later, since when I installed MT IX, I keep getting Multiterm glossary as XML files that are not usable because target term does not show up in WB windows.

I know that there is a workaround somewhere, one should fiddle with the xml in a text editor or change some option in the import process. However it is so complicated that I cannot remember it from one occasional project to the next, and several times per year I am forced to spend hours looking in the forums and elsewhere for the solution.

I noticed this immediately and wanted to go back to normal MTW files, but apparently MT IX cannot cohexist on the same system with the old Multiterm 6, and disinstallation without loosing databases seems to be more cumbersome than disinstalling Norton AV products.

Now I have to run, if I want to find the solution before the client fires me...

-------------

SOLUTION. (I'll put it in here hoping to find it next time.)
I have edited the xml file with S&R: Search term: "IT" (my target language), Replace with: "IT-IT", Multiterm is reimporting now, and... now in WB I have two matches for each term, neither of them is showing the Italian!!

[Edited at 2008-07-30 12:59]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 02:15
English
Try this... Jul 30, 2008

Hello Luca,

I suspect you are not seeing the translation terms in Workbench because there is an issue with the TermBase database. There are a number of things you can do to make sure this works:

1. Open the TermBase in MultiTerm and then Reorganise the TermBase;

2. In Translators Workbench go to: Options -> Term Recognition Options and make sure the TermBase language selection matches the currently open TM language combination;

3. If you still have problems it may be an idea to recreate the TermBase, to do this you will need to export the TermBase from MultiTerm to .XML format and also save the TermBase definition (*.xdt). You can then create a new TermBase based on the .xdt file and then import the .xml file into the newly created TermBase. Now link to this TermBase in Workbench to see if this helps.

I hope this helps.

Many Thanks,

Gareth Powell
SDL Support Team


Direct link Reply with quote
 

Daniel Meier  Identity Verified
Local time: 02:15
English to German
+ ...
Same problem here with Error Message for Reorganisation Sep 15, 2008

SDL Support wrote:

Hello Luca,

I suspect you are not seeing the translation terms in Workbench because there is an issue with the TermBase database. There are a number of things you can do to make sure this works:

1. Open the TermBase in MultiTerm and then Reorganise the TermBase;

2. In Translators Workbench go to: Options -> Term Recognition Options and make sure the TermBase language selection matches the currently open TM language combination;

3. If you still have problems it may be an idea to recreate the TermBase, to do this you will need to export the TermBase from MultiTerm to .XML format and also save the TermBase definition (*.xdt). You can then create a new TermBase based on the .xdt file and then import the .xml file into the newly created TermBase. Now link to this TermBase in Workbench to see if this helps.

I hope this helps.

Many Thanks,

Gareth Powell
SDL Support Team


Hello Gareth,
I have the same problem (TermRecognition does not work), in fact only with one Excel file provided by a client. I am doing conversions of Excel glossaries regularly, and it´s the first time this problem occured.
Now when I try to reorganise the TermBase, I get this error message:

"Termbase reorganize failed.
Id: 1, Cannot find output table I_English.
Id: 2, Cannot find ...
Id: 15, Cannot find output table I_English.
(More entries not displayed ... )"

The actual error message is in Czech, but it seems the TermBase cannot be reorganized at all. Why?
I tried copying only part of the Excel file and then rerun the whole Convert/Create Termbase/Import entries several times - the result is always the same.
Does anybody have a hint?
Many thanks
Daniel


P.S.: I have also tried and checked the other solutions mentioned above (Sublanguages, Standalone MultiTerm etc.)






[Edited at 2008-09-15 20:07]


Direct link Reply with quote
 

Rod Walters  Identity Verified
Japan
Local time: 09:15
Japanese to English
Horrible realization! - an errant space Oct 28, 2008

I've wasted days and days trying to get one of my most important termbases to show the English term properly, both within MT and WB. I was just about to post a question about it here, throwing in a red herring about double-byte languages which I thought might be part of the cause.

The cause in fact was that for some reason, I had entered a space on the Excel sheet after the column heading "English", so that in fact it read "English ". Although of course, I couldn't see the space.

This invisible space caused me hours of grief.

Be warned!


Direct link Reply with quote
 

Daniel Meier  Identity Verified
Local time: 02:15
English to German
+ ...
Term Recognition fails after importing entries - Workaround Nov 11, 2008

By chance I found a possible workaround for "No target term available", i.e. for the situation when Term Recognition does not work any more after importing entries.
The procedure is quite simple: just open MultiTerm, detach the termbase and then load it again.
Of course there is no guarantee it will work always, and also I did not try if you have to deselect the Termbase also in Workbench and then reselect it under Term Recognition Options. So it´s not a solution but a possible workaround.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Multiterm ix: "no target term available"

Advanced search


Translation news related to SDL Trados





Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs