Pages in topic:   [1 2] >
Error installing Trados 7.5 .net framework needed?
Thread poster: Mihailolja

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
Dec 6, 2006

Hello

I know this is a Windows issues and not a problem with the software but while installing trados I get the following error message:

" The .Net Framework 1.0 with sp2 is needed to continue with this install.Please lanunch this install from setup.exe"

Now I have windows xp with Microsoft .NET 1.1 so I uninstalled it and then installed 1.0 ( download from Microsoft )., still no luck, I have heard there is some utility in Trados called dotnetfx which is supposed to help but I do not know how.

Any help any one?


Direct link Reply with quote
 
xxxBrandis
Local time: 18:52
English to German
+ ...
I think you need .net 2.0 Dec 6, 2006

Hi! that is also called dotnetfx , this is about 23 MB there is yet another Feb edition 2006 about 50 MB. Generally the 23 MB should suffice. Best Brandis

Direct link Reply with quote
 

David Earl  Identity Verified
United States
Local time: 10:52
Member (2007)
German to English
DotNetFX.exe Dec 7, 2006

Hi Mihailoljo,

Looking over the MS site, files named DotNetFx.exe are the installation programs for the .NET runtime (objects, components, functions, etc.). If you haven't tried searching the install CD/directory for files named "DotNetFx.exe", I'd do that first. My reasoning is that that would be the version of the .NET runtime that Trados 7.5 is expecting to work with/was tested with.

Failing that, I'd ask SDL which version of the .NET runtime they're expecting, and try to get that through the following link:

http://www.microsoft.com/downloads/details.aspx?FamilyID=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en

Theoretically, newer versions of .NET should be backwardly compatible, so version 2.0 should offer all of the features of 1.1...at least, that's Microsoft's theory.... Experience tells me there's always "adjustments" to existing components (or it wouldn't be a new version).

HTH,
David.


Direct link Reply with quote
 

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
TOPIC STARTER
Hello all.. Dec 7, 2006

I will have a go and let you know.

Thanks for the advice.

Regards

Mihailo


Direct link Reply with quote
 

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
TOPIC STARTER
No luck so far... Dec 7, 2006

Even with .NET version 2.0 installed it keeps asking for version 1.0 with sp2, now I looked to see if 1.0 is indeed in my Trados install directory and the files I have are as follows:

dotnetfxsp1 ( no sp2 mentioned here )

&

dotnetfx ( no sp2 mentioned here either )

the long and short of it all is that irregardless of what version of .NET I have installed, during the install of Trados it installs automatically .NET 1.1 and then annoyingly having installed it itself gives me the error message in my first posting!

( ps I have rebooted countless times to no effect )

Best Regards

Mihailo


Direct link Reply with quote
 

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
TOPIC STARTER
some progress... Dec 9, 2006

Hello

I have managed to install Trados successfully!!! but just on my laptop , my desktop pc keeps coming back with the same error message.

Now I've gone through my laptop and it has .NET versions 1.1 , 2 and a 1.1 hotfix installed, so I have put these on my desktop hoping this would make the crucial difference but ..... alas , no.

( laptop and desktop are running the same version of Windows, same service pack )

Leaving me with no ideas.....

anyone?

Mihailo


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 18:52
Member (2003)
Polish to German
+ ...
Instal MS XML 4.0 Dec 9, 2006

Is included in Trados distrubution or may be downloaded from MS site.
After I recently bought a new notebook, I have had some problems with Corel Draw, which told me it needs MS XML 4.0. At the same time Trados would not run also (I was installing my software at this moment). After I installed MS XML 4.0 both Corel Draw 12 and Trados started to work.

Regards
Jerzy


Direct link Reply with quote
 

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
TOPIC STARTER
Tried it but.... Dec 9, 2006

Thanks for the suggestion Jerzy but it has made no difference unfortunately....

Downloaded MS XML 4.0 as you suggested but still the same error.

Regards

Mihalo


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 18:52
Member (2003)
Polish to German
+ ...
How about Java Runtimes on your PC? Dec 10, 2006

Do you have JRE 1.4.2_08 installed?
AFAIK it is crucial to have exactly this version of Java.

You could also deinstall all .NET Framework instances from your PC and install only the latest one. This is .NET 3 - after installing it you will find NET 2 & 3 on your PC.

You wrote Trados is working on your notebook - what different software do you have on PC and notebook? Maybe another piece of software is interacting with Trados...

Regards
Jerzy


Direct link Reply with quote
 

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
TOPIC STARTER
alas no luck.... Dec 13, 2006

Hi Jerzy

Have tried all your suggestions in your last post, have almost given up, will probably go through my laptop with a fine comb to find how it differs from my desktop.

Regards

Mihailo


Direct link Reply with quote
 

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
TOPIC STARTER
just a query Dec 14, 2006

My desktop has an old, unfunctioning install of Trados 6.5, could it be this which is intefering? When I try to uninstall it I get the same error message as when I try to install Trados 7.5 ( above )!

regards

Mihailo


Direct link Reply with quote
 

David Earl  Identity Verified
United States
Local time: 10:52
Member (2007)
German to English
Second user account? Dec 19, 2006

The 6.5 uninstall bringíng up that message makes me suspiscious of the registry. (When you installed 7.5, did you tell it to install over 6.5? Or did the install program maybe try to locate an existing Trados install? _Could_ be a problem caused by a partial install and poor registry clean up after the 7.5 install failed.)

You might try setting up another user account, and installing 7.5 under that account. The registry consists of several files or "hives", and one of those hives is associated with the user account. Using a second user account would get you a "clean" user hive, based on the default user account. It should be an admin account, so that you can install.

There's a ca. 50% chance that that will work. If the problem is in the "Local Machine" hive (associated with the machine, and not the user), then this trick won't/can't work.


Direct link Reply with quote
 

Janne Ulvinen  Identity Verified
Finland
Local time: 19:52
English to Finnish
+ ...
Exact same problem here Feb 9, 2007

I have the same problem as described above. I'm trying to install SDL Trados 2006 but I end up getting the following error message no matter what the configuration:

"The .Net Framework 1.0 with sp2 is needed to continue with this install. Please launch this install from setup.exe"

Originally I had .NET Framework 3.0 installed. Then I removed everything, tried installing .NET Framework 1.0 and 1.1 from MS's site and separately from the installation package. As the error message suggests, I have tried to launch the installation from all possible locations. Nothing seems to work and every time it ends up with the same error message.

I have no possibility to ask SDL about this since I have not purchased the support package.

It seems that when the files from the SDLTrados2006_FL_756.exe package are extracted, the Products\Trados\TT folder seems to resemble the "actual" installed folder more or less (with working executables for each application etc.) - Is it possible to "install" the Trados part "manually" somehow?

The SDLX 2006 installation succeeded without a problem.

My JRE version is 1.4.1._02 but IMHO it has nothing to do with this.

Help is very highly appreciated.


Direct link Reply with quote
 

Mihailolja
United Kingdom
Local time: 17:52
Ukrainian to English
+ ...
TOPIC STARTER
still no luck... Feb 10, 2007

Hi Janne,

I've tried everything posted by the colleagues on this thread and nothing has worked, the only thing I can do now is reinstall windows and try the install afresh, or just continue to use Trados on my laptop where I have had no problems.

Would still like to know if its possible to solve this problem!

Regards

Mihailo


Direct link Reply with quote
 
Daniel García
English to Spanish
+ ...
Possible fix from TRADOS page... ? Feb 10, 2007

Mihailolja wrote:

My desktop has an old, unfunctioning install of Trados 6.5, could it be this which is intefering? When I try to uninstall it I get the same error message as when I try to install Trados 7.5 ( above )!


You could try applying this fix to your 6.5 installation:

http://www.sdl.com/trados-support-view.htm?cntID=1439

If it works, then you might be able to uninstall it and install 7.5...

If not, before a fresh install you might try to restore your PC to the point before TRADOS 6.5 was installed and then install TRADOS 7.5.

I think that I personally would go for a fresh install.

Daniel


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Error installing Trados 7.5 .net framework needed?

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs