Pages in topic:   [1 2] >
MultiTerm: blank input form (no input fields)
Thread poster: DE-EN-xl8
DE-EN-xl8
Local time: 20:59
German to English
Jan 31, 2007

MultiTerm: 7.1.0.361 (Build 361)
Java: 1.5.0 (build 1.5.0_10-b03)
Windows XP Pro SP2

Hi All!

I'm having problems entering new terms in MultiTerm. My own input model and the default input model used to work fine but now when I click on "Add Entry" I'm just presented with a blank input form, i.e. no fields or field headers whatsoever - just a white space.

If I try closing the blank form by right clicking on it and then clicking "Cancel Edit" in the context menu I get:

"A Runtime error has occurred.
Do you wish to debug?
Line: 35
Error: Object doesn't support this property or method"

If I click on "Yes" to debug, the debug application points to the following (second line):

function onLoad() {
if (getEditApplet().isActive()) {
showEntry();

I've tried using the "Repair" option in the MultiTerm setup program but the problem remains. Should I completely reinstall?

I've also tried creating a new input model but that doesn't help either.

The strange thing is I'm able to add new entries from the MultiTerm toolbar in Word.

If anyone has any ideas what could be causing this I would be most grateful for some hints, suggestions or indeed a solution!

Kind regards,
Mark


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 20:59
English to Dutch
+ ...
applet Feb 1, 2007


function onLoad() {
if (getEditApplet().isActive()) {
showEntry();

It’s the java applet I think. It needs to be able to access the net to do its job (allow adding or editing in Multiterm). Possibly you had your virus scanner updated and the update (like mine -McAfee- would) is blocking Multiterm.


Direct link Reply with quote
 
DE-EN-xl8
Local time: 20:59
German to English
TOPIC STARTER
Solved (I think/hope) Feb 1, 2007

saitch wrote:
It’s the java applet I think. It needs to be able to access the net to do its job (allow adding or editing in Multiterm). Possibly you had your virus scanner updated and the update (like mine -McAfee- would) is blocking Multiterm.


Hi Saitch,

Thanks for the tip! I've managed to solve the problem now, I hope. I deactivated all McAfee components, uninstalled Java 1.5, reinstalled it and then reactivated all McAfee components (virus scanner, firewall, etc.) except for script scanning protection. I restarted Windows and can now add and edit MultiTerm terms!

What did you change in McAfee to solve your problems?

Kind regards,
Mark


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 20:59
English to Dutch
+ ...
zero change Feb 1, 2007

Mark Staton wrote:
What did you change in McAfee to solve your problems?


Nothing; I got the alert dialog, something like 'this program is trying to acces the internet' and the options Allow only this time/ Always allow/ ...

As it was Multiterm, and I was editing sth in it, I simply allowed it (and I never had the problem.)

Glad to have been of help.


Direct link Reply with quote
 
translator-pl
Local time: 20:59
German to Polish
+ ...
Problem with SDL MultiTerm SP3 - blank input form / no input fields Jan 7, 2011

Hello!

Totday I came across the same problem. After having created a new termbase (in SDL MultiTerm SP3 8.5.166.0), I couldn't create any entry as a blank input form appeared (without input fields).

A Runtime error has occurred.
Line: 89
Sign: 2
Error: Object doesn't support this property or method.
Code: 0
URL: file://C:/Program%20Files%20(x86)/Common%20Files/SDL/MultiTerm8/MultiTermMtCommon/Editor/script/connector.js

In German:
In dem Skript auf dieser Seite ist ein Fehler aufgetreten.
Zeile: 89
Zeichen: 2
Fehler: Das Objekt unterstützt diese Eigenschaft oder Methode nicht.
Code: 0
URL: file://C:/Program%20Files%20(x86)/Common%20Files/SDL/MultiTerm8/MultiTermMtCommon/Editor/script/connector.js
Möchten Sie, dass Scripts auf dieser Seite weiterhin ausgeführt werden?

I suppose the problem concerns Java, however, the installtion of the latest version of Java didn't solve my problem with MultiTerm.

Strangely enough, I can create new entries from MS Word, however I cannot edit them in MultiTerm.

Does anybody have an idea? Many thanks in advance for your hints!

P.S. I have Windows 7 installed.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:59
Member (2003)
Polish to German
+ ...
Use "Repair Multiterm 2009" from Side-by-Side tools Jan 7, 2011

If you don't have Side-By-Side tools listed in MultiTerm program group (Start - Programs and so on), double click this file C:\Program Files (x86)\SDL\SDL MultiTerm\MultiTermSideBySide\_Repair2009.cmd

BTW, this is not really the correct topic, as you report a bug for MT 2009, while this topic is about MT 2007 or even MTiX


Direct link Reply with quote
 
translator-pl
Local time: 20:59
German to Polish
+ ...
The command <Repair MultiTerm 2009> worsened the problem... Jan 8, 2011

Many thanks for your reply!

Well, the thing turned out to be much more complicated. After I had used the command (Repair MultiTerm 2009), the following message appeared:

The activation could not be finished successfully. The following list describes the error details:

Problem executing command: C:\Windows\system32\msiexec.exe /f {A1CC3003-50E3-4EBA-965A-377250B576BF} /l*v "C:\Program Files (x86)\SDL\SDL MultiTerm\MultiTermSideBySide\Reinstalling 2009 core.log"

Problem executing command: C:\Windows\system32\msiexec.exe /f {6416EEE2-6332-45FC-B63B-8E14F8A73991} /l*v "C:\Program Files (x86)\SDL\SDL MultiTerm\MultiTermSideBySide\Reinstalling Studio 2009.log"

After I tried to relaunch MultiTerm, the following message appeared:

Die COM-Klassenfactory für die Komponente mit CLSID {…} konnte aufgrund des folgenden Fehlers nicht abgerufen werden: 80040154.

I un- & reinstalled MultiTerm, relaunched it again, no change at all - I still receive a blank input form. Moreover, as I tried to edit an etry in an existing termbase, I suddenly noticed in the right corner the following message:

Gesperrt von super seit 08.01.2011 00:00
Dieser Eintrag ist gesperrt, da er von einem anderen Benutzer bearbeitet wird.

I just can't believe it! Does anybody encountered the same problems? I would be grateful for any help!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:59
Member (2003)
Polish to German
+ ...
Your installation seems to be crap Jan 8, 2011

Please uninstall Side-by-Side tools and Multiterm, then install MultiTerm 2009 SP3 again.
Your problem is caused by Side-by-Side tools bein incompatible with your installed MT version.


Direct link Reply with quote
 
translator-pl
Local time: 20:59
German to Polish
+ ...
Re-installed MultiTerm 2009 crashed Jan 8, 2011

Thank you for your quick reply!

You're right, all of a sudden their versions might have been incompatible 'cause after I had re-installed and restarted MultiTerm, an automatic update was attempted. I interrupted the connection to the internet and deactivated the option of automatic updates.

Then I tried to open an existing termbase and edit or add a new entry. Unfortunately MultiTerm crashed and didn't response.

Is there something wrong with my MultiTerm 2009 installation file? May I ask SDL for a new one? Ultimately I've bought the SDL Trados Studio 2009 recently and cannot even use it properly.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:59
Member (2003)
Polish to German
+ ...
I cannot run diagnostics for your MT installation or installation file Jan 8, 2011

from remote.
However, if you re about this: uninstall the software, delete the profile files C:\Users\your_username\AppData\Roaming\SDL\SDL MultiTerm\8.5.0.0\BaseSettings.xml
C:\Users\your_username\AppData\Roaming\SDL\SDL MultiTerm\8.5.0.0\UserSettings.xml

Then use the "Run" funcntion in Windows and enter REgedit.
Go to HKEY_CURRENT_USER\Software\SDL and rename all keys that have something with MultiTerm or Studio in common.
Uninstall also Side-By-Side tools
Reinstall the complete software.


Direct link Reply with quote
 
translator-pl
Local time: 20:59
German to Polish
+ ...
Renaming keys? Jan 9, 2011

Please, could you explain what you mean by renaming all keys that have something in common with MultiTerm or Studio? Do you mean all SDL folders in the Registry Editor? Should they be renamed or deleted? Thanks in advance for your explanation.

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:59
Member (2003)
Polish to German
+ ...
Regedit Jan 9, 2011

rename these keys:
HKEY_CURRENT_USER\Software\SDL\MultiTerm8
HKEY_CURRENT_USER\Software\SDL\SDL MultiTerm
HKEY_CURRENT_USER\Software\SDL\SDL Trados Studio
HKEY_CURRENT_USER\Software\SDL\Studio1

For example change to _MultiTerm8 or similar.


Direct link Reply with quote
 
translator-pl
Local time: 20:59
German to Polish
+ ...
Problem solved Jan 10, 2011

Dear Mr Czopik,

thank you very much for your explanation and all your hints. At last I could solve the problem caused in effect by Java-Updates:

There were two another Java-Updates (16 and 23) installed on my PC. These updates were in conflict with the Java-Version (Update 14) used by MultiTerm 2009. After I had unistalled the new Java Updates and disabled the "Enable the next-generation Java plug-in" feature, my MultiTerm worked properly again.

I'm gald I can manage my terminology resources again. Once more, thank you very very much for your quick responses and hints!

Best regards
A. Chmielewski


Direct link Reply with quote
 

Maria Helena Brenner-Kelly
United States
Local time: 14:59
Member (2011)
English to Portuguese
Uninstalling Java update worked for me too Feb 10, 2012

Dear Chmielewski,

Just to thank you for your post re: uninstalling Java updates to put MT back to work. I did that, and it worked for me, as well.

Thanks,

Maria


Direct link Reply with quote
 

Allyson Larimer  Identity Verified
United States
Local time: 14:59
Japanese to English
+ ...
Reduce security settings Sep 25, 2013

I actually had the same problems but mine were solved by reducing Java security settings to medium and restarting trados.

Hope that helps.


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

MultiTerm: blank input form (no input fields)

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs