Mobile menu

TagEditor: Document has different languages than memory
Thread poster: ViktoriaG

ViktoriaG  Identity Verified
Canada
Local time: 20:36
English to French
+ ...
Mar 20, 2007

I used the forum search but it is so cluttered that I wasn't able to find the answer to my question, so here goes...

I am trying to translate RTF files with lots of tags in them. The logical thing to do is to use TagEditor. So, I set up a new TM for this project. When I open the document in TagEditor, I get that annoying error message that says that my document doesn't have the same languages as the TM and therefore, TM functions will be disabled. Now, I know the client is in the US, so I first set up the TM to be EN-US to FR-CA. That doesn't work. Then I thought that maybe the client specified Canadian English as source - so I created a TM EN-CA to FR-CA. Nope, that ain't working either.

Then, I opened my RTF documents, selected all and went Tools > Languages > Set language, to change the language of all the documents to EN-US. Then, I tried to use my EN-US to FR-CA memory with this - nope, still get the same boring error message.

The translation is due tonight. I use Trados 7.5.

Please help!

Thanks!

[Edited at 2007-03-20 17:57]

New information: when I look in the documents, before the actual text starts, I have loads of tags. Here is a sample of them:

> < GALIGNMENT "left" > < GMETHOD "proportional" > < G& "ENGLISH" >

Could it be that the documents are set as plain English, not EN-US or EN-CA? If this is the case (since I don't have the choice of plain English in Trados), how can I edit the tags in the RTF files so that the document is either EN-US or EN-CA? I really need to get going on this document...

Thanks!

[Edited at 2007-03-20 18:05]


Direct link Reply with quote
 

David Ryan Murúa
Spain
Local time: 02:36
Member (2005)
English to Spanish
+ ...
I have the same problem Mar 20, 2007

Dear Viktoria,

I was just about to publish a thread with a very similar problem, so, if you allow me, I will describe my problem too.

I received a file for review from a regular client in TagEditor format (AmEN into SP). When I open the TM (which is also set for AmEN-SP), I get the following message:

"The open translation memory has different languages than the document. Interaction with TM will be disabled until matching translation memory is opened"

This means that I not able to open/get or set/close in TagEditor. I can only open and close.

Why does this happen when languages are the same?

All help is appreciated.

Kind regards

David

I use Trados 7.0 (Build 615)


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 20:36
English to French
+ ...
TOPIC STARTER
InDesign Mar 20, 2007

The files I have to translate are InDesign files. I have them in RTF format. The files start with a bunch of tags, two fo which contain the word ENGLISH. I think it is these tags that cause the problem. Trados doesn't have English as a language, it only has EN-US, EN-CA, etc. Therefore, the language code in the RTF file is incompatible with Trados.

I am hoping someone will post here to tell me how to edit the language tags in the RTF files so they will be compatible with Trados. Maybe that is what you also need. However, if you don't have the RTF files for your translation, you may not have a choice but to contact your client to fix this. I, on the other hand, can help it as long as I find out pretty soon what language code to place in those two tags...

Let's hope we get a reply soon!


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 20:36
English to French
+ ...
TOPIC STARTER
Found it! Mar 21, 2007

This is very stupid, but here goes:

When you open your document in TagEditor and get the error message about the language problem and TM, close that message and then save your file as bilingual. Then close TagEditor, open TagEditor, open the document you saved as bilingual and voilà! I think that by saving it as a TTX file, TagEditor automatically overwrites the faulty information in the file and optimizes the file for editing with TagEditor.

This is plain stupid... I just wonder how, if this is so stupid, nobody posted this extremely simple solution. Beats me!


Direct link Reply with quote
 

David Ryan Murúa
Spain
Local time: 02:36
Member (2005)
English to Spanish
+ ...
Thank you... Mar 21, 2007

but it didn't worked for me. I followed your instructions and I still have the same problem. The thing is that the client sends me the file already converted in TagEditor but with the extension .isc., so we are probably in diferent causes to the same problem.
I've informed the client about my problem, so I'll see if they can help. If I get to solve this mistery, I'll let you know.

Kind regards and thanks for your support

David


Direct link Reply with quote
 

David Ryan Murúa
Spain
Local time: 02:36
Member (2005)
English to Spanish
+ ...
Solved it but Mar 26, 2007

I haven't found the reasons behind. The client sent me his memory and now everything works. I have to check the setting to see what differs from mine...

Regards

David Ryan


Direct link Reply with quote
 

Przemek Kalemba  Identity Verified
United Kingdom
Local time: 01:36
Member (2011)
English to Polish
+ ...
You're a genius! Dec 27, 2011

Victoria, you're a star! I had the same problem and your solution worked just fine for me. Many thanks!

BTW: Stupid technology! Stupid Trados!
But still: Thank God for Trados!

All the best & keep posting


Direct link Reply with quote
 

Marina Yartseva  Identity Verified
France
Local time: 02:36
French to Russian
+ ...
Another solution Oct 4, 2013

I had the same problem. I started working on a project yesterday and today TagEditor would tell me that my ttx has different languages... The solutions proposed above gave nothing, so I tried opening my half-translated target text, and TagEditor accepted its languages without any problem. I just saved it as a bilingual and continued translation from the place where I stopped yesterday.

I should add though that I'm working in Trados just for myself and don't need to deliver any memory etc to the client, so I don't know if my solution can cause any trouble here.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TagEditor: Document has different languages than memory

Advanced search


Translation news related to SDL Trados





Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs