Mobile menu

TagEditor - Can't switch to korean characters
Thread poster: Edith Goebel

Edith Goebel  Identity Verified
Local time: 22:37
German to Danish
+ ...
Apr 20, 2007


I'm asking on behalf of a friend, who just purchased Trados 2007 and succeeded installing it. I helped her getting started and Trados works perfectly together with Word. She is translating German-Korean, and in Word and in the TM there are no problems with the Korean characters.

But with TagEditor she can’t switch to Korean characters. In Edit-mode, when a new segment is opened, it is not possible to write anything in Korean, there are only German characters.

If she first opens a segment, then writes for instance xx, closes, and opens again, this xx can be changed in Trados Workbench using “edit translation unit” and here Korean characters are possible. So, this is a kind of workabout, but it is a bit time consuming and with a 60 k project it is not a good solution...
In TagEditor in the “Preview”-mode, it is possible to open segments too, and here Korean characters are possible too, but it is not the perfect place to work either.
It is possible to clean files translated like this, but the cleaned file only shows small boxes instead of Korean characters in Edit-mode, in Preview-mode, it is Korean.

I searched the forum, but couldn't find any help. The only non-western language enabled in the Microsoft Office Language Settings is Korean.

The problem is only in the "Edit"-mode in TagEditor.
Does anyone have an idea why?
And what can we do?

Thank you for any help

Direct link Reply with quote

Local time: 16:37
English to Korean
+ ...
I don't have any problem, so... Apr 20, 2007

I use both Trados 2007 full version and freelance version, and I have Korean, Chinese, and Japanese in my MS Office non-western language setting.

So far, I have not had any problems with Korean characters except Simplified Chinese. When I work into Simplfied Chinese, in the Edit mode, I need to click on a small "language box" that shows which input mode you use (there are several input modes in Chinese, and the said box will appear on TagEditor screen when your chosen language is Chinese) after I copy words/phrases from source segment and paste them to targe segment because when I "leave" the targe segment, the "language box" becomes inactive (it greys out).

My software specification is:
MS Windows XP Professional, MS Office 2003.
Is it different from your friend's?

Hope someone can help your friend solve the problem in the very near future. Good luck!

Direct link Reply with quote

Edith Goebel  Identity Verified
Local time: 22:37
German to Danish
+ ...
Solution found! Apr 23, 2007

Thank you for your comment, "overseas".

My friend has Windows XP Professional and Office 2003 too.

I found a way to trick the computer to write with korean characters:
Start -> Control Panel -> Regional and Language Options
Click the "Languages" tab and click "Details..."
Here we changed the "Default input language" to korean, and...

It works!

But I suppose the reason for this problem is, that she is translating a .rtf-file, and there are maybe some language settings in there, which prevented her from switching to korean characters.

But at least she can now translate normally with TagEditor.


Direct link Reply with quote

To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

TagEditor - Can't switch to korean characters

Advanced search

Translation news related to SDL Trados

Wake up in the Morning and see that you have sold TMs and made Money overnight

The TM Market Place for Translators
New: Our Instant TM Download
TM owners: Upload your TMs into the online database
Customers: Analyse your text & instantly download a text-specific TM
Well over 1.2 BILLION translation units

More info »
SDL MultiTerm 2015
Guarantee a unified, consistent and high-quality translation with terminology software.

SDL MultiTerm 2015 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2015 you can automatically create term lists from your existing documentation to save time.

More info »

All of
  • All of
  • Term search
  • Jobs