Loss of special characters after the segment is closed
Thread poster: Burrell

Burrell  Identity Verified
United Kingdom
Local time: 16:04
Member (2004)
English to Latvian
+ ...
May 26, 2007

I know this has been discussed endless times but I just cannot get my head around it, I fear I need and explanation for dummies.

I have a 10 000 word document with the usual problem - when the segment is closed, the special characters (Latvian in this case) dissapear and leave something unrecognisible instead.

I am a complete dummy when it comes to document formatting but as far as I can tell there is a lot of it there. I found a couple of paragraphs where the characters turn out ok, but most of the document useless.

I know I can move to TE, however I usually mark problematic words or phrases with special colours so that I know which questions go to Proz, my husband or a Latvian linguist. This is something as far as I know I cannot do in TE. So I would ideally want to use word.

Any help will be appreciated.

Techical info: Windows XP Standard, SDL Trados 2007, Word 2003.

Ines


Direct link Reply with quote
 

Uldis Liepkalns  Identity Verified
Latvia
Local time: 18:04
Member (2003)
English to Latvian
+ ...
Hi Ines, first try May 26, 2007

to switch Times New Roman to Arial or vice versa in source text BEFORE starting to use Trados (original document formatting allowing, of course, if your source document contains several typesets, you cannot do it- unless you're ready to reformat all manually once the translation is done). Has worked for me, but I met this problem only until Trados 6.5 included, I haven't experienced it with 7.0.

One more possible solution is (again, before starting to translate) to resave your document as *.doc or *.rtf accordingly- to the format it isn't now. Generally rtf is less affected by such glitches.

One more suggestion- if you don't need to deliver unclean file, you may want to try out MemoQ, presented on Budapest Conference. It's memory is Trados compatible and I have only the best testimonials from our translators who have tried it out on a real jobs. I myself haven't done it yet, but when I saw its interface in Budapest, I liked it very much.

It's downloadable from www.kilgray.com.

Uldis

[Rediģēts plkst. 2007-05-26 19:15]


Direct link Reply with quote
 

Vito Smolej
Germany
Local time: 17:04
Member (2004)
English to Slovenian
+ ...
My two cents on this issue May 27, 2007

I had (and still have now and then) this problem about characters, that disappear - or change to something useless.

Behind this all is the legacy of 8bit character sets, and the tug-of-war between the western1 and - in my case as well as yours Id say - central-European character set.

By now more or less all the font files are unicode-enabled, so it is - the way I understand the situation - NOT the question of the wrong font, its the question of a wrong (assumed, default, whatever) language.

I don't know if it really solves the problem, but heres my ways of fighting it:

i) save doc file as a unicode RTF - it's not a clear cut proposition, but it does not take much to try it.

ii) Tell word what's the language of the file (90% sure). There's some place in word, where the decision between different character sets is being made, and if the language of the file is assumed to be English for instance, you can keep fighting it but you will not win it.



[Edited at 2007-05-27 10:32]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:04
Member (2003)
Polish to German
+ ...
You will have to play with word styles May 27, 2007

Check with Word help, how to edit styles.
When you checked, select the style called "normal" or "standard" or similar in your language (style names are mostly localized, so I don't know the Latvian names). Change the language in this style to Latvian. If you see any Asian language there, stop now, come back here and tell me that. In such case check please, how many styles are defined in your document.
If you do not find any Asian languge, go on and do the same (language change) with all other styles (I mean literaly ALL!) Every single style in your document must have Latvian as language.
Close the style editing window.
Select the whole text (by pressing CTRL+A), go to Tools, Language (or similar - I have only German word) and select Latiav again. deselect automatic language recognition. If the document is longer, select "Do not spell check". Press OK. Should you have switched spell cheker off you will have to activate it for this part of the document, you are now translating. Otherwise with longer documents the spell checker will not work (to many errors). Now to get it workiung select only few pager, where you are now (one or two) and go again to Tools, Language. Now make sure Latvian is selected and deselect the option "Do not spell check". This will activate the spell checker for a part of teh document. When you finish this part, repeat the same procedure again (CTRL+A for the whole document, switch spell checker off, then select only a part of the documnt and activate spel checker only fo that part).
For 80% of all cases this should already help and no special character changes should occur anymore.
If you still have formatting issues, check, if the styles do match the local formatting of the text. In case of mismatching adapt styles to match the document.
Consider chaswitching to Tageditor, as there you can forget about all your trouble.

In case you wanna work with Word, but there was an Asian language defined in your document, come back here and tell me that. There is a slight possibility, I will be able to help even then.

Jerzy


Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 16:04
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
Did not work May 28, 2007

Thanks everybody! Unfortunately none of the suggestions worked. I changed language for every single style but the problem still persisted in most of the document even after I modified the style for the specific part. I would welcome more suggestions.

In the meantime it does seem I will have to move to TE but I honestly dislike it - I cannot use spell check there, it is visually confusing and generally consumes more time than word.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:04
Member (2003)
Polish to German
+ ...
Any Asian language there? May 28, 2007

Do the styles match the formatting?
What is the font of your corrupted characters? Is this an Unicode font? Does it exist in your PC?

You can use Word spell-checker in Tageditor. If you are able to spellcheck in Word, you'll be able to do so in Tageditor.

Please answer my questions, then we shall see further.

Jerzy


Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 16:04
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
Not sure but... May 28, 2007

Jerzy Czopik wrote:

Do the styles match the formatting?
What is the font of your corrupted characters? Is this an Unicode font? Does it exist in your PC?

Jerzy


I am not sure but I think they do not (at least not in all cases). For example, the style says "Times New Roman 12" but the actual text is Arial 10.
When I close the segment it becomes Times New Roman. Both Arial and Times New Roman are addopted for Latvian and normally do not gove me any trouble.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:04
Member (2003)
Polish to German
+ ...
Please check, if all fonts used in the document are installed on your system May 28, 2007

Please go to Tools, Options, Compatibility and press the "Replace font" button there (or similar, my Word is German).
When you find fonts listed there, then try to replace them by something like TNR or Arial.

Do you have any Asian language in your text?
If you select such corrupted character, what font is shown?

Would you send me the file? If yes, my email is info at doku minus trans dot de.

Jerzy


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:04
Member (2003)
Polish to German
+ ...
The file in question is the reason May 28, 2007

The file looks like an expoert from PDF, containing tons of styles, which also have fonts for latin and complex characters. On top there are strange fonts used, which are not installed.
When Trados finds such uninstalled font, it replaces it with a font of the same name, but an "CE" extension, in order to reproduce special characters for slavic languages. But also this font is not existent in you PC. Because Word per default replaces all unavailable fonts with available ones, without telling you that, it does the same with the new font, "generated" by Trados. Now, the font is assumed to be the one for complex characters (for latin it wouldn't need the CE extension), so Word takes a font, able to show double byte characters (complex font, as Arial Unicode MS or SimSun or similar), but the encoding does not fit, and so the story goes.
This is not an exact description of what exactly happens, but just my interpretation of what I can see, when I encounter similar problems.

You have two possibilities:

  • Remove all formatiing from the file with saving it as plain text. The text is English, so you will not need to change any characters. Then open the text in Word, reformat what was bold and with different font size (I would say you'll ned half an hour for all this operations, not more). Then save it as doc and start translating. Don't forget to assign Lativan language to the document.
  • Go for Tageditor and forget abou all formatting problems.


Jerzy


Direct link Reply with quote
 

Burrell  Identity Verified
United Kingdom
Local time: 16:04
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
Thanks! May 28, 2007

OK, thanks, Jerzy! At least I know there is nothing to be done. I actually told the client in the very beginning that all I can do it remove all formatting but so far I have not had back an answer. I guess it will have to be the Tag Editor.

Thanks again!

Ines


Direct link Reply with quote
 
Iulia Anania  Identity Verified
Romania
Local time: 18:04
English to Romanian
+ ...
old classic issue Jul 6, 2007

I hope this info will help, sorry I got so late on this page:

http://www.translationmemory.ru/support/faq/911.php


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Loss of special characters after the segment is closed

Advanced search







PDF Translation - the Easy Way
TransPDF converts your PDFs to XLIFF ready for professional translation.

TransPDF converts your PDFs to XLIFF ready for professional translation. It also puts your translations back into the PDF to make new PDFs. Quicker and more accurate than hand-editing PDF. Includes free use of Infix PDF Editor with your translated PDFs.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs