Mobile menu

Term recognition not working in Workbench
Thread poster: Astrid Elke Witte

Astrid Elke Witte  Identity Verified
Germany
Local time: 17:10
Member (2002)
German to English
+ ...
Jul 5, 2007

I unfortunately had to reinstall Multiterm 2007 yesterday evening, after the browse pane and project pane became detached and I could not put them back into place, because the entry pane had moved over to the left-hand side, and could not be moved back to the middle. I reinstalled Multiterm empty, and imported back my termbases, one by one.

Now today I cannot translate with Workbench without disabling term recognition, and I really do need term recognition.

I have read everything previously written on the subject. I cannot select the languages in Workbench, because the language choice boxes are empty, and no languages can be selected.

I am getting these errors when I open a TU:

"(-2147467261): null"

and

"(-2147024894): Das System kann die angegebene Datei nicht finden."

I am sure these errors would go away if I could only select the languages in Workbench. I have just uninstalled and reinstalled Workbench, but the fault remains. So my question is, "How do I regain the option to select the languages?" (in particular if reinstalling the program has no impact).

Astrid


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 17:10
Member (2003)
Polish to German
+ ...
Chose only one termbase first Jul 5, 2007

But before you start doing something in Workbench, close all Trados applications and register them. To do so go to SDL Trados program group and let the "Register SDL Trados 200x" run. Then open Windows Explorer, navigate to Multiterm installation folder (C:\Programme\SDL International\MultiTerm 2007\#_SelfRegister_Desktop.bat) and let this file "#_SelfRegister_Desktop.bat" run.

After you finished I hope your MT installation will work.
Should it still deliver errors, check with this error number on SDL Support page (support.sdl.com)

Jerzy


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 17:10
Member (2002)
German to English
+ ...
TOPIC STARTER
The problem didn't go away... Jul 5, 2007

Thanks for your prompt answer, Jerzy! Unfortunately the problem didn't go away, so a couple more reinstallations and a couple more fresh errors (e.g. Workbench open and the error "Workbench not running" as I tried to open a TU), and now it is working again, but I don't know if that is the end of the problems, because it was already working again once today, until I closed it and opened it again later!

I'll finish this translation now, and see if everything is still working again tomorrow.

Best regards,

Astrid


Direct link Reply with quote
 

Nora Diaz  Identity Verified
Mexico
Local time: 09:10
Member (2002)
English to Spanish
+ ...
In Windows Vista, User Account Control may be to blame Jul 5, 2007

Hi, Astrid,

Among the many things I tried to get Multiterm to work with Workbench and Word in Windows Vista, I disabled UAC - User Account Control, and that did the trick.

This simple change allowed Multiterm to work properly (including adding terms to the termbase from within Word).

Hope it helps!

Nora


Direct link Reply with quote
 

Alicia Casal  Identity Verified
Argentina
Local time: 13:10
Member (2005)
English to Spanish
+ ...
In My case Jul 5, 2007

It' s not working because I need Multiterm*.dot to appear in the start menu: I mean, Multiterm is not correctly installed.

Im using XP.

A.


Direct link Reply with quote
 

Witold Chocholski  Identity Verified
Poland
Local time: 17:10
English to Polish
+ ...
The same problem, slightly different error number... Jul 5, 2007

Astrid Elke Johnson wrote:

I unfortunately had to reinstall Multiterm 2007 yesterday evening, after the browse pane and project pane became detached and I could not put them back into place, because the entry pane had moved over to the left-hand side, and could not be moved back to the middle. I reinstalled Multiterm empty, and imported back my termbases, one by one.


I am getting these errors when I open a TU:

"(-2147467261): null"

and

"(-2147024894): Das System kann die angegebene Datei nicht finden."



I have just installed Multiterm 2007 and Trados Freelance 2007 and while setting the Terminology Recognition Options in Workbench I don't even have Multiterm 2007 available. When I try Multiterm 7, an error occurs: (-2147467259). System: Windows XP.

Anyone has overcome that?


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 17:10
Member (2002)
German to English
+ ...
TOPIC STARTER
Yes, had that error number as well Jul 6, 2007

That is the "illegal index" one. I had that problem, too, when I installed Multiterm 2007 and Trados Freelance 2007 for the first time.

Try uninstalling them both again, and then install Multiterm first, but empty, not taking over the databases. They will be there in their place where they are stored on your computer, ready for you to import them back into Multiterm after the installation. You install Trados Freelance 2007 last.

I have solved yesterday's problems now. Thanks to everyone who helped.

Astrid


Direct link Reply with quote
 
xxxOptiproz Pri
Local time: 17:10
English
(-2147467261): null Jul 6, 2007

It looks like the registry key is not showing the path to the termbases.

Solution for Windows XP:
1. Make first sure if the Termbase folder path is C:\Documents and Settings\All Users\Application Data\SDL International\MultiTerm\Termbases\ and the "MTMaster.mdb" is placed in.
2. Copy this path
3. Open START --> Run..
4. Type in: regedit
5. A window opens
6. Now goto: HKEY_LOCAL_MACHINE --> SOFTWARE --> TRADOS --> MultiTerm --> ServerDataBaseInfo
7. At the right window you now must see:
(Standard)
Location
MasterDB
TemplateFile
8. Double click on Location and a new window will open.
9. There you should be able to paste your copied path C:\Documents and Settings\All Users\Application Data\SDL International\MultiTerm\Termbases\ to your MTMaster.mdb (Please
don´t forgot the backslash at the end of the path)
10. Close the Registration Editor
11. Now open Word again
12. When you click on select Termbase the window will open
13. Click on the "+"
14. Now you should be able to see your termbases

Solution for Windows Vista:
1. Make first sure if the Termbase folder path is C:\Users\\AppData\Local\VirtualStore\ProgramData\SDL International\MultiTerm\Termbases\ and the "MTMaster.mdb" is placed in.
2. Copy this path
3. Open START --> Run..
4. Type in: regedit
5. A window opens
6. Now goto: HKEY_LOCAL_MACHINE --> SOFTWARE --> TRADOS --> MultiTerm --> ServerDataBaseInfo
7. At the right window you now must see:
(Standard)
Location
MasterDB
TemplateFile
8. Double click on Location and a new window will open.
9. There you should be able to paste your copied path C:\Users\\AppData\Local\VirtualStore\ProgramData\SDL International\MultiTerm\Termbases\ to your MTMaster.mdb (Please
don´t forgot the backslash at the end of the path)
10. Close the Registration Editor
11. Now open Word again
12. When you click on select Termbase the window will open
13. Click on the "+"
14. Now you should be able to see your termbases

Regards


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 17:10
Member (2002)
German to English
+ ...
TOPIC STARTER
Thanks for the detailed explanation, Rykardo! Jul 6, 2007

I did actually have to install Multiterm and Workbench to the wrong folders when I re-installed them, because, when I tried to install them to the recommended folders, I kept getting messages saying that I had no administrator rights, even though I am logged on to my computer as administrator. In the end I managed to transfer them to the right folders afterwards.

Anyhow, thanks for providing such detailed information on how to fix this particular error. It will be very useful to many people who search the forum database concerning this error in future. It is very difficult to come by information on how to deal with these error codes, and there is also very little written about them on sdl's web site.

Best regards,

Astrid


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 17:10
Member (2002)
German to English
+ ...
TOPIC STARTER
User Account Control Jul 6, 2007

Hi Nora,

Thanks for the tip about User Account Control. I have disabled it now again. I wanted it disabled actually, but the computer man who came last week seems to have enabled it again.

Astrid


Direct link Reply with quote
 

Witold Chocholski  Identity Verified
Poland
Local time: 17:10
English to Polish
+ ...
(-2147467259) Jul 6, 2007

Astrid Elke Johnson wrote:

That is the "illegal index" one. I had that problem, too, when I installed Multiterm 2007 and Trados Freelance 2007 for the first time.

Try uninstalling them both again, and then install Multiterm first, but empty, not taking over the databases. They will be there in their place where they are stored on your computer, ready for you to import them back into Multiterm after the installation. You install Trados Freelance 2007 last.

Astrid


Thank you for tips.
Unfortunately, that hasn't helped. Did you uninstall Synergy and SDLX as well? I have re-installed everything following your advice but the problem persits. Did you try that once or several times?

Regards
Witold


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 17:10
Member (2002)
German to English
+ ...
TOPIC STARTER
Illegal index problem Jul 6, 2007

Hi Witold,

Yes, I uninstalled Synergy and SDLX again as well. It seems that Multiterm must be in place first, but you have to say "No" to the question about taking over the termbases, because the termbases from the previous version (7) are not compatible with the 2007 version. You have to have Multiterm entirely empty to begin with.

You then create a new framework (Termbase Definition), import the first database and then test it out.

To test it out, in Trados Translators Workbench you have to activate Term Recognition and then select "Term Recognition Options" and choose that termbase that you just imported, as one that should be recognised/linked.

Once you have selected it, you should then see languages appear in the source and target language boxes underneath. If these are the wrong way round, you have to correct the languages. If you do not, then you will definitely get the "illegal index" error. However, there will be no languages in these boxes until you have selected at least one termbase, which you have previously imported into Multiterm, into a new Termbase definition.

The error codes that I was complaining about yesterday are related to the same problem. In that case, I first got the "illegal index" problem again. My problem was, however, that there were no languages showing in the boxes and I could not select any. It turned out to be due to an installation error.

Best regards,

Astrid

P.S. Reorganising termbases is also reputed to clear the "illegal index" error, but, if you start off with Multiterm empty, and newly import them, they are at that point automatically reorganised.

[Edited at 2007-07-06 21:37]

P.P.S. The "illegal index" error can also occur/continue to occur if you have either duplicate or incomplete entries in your termbases. Therefore, you have to import a single termbase and then do a search, using the appropriate option from the menu, for duplicate entries and incomplete entries. You have to manually delete each of these found.

[Edited at 2007-07-06 21:48]


Direct link Reply with quote
 

Witold Chocholski  Identity Verified
Poland
Local time: 17:10
English to Polish
+ ...
Problem gone Feb 16, 2008

It was not possible to solve it in aby other way but only a disk format and after installing the system from scratch. Even the SDL support didn't help.

However, after a few months of very good operating, another problem occured with MT. It is extremely irritating. Why such expensive software with such little features (for the price) is so faulty? It is a different story anyway...


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 17:10
Member (2002)
German to English
+ ...
TOPIC STARTER
Problems with Multiterm Feb 16, 2008

There are a lot of problems with Multiterm. I notice, for example, the following:

1. If the TU is fairly large (as it often is with sentences in German legal documents), Multiterm does not recognise more than (at the most) 50% of the terms that are in the termbase, so the other terms have to be typed manually each time - and it is almost always the most common terms in that particular translation that are left out.

2. If you are using a list of different termbases for that translation, you are supposed to arrange them, in Workbench, in the order that you want them to be searched.

If I have an exactly matching term in one termbase, sometimes a different, only similar term, from a different termbase, is recognised instead.

Initially I thought that this was the case because I had given the termbases the wrong priority in Workbench. However, when I changed them round, the problem remained.

For these two reasons, there is not too much practical sense in building up extensive termbases, as it is a great investment of time and the software cannot presently handle it.

Astrid


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Term recognition not working in Workbench

Advanced search


Translation news related to SDL Trados





Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs