Mobile menu

Dragon won't start with a capital in Trados
Thread poster: maryrose
maryrose  Identity Verified
Local time: 05:23
English
+ ...
Aug 9, 2007

Hi everyone

I have seen the previous post on this problem. The answer proposed was to make sure "hidden text" wasn't ticked, but mine never is.

What's weird is that Dragon is quite quixotic about this - sometimes it starts the first sentence of a new segment with a capital and sometimes not. I should say, some sessions it does and some sessions it doesn't. Yesterday it capitalised, today it doesn't. I don't think there's anything I'm doing differently from one day to the next, but clearly something's wrong.

Does anyone have any ideas about this? I know you can say "Cap" at the beginning of every segment, but it's easy to forget and anyway you shouldn't have to.

Thanks a lot
Maryrose


Direct link Reply with quote
 
Richard Walker
Local time: 04:53
Japanese to English
Lack of resources? Aug 11, 2007

I find that if Dragon cannot summon up enough system resources, say because I've used a lot of other resource-intensive programs since the last reboot, it starts to treat Word like any other program. For programs that it knows, Dragon has lots of tools and tricks for making dictation a pleasurable experience, but for all the others (for example, TagEditor or the editing window for this forum), it basically just emulates a keyboard, sending out keystrokes with little or no recognition of where it is in relation to anything else. That is why you don't get capitalization at the beginning of a TagEditor unit; Dragon has no way of knowing that it is at the beginning of something.

Could this be what is happening to you? You aren't getting capitals in Word because Dragon has failed to get all of its hooks into the program and therefore has no idea it is at the beginning of a line.

Here's a test that works for me. Make sure Word has smart quotes turned on. Dictate some text with Dragon that includes a quotation mark or apostrophe. If all of the Dragon add-ins for Word are functioning, you should *not* get curly quotes since Dragon hates them. If, on the other hand, Dragon is merely sending blind keystrokes, you will get curly quotes because as far as Word is concerned you are typing.

The only reliable cure I know is to restart the computer.


Direct link Reply with quote
 
maryrose  Identity Verified
Local time: 05:23
English
+ ...
TOPIC STARTER
Could be! Aug 12, 2007

[quote]Richard Walker wrote:

I find that if Dragon cannot summon up enough system resources, say because I've used a lot of other resource-intensive programs since the last reboot, it starts to treat Word like any other program.


Sorry, Richard, I clicked "post" prematurely.

Thanks for your very comprehensive response. I don't actually use TagEditor, but I think your explanation is very plausible anyway. The very erratic nature of this problem suggests that it depends on different circumstances on different days. The last two days it has operated fine, for example.

I note the suggestion about curly quotes; however, no matter what I do, I can never get Dragon to make curly quotes when I want it to, so I don't think this one will work for me.

Next time I'll just reboot.

Thanks a lot .

Maryrose

[Edited at 2007-08-12 06:59]


Direct link Reply with quote
 
Richard Walker
Local time: 04:53
Japanese to English
Curly quotes Aug 12, 2007

Dragon shouldn't make curly quotes for you. If it does, then you know something is wrong, ie it's no longer communicating natively with Word so Word thinks it's getting input from the keyboard and responds accordingly, automatically curling the quotes as if you had typed.

Direct link Reply with quote
 
maryrose  Identity Verified
Local time: 05:23
English
+ ...
TOPIC STARTER
I want curly quotes! Aug 12, 2007

OK, right, I get that, but I just wish it would!

Thanks again.

Maryrose


Direct link Reply with quote
 
Richard Walker
Local time: 04:53
Japanese to English
There is a way Aug 12, 2007

...if you're not scared off by a little code.

This macro will curl quotes in the current paragraph:

Sub CurlQuotes()
Options.AutoFormatAsYouTypeReplaceQuotes = True
Selection.Paragraphs(1).Range.AutoFormat
End Sub

Put it in the VBA editor and try it out. Now, if you want to have curly quotes in all of your dictated Trados projects, you simply need to make sure that this macro runs before you close the unit.

In the VBA editor, right below the CurlQuotes macro, add another macro:

Sub MySetCloseOpenGet()
CurlQuotes
Application.Run "tw4winSetCloseOpenGet.Main"
End Sub

You have now created a macro that will act exactly like alt+Num+ except that it curls quotes for you first. If you want, you can reassign alt+Num+ to the new macro and things will work like they always did, only curlier. Or, if you have Dragon Pro, you can assign the new macro to a voice command and forever leave behind the Trados dance to the number pad. (When typing into Trados, it always felt a bit Flamenco to be darting over there all the time...)

The same technique works with any of the Trados macros. In the list of available macros that Word presents you (Tools>Macros>Macros), find the ones that start with tw4win plus a descriptive name. In pre-2007 versions of Trados, you will always want to follow them with ".Main". So, just copy the MySetCloseOpenGet macro above, give it a new name and replace the "SetCloseOpenGet" bit as appropriate.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Dragon won't start with a capital in Trados

Advanced search


Translation news related to SDL Trados





TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs