Mobile menu

TagEditor and XML files
Thread poster: Domenica Nieddu

Domenica Nieddu  Identity Verified
United States
English to Italian
+ ...
Aug 16, 2007

Could somebody help me, please?

I have not had this kind of problems for a long time and if I was able to solve it in the past, now I do not remember what I did. The client sent me some strange xml files with "Source" and "Target" codes. When I try to work with TagEditor, all the text is double (source and target) plus the message I get when I use the DTD settings is "This document contains the unknown declaration/root element "xliff"..." and it asks me to specify the settings again. What should I do? The client's office is closed now and I have to start working. Basically I have to problems: 1) How to eliminate the duplicate text which is already in the xml (source and target) files and 2) how to convert in TagEditor the xml files without error messages. I tried to create a new .ini file but I get the same message and duplicate text. Thanks, Domenica

I have Trados 6.5


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 09:12
Member (2003)
Polish to German
+ ...
Did you try to generate "ini" using the settings wizzard in Tageditor? Aug 16, 2007

When using this wizzard, you MUST select all xml files, which will be then translated.
But what I don't understand is, how a monolingual file can get duplicated and create a source and target field?

Jerzy


Direct link Reply with quote
 

Domenica Nieddu  Identity Verified
United States
English to Italian
+ ...
TOPIC STARTER
TagEditor and XML files Aug 16, 2007

Thanks for your answer. I did not know that all the files to be translated have to be included in the Wizard when creating a .ini file (where exactly?). However, I am thinking that the problem is in the original XML files as they are already segmented (have a source and target code with repeated text). I do not why the client created those kind of bilingual files. Any way to get rid of the duplicate text (source and target)? Thanks, Domenica

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 09:12
Member (2003)
Polish to German
+ ...
Wizzard: step two, button "Import" Aug 16, 2007

When you click this button, an explorer window appears, where you need to chose your xml files for translation. Then follow all the steps, chose one root element and you should be done.

To remove the segmentation (source/target) from your xml files: transform them all to ttx. Create a new empty TM in the corresponding language pair and cleanup them. Then you will have only the "target" - but when not pretranslated, then it is identical to source. If pretranslated, you will need to "translate" the files back with a TM, which you get by reverting the one, with which you now cleaned the files.

Jerzy


Direct link Reply with quote
 

Domenica Nieddu  Identity Verified
United States
English to Italian
+ ...
TOPIC STARTER
TagEditor and XML files Aug 16, 2007

I am sorry, Jerzy, but I could not perform the steps you mentioned. I do not see the "import" command under DTD settings manager in TagEditor (Wizard) and nothing changed when I tried to clean the bilingual xml files (after ttx conversion) with a brand new memory (the files have still source and target text). Could you explain it to me again step by step? I am not very used to dealing with these kind of files. Usually the files I translate in TagEditor are ready for translation. I apologize. Thank you. Domenica

I have Trados 6.5.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 09:12
Member (2003)
Polish to German
+ ...
OK, Trados 6.5 maybe the problem Aug 16, 2007

I do not remember, how the Tag settings wizzard in Trados 6.5 was. But I'm afraid with that version you will not be able to create your own ini settings in the way I mentioned.

As for the cleanup - the ttx files remain billingual, of course, but your xml files are monolingual. I simply assumed you did not have monolingual xml files - the files you get after cleaning ttx are monolingual xml files.

I'm afraid you will need to wait until tomorrow and ask our customer for help.

Jerzy


Direct link Reply with quote
 

Domenica Nieddu  Identity Verified
United States
English to Italian
+ ...
TOPIC STARTER
TagEditor and XML files Aug 16, 2007

Thank you so much. I will simply ask the client tomorrow to provide new files. Best regards, Domenica

Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TagEditor and XML files

Advanced search


Translation news related to SDL Trados





LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs