Mobile menu

How to assign non-translatable text in Word for import into TagEditor 8.0?
Thread poster: Carsten Behrend

Carsten Behrend  Identity Verified
Germany
Local time: 09:10
English to German
+ ...
Sep 2, 2007

Dear ProZianers!

Settings: Win XP SP2, SDL Trados Freelance 8.0.0.820 (Build 820), Office 2003 SP2 (11.8134.8132)

I have a word file I want to process in TagEditor. There are some tables in the file which denominate illustrations. The client wanted me to setup tables with the lefthand side containing the source language and the righthand side containing the target language. So I designed the tables. I assigned the Word style DO_NOT_TRANSLATE to the left column and filled in the source text into the target column with the Standard style assigned. So I thought, TagEditor would jump over the cells in the left hand and call up the right hand. Unfortunately, I did not as expected and addressed both cells, the left and the right ones.

Is there another way to circumvent the lefthand sight of the table cells?

[Edited at 2007-09-02 15:19]


Direct link Reply with quote
 

Jabberwock  Identity Verified
Poland
Local time: 09:10
Member (2004)
English to Polish
Copy and paste? Sep 2, 2007

I think the easiest way would be to copy the document to another file, delete the first column, translate it with TagEditor and copy the translated column to the original document.

Direct link Reply with quote
 

Carsten Behrend  Identity Verified
Germany
Local time: 09:10
English to German
+ ...
TOPIC STARTER
Elegant approach Sep 2, 2007

Dear Jabberwock,

I very much appreciate your quick reply. Certainly, it is the easiest way to solve the problem. The thing is, the tables are running over 4-5 pages and it is not convenient to copy and paste them. I would like to have everything in one (big...) file and I'd rather abstain from creating several subfiles and jerking around with them.

Additionally, I remember this DO_NOT_TRANSLATE approach and there must be some similar gadget in TagEditor to force the application to ignore predefined tags, although they contain translatable text.


Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 09:10
Member (2005)
English to Czech
+ ...
Should work with the DO_NOT_TRANSLATE style, I think Sep 2, 2007

I haven't tried; but the Word importing into TagEditor is controlled by the file
Program_Files-SDL_International-T2006_FL-TT-Word_1_0_0_0.xml (I replaced backslashes with dashes in the path) and lines 110 + of this file seem to indicate it should work.

HTH
Antonin

[Edited at 2007-09-02 18:45]


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 09:10
English to Dutch
+ ...
rtf Sep 2, 2007

another way


As far as I know, skipping translation by paragraph styles only works for rtf.
If you save your doc as rtf, you can define the paragraph style in use (which in a table is probably absent though) as non-translatable in the TM's setup.
You could as well apply the tw4winexternal style to make the Workbench skip it. (Again: rtf. This style needn't be defined as non-translatable.)

All in all, Jabberwock's approach might be the fastest way of getting the thing done.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 09:10
Member (2003)
Polish to German
+ ...
Easy way Sep 2, 2007

First make sure, Trados styles are present in the document.
(I mean the especially the tw4winexternal)
If they aren't, press ALT+F8, put "sa" in the macro name field, select the macro "sAddTagStyles" and let it run. This will ad the Trados styles to the document.
Now set the tables as required, than select the left column and assign "tw4external" style to the text in the table - this will certainly be skipped by Tageditor.

Another way: make the text hidden. This is the most simple solution I know, which works for me perfectly well, if I do hide the text not using any styles. Just select the text which shall not be translated and make it hidden via character format option.

HTH
Jerzy


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to assign non-translatable text in Word for import into TagEditor 8.0?

Advanced search


Translation news related to SDL Trados





TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs