Mobile menu

How to replace the old ini with new one in ttx
Thread poster: Meicy
Meicy
Local time: 11:42
Chinese
Oct 13, 2007

Hello everyone,

Thanks for your time reading my message.

I translated 1.xml with a.ini created by myself and saved the translated file as 1.xml.ttx used TagEditor, but all of line in cleaned 1.xml file displayed as a line.

Later on, I found that was because I didn't select "Keep all line breaks" when I created a.ini. (TagEditor>DTD Setting>Elements>Advanced>Display Options>Keep all line breaks)

I updated a.ini to have "Keep all line breaks" selected. It works when I open a new xml with this updated a.ini - all of line displayed correctly with line break as I expected.

However, lines still displayed as a line when I opened and cleaned the translated 1.xml.ttx used the updated a.ini.


My questions are:
1. How to apply the new setting of updated a.ini to translated 1.xml.ttx?eg, to enable the setting of "Keep all line breaks"

2.Is it okay to keep all line in one line in translated xml? as all of content can be displayed correctly with the same structure of English xml in web browser.


You help is much appreciated.


Regards,
Meicy


[修改时间: 2007-10-13 04:25]

[修改时间: 2007-10-13 04:27]


Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 05:42
Member (2005)
English to Czech
+ ...
tweak the ttx Oct 13, 2007

In a notepad-like editor, or a special xml editor, change the

SettingPath=

There is also

SettingsName=

I do not think it has any other role than a descriptive name, so I suppose you vcan put anyhting in this setting.

HTH

Antonin


Direct link Reply with quote
 

Marina Soldati  Identity Verified
Argentina
Local time: 00:42
Member (2005)
English to Spanish
+ ...
Open 1.xml again Oct 13, 2007

Hi Meicy,

Why don´t you open the original (source) 1.xml with the new ini, translate it to fuzzy and save it 1.xml.ttx again (to overwrite your existing 1.xml.ttx).

I think this will solve your problem.
Regards,
Marina


Direct link Reply with quote
 
Meicy
Local time: 11:42
Chinese
TOPIC STARTER
Thanks for your help, Antonin and Marina Oct 13, 2007

Hi Antonin,

Thanks! I tried to delete the ini setting in ttx used notepad as the way you suggested, and reselected the new ini (with Keep all line breaks) when I opened that ttx with a prompt to ask for DTD setting in TagEditor, but the setting of Keep all line breaks still didn't work. I guess this setting - Keep all line breaks does not take effec unless it is selected before starting translation.


Hi Marina,
Thanks! I think it is the last and most sesure method, but I'm still considering it as it will take some time to recheck all retranslated files to ensure everything is applied correctly (for 120,000 words translated and reviewed).


Hi both and anyone who knows it,
Do you know if it is acceptable in development with the translated xml files that displayed as one line in notepad, but displayed as same structure with English one in browser?

In my previous projects, the translated xml files that have slightly different number of line with the original English xml could be accepted. eg, some of lines in English xml shown as one line in the translated xml file viewed as notepad.

I think it might be acceptable in the build as long as xml can be displayed properly in brower, but I don't have enough technical backgroud to ensure it. Any comments are welcomed!



Thanks,
Meicy

[修改时间: 2007-10-13 16:59]


Direct link Reply with quote
 

Stefan Gentz
Local time: 05:42
English to German
+ ...
It depends on the client's xml parser Oct 18, 2007

Meicy wrote:
Do you know if it is acceptable in development with the translated xml files that displayed as one line in notepad, but displayed as same structure with English one in browser?


Meicy, from a strictly technical point of view this is acceptable. However, if all the xml is in one line, this can cause serious problems for the xml parser that has to read your translated xml file - especially if the xml file is that big.
You can try to open the cleaned, translated xml file again in tag editor - you will notice, that the translated xml file will take much longer to open. It can even be that you cannot open the file at all or will have to wait a few hours...
Regarding the possilbe (and actually most likely) problems, it is not acceptable, from a client's perspective, - especially not as it was your faulty setting that caused the problem.

However, I'm wondering why clients who give you a 120,000 word xml job for translation do not care about the translation process and let you alone with creating the necessary ini file on your end - you are obviously not an xml specialist but a translator. This is an absolutely irresponsible attitude of your client's project manager.

I think it might be acceptable in the build as long as xml can be displayed properly in brower, but I don't have enough technical backgroud to ensure it. Any comments are welcomed!


Don't mix things here. The parser of the software on client side will have to read your xml - and not your Internet Explorer.

Kind regards,
Stefan Gentz

[Bearbeitet am 2007-10-18 21:40]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to replace the old ini with new one in ttx

Advanced search


Translation news related to SDL Trados





SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs