Mobile menu

Problems cleaning up excel files in TagEditor
Thread poster: Brigitte Hamilton

Brigitte Hamilton  Identity Verified
Canada
Local time: 15:24
Member (2007)
German to English
Nov 8, 2007

I received an xlt.ttx file from the client, for translation in TAgEditor. There are no problems with the file, except when I try to clean it up (either 'save target as' or using the clean up function in workbench).

The error message in workbench simply says - server application error, unable to case COM object of type

whereas trying to save it in target in TagEditor produces the following message:

connection with server application error: Unable to cast COM object of type 'System,_ComObject' to interface type 'Trados.Interop.Excel.Worksheet'. This operation failed because the QueryInterface call on the COM component for the interface with IID (bunch of numbers) . failed du to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).

I use Trados 2007 and Excel 2007.

Can anyone help, thanks.


Direct link Reply with quote
 

Pavel Blann  Identity Verified
Czech Republic
Local time: 21:24
Member (2005)
English to Czech
I think... Nov 8, 2007

...you got to have the original excel files in the same directory as the ttx files in order to use "save target as"

cheers,
pavel


Direct link Reply with quote
 

Brigitte Hamilton  Identity Verified
Canada
Local time: 15:24
Member (2007)
German to English
TOPIC STARTER
I do... Nov 8, 2007

... have them in the same folder (contains source files and translated files), so there should not be any issue there, I think.



Pavel Blann wrote:

...you got to have the original excel files in the same directory as the ttx files in order to use "save target as"

cheers,
pavel


Direct link Reply with quote
 

jmadsen  Identity Verified
Local time: 21:24
In my experience... Nov 8, 2007

it is important that you have the original and unedited excel files in the folder. If you edit the files manually and save them after having started the translation, Trados will not be able to clean up the files properly.

I may be wrong, but that's my best shot


Direct link Reply with quote
 

Brigitte Hamilton  Identity Verified
Canada
Local time: 15:24
Member (2007)
German to English
TOPIC STARTER
... Nov 8, 2007

Jørgen Madsen wrote:

it is important that you have the original and unedited excel files in the folder. If you edit the files manually and save them after having started the translation, Trados will not be able to clean up the files properly.

I may be wrong, but that's my best shot
..

Hi Jorgen - I was supplied with the original xlt file and xlt.ttx file by the client, and they are all in the same folder as the edited files (which are saved under different names but same extensions obviously). I am also working with their TM. Not sure what else I could be doing to ensure everything is in sync.....

[Edited at 2007-11-08 21:45]


Direct link Reply with quote
 

Pavel Blann  Identity Verified
Czech Republic
Local time: 21:24
Member (2005)
English to Czech
well... Nov 10, 2007


I do have them in the same folder (contains source files and translated files), so there should not be any issue there, I think.


...you can try putting the original xls file in another directory, open it in tageditor, save as ttx, autotranslate, and save target as xls.

if the problem persists pls report it as a bug to sdl.

good luck,
pavel


Direct link Reply with quote
 

Pavel Blann  Identity Verified
Czech Republic
Local time: 21:24
Member (2005)
English to Czech
also... Nov 10, 2007


I was supplied with the original xlt file and xlt.ttx file by the client, and they are all in the same folder as the edited files (which are saved under different names but same extensions obviously). I am also working with their TM. Not sure what else I could be doing to ensure everything is in sync.....


...I noticed your answer to jørgen: you should have source files in one directory and target files with exactly the same names in another directory. do not rename files when working with xlt - ttx pairs in the tageditor.

[Upraveno: 2007-11-10 11:12]


Direct link Reply with quote
 

Brigitte Hamilton  Identity Verified
Canada
Local time: 15:24
Member (2007)
German to English
TOPIC STARTER
Thank you Pavel... Nov 16, 2007

...you were right, I did not save them with exactly the same names. I am glad you pointed it out, as I likely would not have figured that out.:smile:

Thanks to everyone for your help.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problems cleaning up excel files in TagEditor

Advanced search


Translation news related to SDL Trados





LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs