Mobile menu

Excluding parts of Excel sheet from translation in TagEditor
Thread poster: Adam Podstawczynski

Adam Podstawczynski  Identity Verified
Local time: 05:23
Polish to English
+ ...
Jan 16, 2008

Hi,

TagEditor now supports translating Excel sheets, but is there a way to exclude certain parts (e.g. columns) of Excel sheet so that they are not "seen" by TagEditor, in the same way one does it with "DO_NOT_TRANSLATE" style in case of Word files?

Thanks in advance!


Direct link Reply with quote
 

Adam Podstawczynski  Identity Verified
Local time: 05:23
Polish to English
+ ...
TOPIC STARTER
mark them as hidden Jan 16, 2008

I'm sorry for responding to myself, but the solution is clearly described in the file Trados format reference guide.

All you need to do is to mark the unwanted fragments as "Hidden" or "Protected" before translating.

Adam


Direct link Reply with quote
 

Nicole Maina  Identity Verified
Italy
Local time: 05:23
Member (2005)
German to Italian
+ ...
can't make it work Jan 21, 2008

hi adam,

I have selected the cells, marked them as hidden, then protected the sheet. I tried opening the file with tageditor, but all cells are shown and the segments can be opened, so I must have done something wrong...


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 05:23
Member (2003)
Polish to German
+ ...
You do not need to protect the sheet, as this may cause additional trouble Jan 21, 2008

However, you should check your filter settings.
In Excel 2000-2003 (and possibly also on Excel 2007, if you use this program) settings the entry "Translate content from hidden rows and columns" must be deselected. Otherwise also hidden parts of sheet will be translated.


Direct link Reply with quote
 

Nicole Maina  Identity Verified
Italy
Local time: 05:23
Member (2005)
German to Italian
+ ...
what do you mean, Jerzy? Jan 22, 2008

I don't quite understand where to change the settings. In TagEditor? Which menu?

Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 05:23
Member (2003)
Polish to German
+ ...
No, not in Tageditor - in Filter Settings Jan 22, 2008

Go to your SDL International program group, open SDL Trados 2007 group and locate the Filters there (depending on your versions you may also have a subgroup Trados and then Filters). Open "Filter Settings".

You will see this window:



Adapt your settings accordingly, than it should work.


Direct link Reply with quote
 

Nicole Maina  Identity Verified
Italy
Local time: 05:23
Member (2005)
German to Italian
+ ...
still not working... Jan 22, 2008

hi Jerzy,

I have found the settings page, thank you for the explanations.

unluckily this setting was already deselected, so there must be something else wrong. is there any other way to work around this?

I have to translate a big excel file, where 75% of the cells have to remain untouched, and I have absolutely no idea how to do this


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 05:23
Member (2003)
Polish to German
+ ...
It works... Jan 22, 2008

are you sure you have "hidden" the cells/rows?

Would you mind sending me the file for a quick check?
My mail is inf at doku dash trans dot de.


Direct link Reply with quote
 

Jan Sundström  Identity Verified
Sweden
Local time: 05:23
English to Swedish
+ ...
Some tips... Jan 23, 2008

Nicole Maina wrote:
unluckily this setting was already deselected, so there must be something else wrong. is there any other way to work around this?


Note that you have to restart Trados to apply any changes to the Filter settings.
Also, you can't go back to any TTX that was created before the change, because the filters have already been implemented to that file. You'd have to create a new TTX and translate to fuzzy with your TM.

But if the setting was correct all along, I don't have a solution out of my hat. It doesn't sound like expected behavior to me

Are you sure the file is not protected anymore, and all irrelevant columns are hidden?!

/Jan


Direct link Reply with quote
 

Nicole Maina  Identity Verified
Italy
Local time: 05:23
Member (2005)
German to Italian
+ ...
thank you Jan Jan 23, 2008

the option was actually deselected, probably since installation. so I don't know what happened.

Jerzy finally solved the problem by hiding the single lines and columns which were not relevant. but this is of no use if you want to hide single cells or you want to show a single cell in a row and hide everything else.

I have just downloaded SP2, maybe this will help!! (?)


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 05:23
Member (2003)
Polish to German
+ ...
You cannot hide single cells with this method Jan 23, 2008

If you really need single cells hidden, the only way I see is copying to Word and there hiding the text in the corresponding cells. After that translating in Tageditor - this works.

SP2 has no impact on that, I'm afraid

Best
Jerzy


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Excluding parts of Excel sheet from translation in TagEditor

Advanced search


Translation news related to SDL Trados





memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



All of ProZ.com
  • All of ProZ.com
  • Term search
  • Jobs