Trados question: how can I make word spell check the target in target language and not source
Thread poster: Gismar zum Felde
Gismar zum Felde
Local time: 23:02
English to German
+ ...
Jan 20, 2008

hi!

basically what happens is that I have a document in german, so when I open a new translation segment and start typing away in english (for example) the automatic spell checker marks every word incorrect because ms word still thinks it's supposed to be german, only after awhile (but sometimes not) it changes the language to english and shows the real mistakes.

is there a way to have trados change the language automatically?? or am i doing something wrong?


thanks a lot


Direct link Reply with quote
 

Renée van Bijsterveld  Identity Verified
Netherlands
Local time: 04:02
Member (2007)
English to Dutch
+ ...
Change language setting for source doc Jan 21, 2008

or deactivate spell checking when you type.
I know, this is a very annoying habit, which didn't exist in previous versions of Word (97 if I'm correct).
When you first open a segment in f.i. a german document that you want to translate into your default language, say english, and you start typing, the text you type will be marked english. If however you use copy source (or copy any word from the source segment), the segment (or any text directly following this copied word) will be marked as german. After closing of the segment the segment will be marked as english. I've tried setting the language of the source doc to my default language, but this does not always work for the entire doc. So I guess the best thing is to deactivate spell checking when you type and to avoid copying the source. Maybe pretranslating (including segmentation of unknown segments) can help.


Direct link Reply with quote
 

Anthony Green  Identity Verified
Italy
Local time: 04:02
Italian to English
surely Trados can handle this?? Jan 21, 2008

ReneevB wrote:

or deactivate spell checking when you type.
I know, this is a very annoying habit, which didn't exist in previous versions of Word (97 if I'm correct).


This is surely just a programming bug. I find it hard to believe that it is very difficult for the SDL Trados programmers to pass a string to Word which tells it that the text being typed is the language of the TM.

This bug is compounded by the fact that after 5 or 6 words, MS Word then recognises the language you are writing in, but when you close the TU it reverts back to treating it as the source language!!! On a long text Word then spends a long time underlining each word and then says there are too many spelling mistakes to underline...

Anyone else feel this ought to take SDL less than a morning to sort out?

Anthony Green, Bari, Italy


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:02
Member (2003)
Polish to German
+ ...
Please have mercy Jan 21, 2008

This is not Trados, but Word!
When you tell Word to detect the right language and start translating, this will not work properly even without any CAT. Automatic language recognition is - among some other nasty Microsoft "helpers" - the biggest enemy of a translator. But most of us seem to forget that and trust Word exactly as it comes out of the box.

The solution for your problem is quite simple:
Start with assigning the proper language to the styles in the document. Make sure all styles do have your target language defined and the spell-checking is enabled there. Make also sure, that automatic language recognition is disabled. It is important.
Now select the whole document. Go to Tools, Language settings and select your target language. Deselect automatic language recognition and switch the spell checker off for now!
Now select only two-three pages, where you wanna work now and repeat the above remembering to switch the spell checking now on!
After you finished this part of the document repeat the whole procedure for the next part of your document.

This works always for any document with any oprtion you wish - CAT or no CAT.
Has nothing to do with Trados and so on. It is just Word and its (quite logical I think) behaviour in reaction on a foreign language.

PS
Please forgive me, if I may sound rude. It is not my intention.

[Edited at 2008-01-21 11:18]


Direct link Reply with quote
 

Anthony Green  Identity Verified
Italy
Local time: 04:02
Italian to English
Authoritative is very unlikely to be rude! Jan 21, 2008

Jerzy Czopik wrote:

The solution for your problem is quite simple:
Start with assigning the proper language to the styles in the document. Make sure all styles do have your target language defined and the spell-checking is enabled there. Make also sure, that automatic language recognition is disabled. It is important.
Now select the whole document. Go to Tools, Language settings and select your target language. Deselect automatic language recognition and switch the spell checker off for now!
Now select only two-three pages, where you wanna work now and repeat the above remembering to switch the spell checking now on!
After you finished this part of the document repeat the whole procedure for the next part of your document.


This is an excellent answer - thank you so much! We spend so much time with Word that we may think we know it inside out, but like a husband or wife, Word changes over the years and we often don't realise some of the more important changes going on!!

Your solution is logically great - but surely a properly functioning interface between Trados and Word could handle it too, without requiring us to do a manual workaround time after time. Or am I missing something?


PS
Please forgive me, if I may sound rude. It is not my intention.

[Edited at 2008-01-21 11:18]


goodness me Jerzy, as I wrote in the title your answers are very authoritative, so speaking for myself they are extremely unlikely to cause any offence.


Direct link Reply with quote
 

Wojciech Froelich  Identity Verified
Poland
Local time: 04:02
English to Polish
You are definitely missing Ando Tools :) Jan 21, 2008

Anthony Green wrote:

Your solution is logically great - but surely a properly functioning interface between Trados and Word could handle it too, without requiring us to do a manual workaround time after time. Or am I missing something?


You are definitely missing one useful package – Ando Tools You can easily correct the language-definition-mess introduced by Word.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados question: how can I make word spell check the target in target language and not source

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search